发布时间 :2006-03-13 14:34:00
修订时间 :2016-10-17 23:39:13

[原文]unalz 0.53 allows user-assisted attackers to overwrite arbitrary files via an ALZ archive with ".." (dot dot) sequences in a filename.



- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CWE (弱点类目)

CWE-22 [对路径名的限制不恰当(路径遍历)]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  FULLDISC  20060313 Secunia Research: unalz Filename Handling
(VENDOR_ADVISORY)  BUGTRAQ  20060313 Secunia Research: unalz Filename Handling Directory TraversalVulnerability
(UNKNOWN)  BID  17105
(UNKNOWN)  XF  unalz-archive-directory-traversal(25171)

- 漏洞信息

低危 输入验证
2006-03-13 00:00:00 2006-08-28 00:00:00

- 公告与补丁


- 漏洞信息

unalz Archive Processing Traversal Arbitrary File Write
Local Access Required Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

unalz contains a flaw that allows a remote attacker to write to files outside of the archive path. The issue is due to the program not properly sanitizing user input, specifically directory traversal style attacks (../../) supplied within the archive file.

- 时间线

2006-03-13 2006-03-02
Unknow Unknow

- 解决方案

Upgrade to version 0.55 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Unalz Hostile Destination Path Vulnerability
Input Validation Error 17105
Yes No
2006-03-14 12:00:00 2006-03-16 09:45:00
Tan Chew Keong is credited with the discovery of this vulnerability.

- 受影响的程序版本 unalz 0.53 unalz 0.55

- 不受影响的程序版本 unalz 0.55

- 漏洞讨论

The 'unalz' tool contains a vulnerability in the handling of pathnames for archived files.

By specifying a path for an archived item that points outside the expected destination directory, the creator of the archive can cause the file to be extracted to arbitrary locations on the filesystem, possibly including paths containing system binaries and other sensitive or confidential information.

Presumably, an attacker could use this to create or overwrite binaries in any desired location, using the privileges of the invoking user.

Version 0.53 is vulnerable; other versions may also be affected.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released version 0.55 to address this issue. unalz 0.53

- 相关参考