CVE-2006-0915
CVSS7.5
发布时间 :2006-02-28 06:02:00
修订时间 :2011-03-07 21:31:04
NMCOS    

[原文]Bugzilla 2.16.10 does not properly handle certain characters in the (1) maxpatchsize and (2) maxattachmentsize parameters in attachment.cgi, which allows remote attackers to trigger a SQL error.


[CNNVD]Bugzilla Whinedays SQL注入漏洞(CNNVD-200602-436)

        Bugzilla 2.16.10没有正确处理attachment.cgi的(1) maxpatchsize和(2) maxattachmentsize参数中的某些字符,可使远程攻击者触发SQL错误。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0915
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0915
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-436
(官方数据源) CNNVD

- 其它链接及资源

https://bugzilla.mozilla.org/show_bug.cgi?id=313441
(UNKNOWN)  CONFIRM  https://bugzilla.mozilla.org/show_bug.cgi?id=313441
http://www.vupen.com/english/advisories/2006/0692
(UNKNOWN)  VUPEN  ADV-2006-0692

- 漏洞信息

Bugzilla Whinedays SQL注入漏洞
高危 输入验证
2006-02-28 00:00:00 2006-03-01 00:00:00
远程  
        Bugzilla 2.16.10没有正确处理attachment.cgi的(1) maxpatchsize和(2) maxattachmentsize参数中的某些字符,可使远程攻击者触发SQL错误。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Mozilla Bugzilla 2.20
        Mozilla bugzilla-2.20.1.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.20.1.tar.gz
        Mozilla Bugzilla 2.18 rc1
        Mozilla bugzilla-2.18.5.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.18.5.tar.gz
        Mozilla Bugzilla 2.18 rc3
        Mozilla bugzilla-2.18.5.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.18.5.tar.gz
        Mozilla Bugzilla 2.18 rc2
        Mozilla bugzilla-2.18.5.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.18.5.tar.gz
        Mozilla Bugzilla 2.18.1
        Mozilla bugzilla-2.18.5.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.18.5.tar.gz
        Mozilla Bugzilla 2.18.2
        Mozilla bugzilla-2.18.5.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.18.5.tar.gz
        Mozilla Bugzilla 2.18.3
        Mozilla bugzilla-2.18.5.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.18.5.tar.gz
        Mozilla Bugzilla 2.18.4
        Mozilla bugzilla-2.18.5.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.18.5.tar.gz
        Mozilla Bugzilla 2.20 rc2
        Mozilla bugzilla-2.20.1.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.20.1.tar.gz
        Mozilla Bugzilla 2.20 rc1
        Mozilla bugzilla-2.20.1.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.20.1.tar.gz
        Mozilla Bugzilla 2.21
        Mozilla bugzilla-2.22rc1.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.22rc1.tar.gz
        Mozilla Bugzilla 2.21.1
        Mozilla bugzilla-2.22rc1.tar.gz
        http://ftp.mozilla.org/pub/mozilla.org/webtools/bugzilla-2.22rc1.tar.gz

- 漏洞信息

28236
Bugzilla attachment.cgi Forced SQL Error Information Disclosure
Information Disclosure
Loss of Confidentiality
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-10-22 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Bugzilla Whinedays SQL Injection Vulnerability
Input Validation Error 16738
Yes No
2006-02-21 12:00:00 2006-03-03 05:11:00
Frédéric Buclin is credited with the discovery of this vulnerability.

- 受影响的程序版本

Mozilla Bugzilla 2.21.1
Mozilla Bugzilla 2.21
Mozilla Bugzilla 2.20 rc2
Mozilla Bugzilla 2.20 rc1
Mozilla Bugzilla 2.19.3
Mozilla Bugzilla 2.19.2
Mozilla Bugzilla 2.19.1
Mozilla Bugzilla 2.19
Mozilla Bugzilla 2.18.4
Mozilla Bugzilla 2.18.3
Mozilla Bugzilla 2.18.2
Mozilla Bugzilla 2.18.1
Mozilla Bugzilla 2.18 rc3
Mozilla Bugzilla 2.18 rc2
Mozilla Bugzilla 2.18 rc1
Mozilla Bugzilla 2.17.7
Mozilla Bugzilla 2.17.6
Mozilla Bugzilla 2.17.5
Mozilla Bugzilla 2.17.4
Mozilla Bugzilla 2.17.3
Mozilla Bugzilla 2.17.1
Mozilla Bugzilla 2.20
Mozilla Bugzilla 2.21.2
Mozilla Bugzilla 2.20.1
Mozilla Bugzilla 2.18.5
Mozilla Bugzilla 2.22 RC1

- 不受影响的程序版本

Mozilla Bugzilla 2.21.2
Mozilla Bugzilla 2.20.1
Mozilla Bugzilla 2.18.5
Mozilla Bugzilla 2.22 RC1

- 漏洞讨论

Bugzilla is prone to an SQL-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

Successful exploitation could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

Exploitation of this issue requires the attacker to have administrative access to the affected application.

- 漏洞利用


An exploit is not required.

- 解决方案


The vendor has released updates to address this issue. Please the referenced vendor advisory for further information.


Mozilla Bugzilla 2.20

Mozilla Bugzilla 2.18 rc1

Mozilla Bugzilla 2.18 rc3

Mozilla Bugzilla 2.18 rc2

Mozilla Bugzilla 2.18.1

Mozilla Bugzilla 2.18.2

Mozilla Bugzilla 2.18.3

Mozilla Bugzilla 2.18.4

Mozilla Bugzilla 2.20 rc2

Mozilla Bugzilla 2.20 rc1

Mozilla Bugzilla 2.21

Mozilla Bugzilla 2.21.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站