CVE-2006-0898
CVSS2.6
发布时间 :2006-02-25 06:02:00
修订时间 :2008-09-10 16:03:32
NMCOS    

[原文]Crypt::CBC Perl module 2.16 and earlier, when running in RandomIV mode, uses an initialization vector (IV) of 8 bytes, which results in weaker encryption when used with a cipher that requires a larger block size than 8 bytes, such as Rijndael.


[CNNVD]Lincoln D. Stein Crypt::CBC Perl模块弱密文漏洞(CNNVD-200602-398)

        Crypt::CBC Perl module 2.16及之前版本在RandomIV模式下运行时使用8个字节的初始化向量(IV),当与需要大于8字节块大小的密码(如Rijndael)一起使用时会导致更低的加密强度。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:lincoln_d._stein:crypt_cbc:2.09
cpe:/a:lincoln_d._stein:crypt_cbc:1.10
cpe:/a:lincoln_d._stein:crypt_cbc:1.24
cpe:/a:lincoln_d._stein:crypt_cbc:2.16
cpe:/a:lincoln_d._stein:crypt_cbc:2.07
cpe:/a:lincoln_d._stein:crypt_cbc:2.02
cpe:/a:lincoln_d._stein:crypt_cbc:2.05
cpe:/a:lincoln_d._stein:crypt_cbc:1.21
cpe:/a:lincoln_d._stein:crypt_cbc:2.14
cpe:/a:lincoln_d._stein:crypt_cbc:2.13
cpe:/a:lincoln_d._stein:crypt_cbc:2.12
cpe:/a:lincoln_d._stein:crypt_cbc:2.10
cpe:/a:lincoln_d._stein:crypt_cbc:2.08
cpe:/a:lincoln_d._stein:crypt_cbc:1.00
cpe:/a:lincoln_d._stein:crypt_cbc:2.01
cpe:/a:lincoln_d._stein:crypt_cbc:2.04
cpe:/a:lincoln_d._stein:crypt_cbc:2.03
cpe:/a:lincoln_d._stein:crypt_cbc:1.25
cpe:/a:lincoln_d._stein:crypt_cbc:2.11
cpe:/a:lincoln_d._stein:crypt_cbc:2.15
cpe:/a:lincoln_d._stein:crypt_cbc:1.22
cpe:/a:lincoln_d._stein:crypt_cbc:1.20
cpe:/a:lincoln_d._stein:crypt_cbc:2.00

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0898
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0898
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-398
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16802
(PATCH)  BID  16802
http://www.securityfocus.com/archive/1/archive/1/425966/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060223 Vulnerability in Crypt::CBC Perl module, versions <= 2.16
http://secunia.com/advisories/31493
(UNKNOWN)  SECUNIA  31493
http://rhn.redhat.com/errata/RHSA-2008-0630.html
(UNKNOWN)  REDHAT  RHSA-2008:0630
http://xforce.iss.net/xforce/xfdb/24954
(UNKNOWN)  XF  crypt-cbc-header-weak-encryption(24954)
http://www.redhat.com/support/errata/RHSA-2008-0261.html
(UNKNOWN)  REDHAT  RHSA-2008:0261
http://www.novell.com/linux/security/advisories/2006_38_security.html
(UNKNOWN)  SUSE  SUSE-SR:2006:015
http://www.gentoo.org/security/en/glsa/glsa-200603-15.xml
(UNKNOWN)  GENTOO  GLSA-200603-15
http://www.debian.org/security/2006/dsa-996
(UNKNOWN)  DEBIAN  DSA-996
http://securityreason.com/securityalert/488
(UNKNOWN)  SREASON  488
http://secunia.com/advisories/20899
(UNKNOWN)  SECUNIA  20899
http://secunia.com/advisories/19303
(UNKNOWN)  SECUNIA  19303
http://secunia.com/advisories/19187
(UNKNOWN)  SECUNIA  19187
http://secunia.com/advisories/18755
(UNKNOWN)  SECUNIA  18755

- 漏洞信息

Lincoln D. Stein Crypt::CBC Perl模块弱密文漏洞
低危 设计错误
2006-02-25 00:00:00 2006-02-27 00:00:00
远程※本地  
        Crypt::CBC Perl module 2.16及之前版本在RandomIV模式下运行时使用8个字节的初始化向量(IV),当与需要大于8字节块大小的密码(如Rijndael)一起使用时会导致更低的加密强度。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Lincoln D. Stein Crypt::CBC 1.25
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.02
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.08
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.11
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.05
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 1.21
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.10
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.14
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.01
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.00
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.15
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.03
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.07
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.12
        Debian libcrypt-cbc-perl_2.12-1sarge1_all.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/libc/libcrypt-cbc-perl/i bcrypt-cbc-perl_2.12-1sarge1_all.deb
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 1.10
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 1.20
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.16
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz
        Lincoln D. Stein Crypt::CBC 2.04
        Lincoln D. Stein Crypt-CBC-2.17.tar.gz
        http://search.cpan.org/CPAN/authors/id/L/LD/LDS/Crypt-CBC-2.17.tar.gz

- 漏洞信息

23513
Crypt::CBC RandomIV Header IV Header Encryption Weakness
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.17 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Lincoln D. Stein Crypt::CBC Perl Module Weak Ciphertext Vulnerability
Design Error 16802
Yes Yes
2006-02-24 12:00:00 2008-08-25 10:46:00
The vendor disclosed this issue.

- 受影响的程序版本

SuSE SUSE Linux Enterprise Server 8
+ Linux kernel 2.4.21
+ Linux kernel 2.4.19
S.u.S.E. UnitedLinux 1.0
S.u.S.E. SuSE Linux Standard Server 8.0
S.u.S.E. SuSE Linux School Server for i386
S.u.S.E. SUSE LINUX Retail Solution 8.0
S.u.S.E. SuSE Linux Openexchange Server 4.0
S.u.S.E. SuSE Linux Open-Xchange 4.1
S.u.S.E. Open-Enterprise-Server 9.0
S.u.S.E. Open-Enterprise-Server 1
S.u.S.E. Office Server
S.u.S.E. Novell Linux Desktop 9.0
S.u.S.E. Novell Linux Desktop 1.0
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 10.0
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 10.1
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 10.1
S.u.S.E. Linux Openexchange Server
S.u.S.E. Linux Office Server
S.u.S.E. Linux Enterprise Server for S/390 9.0
S.u.S.E. Linux Enterprise Server for S/390
S.u.S.E. Linux Enterprise Server 9
S.u.S.E. Linux Desktop 1.0
S.u.S.E. Linux Database Server 0
S.u.S.E. Linux Connectivity Server
RedHat Network Satellite (for RHEL 4) 5.1
RedHat Network Satellite (for RHEL 4) 4.2
Red Hat Red Hat Network Satellite Server 5.0
Red Hat Red Hat Network Satellite Server 4.2
Red Hat Network Satellite (for RHEL 3) 4.2
Lincoln D. Stein Crypt::CBC 2.16
Lincoln D. Stein Crypt::CBC 2.15
Lincoln D. Stein Crypt::CBC 2.14
Lincoln D. Stein Crypt::CBC 2.13
Lincoln D. Stein Crypt::CBC 2.12
Lincoln D. Stein Crypt::CBC 2.11
Lincoln D. Stein Crypt::CBC 2.10
Lincoln D. Stein Crypt::CBC 2.09
Lincoln D. Stein Crypt::CBC 2.08
Lincoln D. Stein Crypt::CBC 2.07
Lincoln D. Stein Crypt::CBC 2.05
Lincoln D. Stein Crypt::CBC 2.04
Lincoln D. Stein Crypt::CBC 2.03
Lincoln D. Stein Crypt::CBC 2.02
Lincoln D. Stein Crypt::CBC 2.01
Lincoln D. Stein Crypt::CBC 2.00
Lincoln D. Stein Crypt::CBC 1.25
Lincoln D. Stein Crypt::CBC 1.24
Lincoln D. Stein Crypt::CBC 1.22
Lincoln D. Stein Crypt::CBC 1.21
Lincoln D. Stein Crypt::CBC 1.20
Lincoln D. Stein Crypt::CBC 1.10
Lincoln D. Stein Crypt::CBC 1.00
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Lincoln D. Stein Crypt::CBC 2.17

- 不受影响的程序版本

Lincoln D. Stein Crypt::CBC 2.17

- 漏洞讨论

Crypt::CBC is prone to a weak-ciphertext vulnerability. This issue stems from a flaw in its creation of IVs (Initialization Vectors) for ciphers with a blocksize larger than 8.

This issue results in the creation of ciphertext that contains bytes encrypted with a constant null IV. This ciphertext is prone to differential cryptanalysis, aiding attackers in compromising the plaintext of encrypted data.

The level of difficulty attackers may face trying to exploit this flaw is currently unknown, but data encrypted with vulnerable versions of Crypt::CBC should be considered insecure.

Versions prior to Crypt::CBC 2.17 are vulnerable to this issue if they use the 'RandomIV' header style.

- 漏洞利用

Software designed to perform cryptanalysis is required.

Depending on the methods used to gain access to the cyphertext, such as exploiting latent vulnerabilities in other software, exploit code may also be required.

- 解决方案

The vendor has released Crypt::CBC 2.17 to address this issue. Please see the references for more information and advisories.


Lincoln D. Stein Crypt::CBC 1.25

Lincoln D. Stein Crypt::CBC 2.02

Lincoln D. Stein Crypt::CBC 2.08

Lincoln D. Stein Crypt::CBC 2.11

Lincoln D. Stein Crypt::CBC 2.05

Lincoln D. Stein Crypt::CBC 1.21

Lincoln D. Stein Crypt::CBC 2.10

Lincoln D. Stein Crypt::CBC 2.14

Lincoln D. Stein Crypt::CBC 2.01

Lincoln D. Stein Crypt::CBC 2.00

Lincoln D. Stein Crypt::CBC 2.15

Lincoln D. Stein Crypt::CBC 2.03

Lincoln D. Stein Crypt::CBC 2.07

Lincoln D. Stein Crypt::CBC 2.12

Lincoln D. Stein Crypt::CBC 1.10

Lincoln D. Stein Crypt::CBC 1.20

Lincoln D. Stein Crypt::CBC 2.16

Lincoln D. Stein Crypt::CBC 2.04

Lincoln D. Stein Crypt::CBC 2.13

Lincoln D. Stein Crypt::CBC 1.24

Lincoln D. Stein Crypt::CBC 1.00

Lincoln D. Stein Crypt::CBC 1.22

Lincoln D. Stein Crypt::CBC 2.09

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站