发布时间 :2006-02-24 06:02:00
修订时间 :2011-03-07 21:30:59

[原文]POPFile before 0.22.4 allows remote attackers to cause a denial of service (application crash) via unspecified vectors involving character sets within e-mail messages.


        POPFile 0.22.4之前的版本可使远程攻击者借助涉及电子邮件消息中字符集的未明向量造成拒绝服务(应用程序崩溃)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-0698
(UNKNOWN)  BID  16792

- 漏洞信息

中危 其他
2006-02-24 00:00:00 2006-02-24 00:00:00
        POPFile 0.22.4之前的版本可使远程攻击者借助涉及电子邮件消息中字符集的未明向量造成拒绝服务(应用程序崩溃)。

- 公告与补丁

        POPFile POPFile 0.22.3

- 漏洞信息 (F46500)

Debian Linux Security Advisory 1061-1 (PacketStormID:F46500)
2006-05-22 00:00:00
advisory,denial of service

Debian Security Advisory 1061-1 - It has been discovered that popfile, a bayesian mail classifier, can be forced into a crash through malformed character sets within email messages, which allows denial of service.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1061-1                                   Moritz Muehlenhoff
May 19th, 2006                
- --------------------------------------------------------------------------

Package        : popfile
Vulnerability  : missing input sanitising
Problem-Type   : local(remote)
Debian-specific: no
CVE ID         : CVE-2006-0876
Debian Bug     : 354464

It has been discovered that popfile, a bayesian mail classifier, can
be forced into a crash through malformed character sets within email
messages, which allows denial of service.

The old stable distribution (woody) does not contain popfile packages.

For the stable distribution (sarge) this problem has been fixed in
version 0.22.2-2sarge1.

For the unstable distribution (sid) this problem has been fixed in
version 0.22.4-1.

We recommend that you upgrade your popfile package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:
      Size/MD5 checksum:      589 3e810260fb4c4527a1b2b4ed2cb60550
      Size/MD5 checksum:    13892 412e873bf3ed0031ac6f0d728f428188
      Size/MD5 checksum:  1494830 05538821f28c3f57d514460effc034ef

  Architecture independent components:
      Size/MD5 checksum:  1481360 85f5e08bff66c1830c1d6bd35f34c89b

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>
Version: GnuPG v1.4.3 (GNU/Linux)



- 漏洞信息

POPFile Email Crafted Charset Message Download DoS
Denial of Service
Loss of Availability
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-22 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.22.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

POPFile Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 16792
Yes No
2006-02-23 12:00:00 2006-05-19 09:48:00
This issue was disclosed by the vendor.

- 受影响的程序版本

POPFile POPFile 0.22.3
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
POPFile POPFile 0.22.4

- 不受影响的程序版本

POPFile POPFile 0.22.4

- 漏洞讨论

A denial-of-service vulnerability has been reported in POPFile.

A remote attacker may cause a denial-of-service condition in the application, effectively halting service to legitimate users.

- 漏洞利用

This exploit may be triggered by downloading a malicious email message.

- 解决方案

The vendor has released version 0.22.4. to address this issue.

Please see the references for vendor advisories and fixes.

POPFile POPFile 0.22.3

- 相关参考