CVE-2006-0868
CVSS7.5
发布时间 :2006-02-23 18:02:00
修订时间 :2011-03-07 21:30:56
NMCOS    

[原文]Multiple unspecified injection vulnerabilities in unspecified Auth Container back ends for PEAR::Auth before 1.2.4, and 1.3.x before 1.3.0r4, allow remote attackers to "falsify authentication credentials," related to the "underlying storage containers."


[CNNVD]PEAR::Auth模块多个SQL注入漏洞(CNNVD-200602-352)

        PEAR::Auth模块包允许使用PHP创建认证系统。
        PEAR::Auth模块在处理用户提交的认证数据时存在问题,远程攻击者可能利用此漏洞绕过认证。
        一些PEAR::Auth贮藏容器后端(具体来说是DB和LDAP认证贮藏容器)在将用户输入提交给基础认证机制之前没有执行充分的验证,这可能允许恶意用户执行SQL注入攻击,伪造认证凭据,导致非授权访问。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:pear:xml_rpc:1.2.2
cpe:/a:pear:xml_rpc:1.2.0
cpe:/a:pear:xml_rpc:1.3.0rc3
cpe:/a:pear:xml_rpc:1.0.4
cpe:/a:pear:xml_rpc:1.0.3
cpe:/a:pear:xml_rpc:1.2.0rc3
cpe:/a:pear:xml_rpc:1.3.0rc1
cpe:/a:pear:xml_rpc:1.2.0rc7
cpe:/a:pear:xml_rpc:1.2.0rc5
cpe:/a:pear:xml_rpc:1.2.1
cpe:/a:pear:xml_rpc:1.2.0rc2
cpe:/a:pear:xml_rpc:1.3.0rc2
cpe:/a:pear:xml_rpc:1.0.2
cpe:/a:pear:xml_rpc:1.2.0rc1
cpe:/a:pear:xml_rpc:1.2.0rc4
cpe:/a:pear:xml_rpc:1.2.0rc6
cpe:/a:pear:xml_rpc:1.1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0868
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0868
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-352
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16758
(VENDOR_ADVISORY)  BID  16758
http://pear.php.net/package/Auth/download/1.3.0r4
(PATCH)  CONFIRM  http://pear.php.net/package/Auth/download/1.3.0r4
http://pear.php.net/package/Auth/download/1.2.4
(PATCH)  CONFIRM  http://pear.php.net/package/Auth/download/1.2.4
http://www.vupen.com/english/advisories/2006/0696
(UNKNOWN)  VUPEN  ADV-2006-0696
http://www.securityfocus.com/archive/1/archive/1/425796/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060222 Multiple Injection Vulnerabilities in PHP PEAR::Auth Module
http://xforce.iss.net/xforce/xfdb/24854
(UNKNOWN)  XF  auth-multiple-injections(24854)
http://www.gentoo.org/security/en/glsa/glsa-200603-13.xml
(UNKNOWN)  GENTOO  GLSA-200603-13
http://securitytracker.com/id?1015666
(UNKNOWN)  SECTRACK  1015666
http://secunia.com/advisories/19301
(UNKNOWN)  SECUNIA  19301
http://secunia.com/advisories/19008
(UNKNOWN)  SECUNIA  19008

- 漏洞信息

PEAR::Auth模块多个SQL注入漏洞
高危 输入验证
2006-02-23 00:00:00 2006-02-24 00:00:00
远程  
        PEAR::Auth模块包允许使用PHP创建认证系统。
        PEAR::Auth模块在处理用户提交的认证数据时存在问题,远程攻击者可能利用此漏洞绕过认证。
        一些PEAR::Auth贮藏容器后端(具体来说是DB和LDAP认证贮藏容器)在将用户输入提交给基础认证机制之前没有执行充分的验证,这可能允许恶意用户执行SQL注入攻击,伪造认证凭据,导致非授权访问。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        PEAR Auth-1.2.4.tgz
        http://pear.php.net/get/Auth-1.2.4.tgz
        PEAR Auth-1.3.0r4.tgz
        http://pear.php.net/get/Auth-1.3.0r4.tgz

- 漏洞信息

23428
PEAR::Auth DB / LDAP Container SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-14 2006-01-30
Unknow Unknow

- 解决方案

Upgrade to version 1.2.4, 1.3.0r4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PEAR::Auth Multiple Unspecified SQL Injection Vulnerabilities
Input Validation Error 16758
Yes No
2006-02-21 12:00:00 2006-03-20 05:39:00
Discovered by Matt Van Gundy <mattvg@cs.ucsb.edu>.

- 受影响的程序版本

PEAR PEAR::Auth 1.3 r3
PEAR PEAR::Auth 1.2.3
Gentoo Linux
PEAR PEAR::Auth 1.3 r4
PEAR PEAR::Auth 1.2.4

- 不受影响的程序版本

PEAR PEAR::Auth 1.3 r4
PEAR PEAR::Auth 1.2.4

- 漏洞讨论


PEAR::Auth is prone to multiple unspecified SQL-injection vulnerabilities. This vulnerability could permit remote attackers to pass malicious input to database queries, resulting in the modification of query logic or other attacks.

Successful exploitation could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

PEAR::Auth versions prior to 1.2.4 and to 1.3.0r4 are vulnerable.

Further information reports these issues affect the DB and LDAP Auth Containers.

- 漏洞利用


An exploit is not required.

- 解决方案

The vendor has released fixes to address this issue.

Please see the referenced vendor advisories for details on obtaining and applying the appropriate updates.


PEAR PEAR::Auth 1.2.3

PEAR PEAR::Auth 1.3 r3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站