发布时间 :2006-02-20 21:02:00
修订时间 :2008-09-05 17:00:16

[原文]Unspecified vulnerability in config.php in Skate Board 0.9 allows remote authenticated administrators to execute arbitrary PHP code by causing certain variables in config.php to be modified, possibly due to XSS or direct static code injection.

[CNNVD]Skate Board config.php 未明漏洞(CNNVD-200602-307)

        Skate Board 0.9的config.php中存在未明漏洞。远程认证管理员可以通过修改config.php中的某些变量(可能是由于XSS或直接静态代码注入)来执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 3.5 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  skateboard-config-file-include(24780)
(UNKNOWN)  BID  16936
(UNKNOWN)  BUGTRAQ  20060303 [eVuln] Skate Board Multimple Vulnerabilities

- 漏洞信息

Skate Board config.php 未明漏洞
低危 输入验证
2006-02-20 00:00:00 2007-07-03 00:00:00
        Skate Board 0.9的config.php中存在未明漏洞。远程认证管理员可以通过修改config.php中的某些变量(可能是由于XSS或直接静态代码注入)来执行任意PHP代码。

- 公告与补丁


- 漏洞信息 (F44361)

EV0084.txt (PacketStormID:F44361)
2006-03-06 00:00:00
Aliaksandr Hartsuyeu
exploit,php,xss,sql injection

Skate Board version 0.9 is susceptible to SQL injection, cross site scripting, authentication bypass, and PHP code injection flaws.

New eVuln Advisory:
Skate Board Multimple Vulnerabilities

eVuln ID: EV0084
CVE: CVE-2006-0809 CVE-2006-0810 CVE-2006-0811
Software: Skate Board
Sowtware's Web Site:
Versions: 0.9
Critical Level: Dangerous
Type: Multiple Vulnerabilities
Class: Remote
Status: Unpatched. No reply from developer(s)
Exploit: Available
Solution: Not Available
Discovered by: Aliaksandr Hartsuyeu (

1. SQL Injection.

Vulnerable script: includes/root/sendpass.php

Variable $_POST[usern] isn't properly sanitized before being used in a SQL query. This can be used to make any SQL query by injecting arbitrary SQL code.

Condition: magic_quotes_gpc - off

2. Authentication Bypass.

Vulnerable scripts:

Variables $_POST[usern] $_POST[passwd] $_COOKIE[sf_cookie] are not properly sanitized before being used in a SQL query. This can be used to make any SQL query by injecting arbitrary SQL code and make authorization bypass.

Condition: magic_quotes_gpc - off

3. PHP Code Injection.

Administrator has an ability to edit values of variables in config.php This can be used to inject arbitrary PHP code.

System access is possible.

4. Multiple Cross-Site Scripting.

Vulnerable script: includes/root/reguser.php

All user-defined data from registration form isn't properly sanitized. This can be used to inject arbitrary html or script code.

Available at:

1. SQL Injection Example

Url: http://[host]/index.php? act=lostpass
Username: aaa' union select 1,2,3,4,5,6, 7,8,9,10,11, 12,13,14,15, 16,17,18,19, 20/*

2. Authentication Bypass.

a) From login form:
username: [username]' and 1/*
password: any

b) Cookie value
Cookie: sf_cookie=admin% 27+and+1%2F% 2A%3Basd

3. PHP Code Injection Example.

Min user chars is: 3; [code]

4. Multiple Cross-Site Scripting.

url: http://[host]/index.php? act=register
username: [XSS]
Full Name: [XSS]
Location: [XSS]
Yahoo: [XSS]

No Patch available.

Discovered by: Aliaksandr Hartsuyeu (

Aliaksandr Hartsuyeu - Penetration Testing Services


- 漏洞信息

Skate Board config.php Administrator Arbitrary PHP Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Skate Board contains a flaw that may allow a malicious user to gain access to unauthorized privileges. The issue is triggered when when an authenticated Skate Board user with administrative priveleges injects PHP code into multiple variables in the config.php script. This flaw may lead to a loss of confidentiality and/or integrity on the server hosting the bulletin board.

- 时间线

2006-02-17 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者