发布时间 :2006-02-20 21:02:00
修订时间 :2011-09-13 00:00:00

[原文]Multiple cross-site scripting (XSS) vulnerabilities in ADOdb 4.71, as used in multiple packages such as phpESP, allow remote attackers to inject arbitrary web script or HTML via (1) the next_page parameter in and (2) other unspecified vectors related to PHP_SELF.


        ADOdb 4.71中存在多个跨站脚本攻击(XSS)漏洞,当用于多个程序包(如phpESP)时,远程攻击者可以借助(1)中的next_page参数和(2)与PHP_SELF相关的其他未明向量注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  16720
(UNKNOWN)  BUGTRAQ  20060218 ADOdb Library Cross Site Scripting

- 漏洞信息

中危 跨站脚本
2006-02-20 00:00:00 2006-09-08 00:00:00
        ADOdb 4.71中存在多个跨站脚本攻击(XSS)漏洞,当用于多个程序包(如phpESP)时,远程攻击者可以借助(1)中的next_page参数和(2)与PHP_SELF相关的其他未明向量注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

ADOdb Pagination XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

ADOdb for PHP contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate "next_page" and "PHP_SELF" variables upon submission to the script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-02-18 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.72 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

ADOdb Multiple Cross-Site Scripting Vulnerabilities
Input Validation Error 16720
Yes No
2006-02-18 12:00:00 2006-04-17 08:41:00
GulfTech Security Research <> is credited with the discovery of these vulnerabilities.

- 受影响的程序版本

Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0
ADOdb ADOdb 4.71
ADOdb ADOdb 4.70
ADOdb ADOdb 4.68
ADOdb ADOdb 4.66

- 漏洞讨论

ADOdb is prone to multiple cross-site scripting vulnerabilities. These issues are due to a lack of proper sanitization of user-supplied input.

An attacker may leverage these issues to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. These may help the attacker steal cookie-based authentication credentials and launch other attacks.

ADOdb versions 4.71 and prior are vulnerable.

- 漏洞利用

No exploit is required.

- 解决方案

Debian Linux has released security advisories DSA 1029-1 and DSA 1030-1 to address this issue. Please see the referenced vendor advisories for further information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at:

- 相关参考