CVE-2006-0804
CVSS7.5
发布时间 :2006-02-20 20:02:00
修订时间 :2011-03-07 21:30:50
NMCOS    

[原文]Off-by-one error in TIN 1.8.0 and earlier might allow attackers to execute arbitrary code via unknown vectors that trigger a buffer overflow.


[CNNVD]Tin News Reader缓冲区溢出漏洞(CNNVD-200602-311)

        TIN 1.8.0及之前版本中存在差缓存区溢出漏洞,攻击者可以借助触发缓冲区溢出的未知向量执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:tin:tin:1.6.2
cpe:/a:tin:tin:1.6.0
cpe:/a:tin:tin:1.1_pl7
cpe:/a:tin:tin:1.1_pl6
cpe:/a:tin:tin:1.1_pl8
cpe:/a:tin:tin:1.0_pl5
cpe:/a:tin:tin:1.0_pl1
cpe:/a:tin:tin:1.0_pl3
cpe:/a:tin:tin:1.4.4
cpe:/a:tin:tin:1.0_pl2
cpe:/a:tin:tin:1.6.1
cpe:/a:tin:tin:1.1_pl2
cpe:/a:tin:tin:1.1_pl1
cpe:/a:tin:tin:1.1_pl4
cpe:/a:tin:tin:1.4.1
cpe:/a:tin:tin:1.1_pl9
cpe:/a:tin:tin:1.4.3
cpe:/a:tin:tin:1.0_pl0
cpe:/a:tin:tin:1.1_pl0
cpe:/a:tin:tin:1.8.0
cpe:/a:tin:tin:1.2_pl1
cpe:/a:tin:tin:1.4.2
cpe:/a:tin:tin:1.1_pl3
cpe:/a:tin:tin:1.4.7
cpe:/a:tin:tin:1.4.6
cpe:/a:tin:tin:1.4.5
cpe:/a:tin:tin:1.4.0
cpe:/a:tin:tin:1.2_pl0
cpe:/a:tin:tin:1.2_pl2
cpe:/a:tin:tin:1.0_pl4
cpe:/a:tin:tin:1.1_pl5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0804
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0804
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-311
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/0702
(UNKNOWN)  VUPEN  ADV-2006-0702
http://www.securityfocus.com/bid/16728
(UNKNOWN)  BID  16728
http://www.openpkg.org/security/OpenPKG-SA-2006.005-tin.html
(VENDOR_ADVISORY)  OPENPKG  OpenPKG-SA-2006.005
http://xforce.iss.net/xforce/xfdb/24841
(UNKNOWN)  XF  tin-offbyone-bo(24841)
http://www.novell.com/linux/security/advisories/2006_05_sr.html
(UNKNOWN)  SUSE  SUSE-SR:2006:005
http://security.gentoo.org/glsa/glsa-200611-18.xml
(UNKNOWN)  GENTOO  GLSA-200611-18
http://secunia.com/advisories/19130
(UNKNOWN)  SECUNIA  19130

- 漏洞信息

Tin News Reader缓冲区溢出漏洞
高危 缓冲区溢出
2006-02-20 00:00:00 2006-02-23 00:00:00
远程  
        TIN 1.8.0及之前版本中存在差缓存区溢出漏洞,攻击者可以借助触发缓冲区溢出的未知向量执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Tin News Reader 1.8
        Tin tin-current.tar.gz
        ftp://ftp.tin.org/pub/news/clients/tin/stable/tin-current.tar.gz

- 漏洞信息

23698
TIN Unspecified Off-by-one Error Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-20 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.8.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Tin News Reader Buffer Overflow Vulnerability
Boundary Condition Error 16728
Yes No
2006-02-20 12:00:00 2006-11-24 03:40:00
The vendor disclosed this vulnerability.

- 受影响的程序版本

Tin News Reader 1.8
SuSE SUSE Linux Enterprise Server 8
+ Linux kernel 2.4.21
+ Linux kernel 2.4.19
S.u.S.E. SuSE Linux Standard Server 8.0
S.u.S.E. SuSE Linux School Server for i386
S.u.S.E. SUSE LINUX Retail Solution 8.0
S.u.S.E. SuSE Linux Openexchange Server 4.0
S.u.S.E. Open-Enterprise-Server 9.0
S.u.S.E. Novell Linux Desktop 9.0
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Professional 8.2
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
S.u.S.E. Linux Personal 8.2
S.u.S.E. Linux Enterprise Server 9
S.u.S.E. Linux Desktop 1.0
S.u.S.E. blam 9.3
OpenPKG OpenPKG 2.5
OpenPKG OpenPKG 2.4
OpenPKG OpenPKG 2.3
OpenPKG OpenPKG Current
Gentoo Linux
Tin News Reader 1.8.1

- 不受影响的程序版本

Tin News Reader 1.8.1

- 漏洞讨论

The Tin news reader is prone to a buffer-overflow vulnerability. This issue is due to a failure in the application to do proper boundary checks on user-supplied data before using it in a finite-sized buffer.

An attacker can exploit this issue to execute arbitrary code on the victim userâ??s computer in the context of the victim user. This may facilitate a compromise of the affected computer.

Versions 1.8.0 and earlier are vulnerable.

- 漏洞利用

No exploit is required.

- 解决方案

Tin version 1.8.1 is available; please see the reference section for further details.

Please see the references for further information and fixes.


Tin News Reader 1.8

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站