CVE-2006-0800
CVSS2.6
发布时间 :2006-02-20 17:02:00
修订时间 :2011-10-11 00:00:00
NMCO    

[原文]Interpretation conflict in PostNuke 0.761 and earlier allows remote attackers to conduct cross-site scripting (XSS) attacks via HTML tags with a trailing "<" character, which is interpreted as a ">" character by some web browsers but bypasses the blacklist protection in (1) the pnVarCleanFromInput function in pnAPI.php, (2) the pnSecureInput function in pnAntiCracker.php, and (3) the htmltext parameter in an edituser operation to user.php.


[CNNVD]PostNuke多个输入验证漏洞(CNNVD-200602-308)

        PostNuke 0.761及之前版本中存在解释冲突。远程攻击者可以借助带有"<"字符后缀(在有些web浏览器中会被解释为">",但是会绕过(1)pnAPI.php中pnVarCleanFromInput功能、(2)pnAntiCracker.php中pnSecureInput功能和(3)对user.php进行的edituser操作中的htmltext参数的黑名单保护)的HTML标签进行跨站脚本(XSS)攻击。

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:postnuke_software_foundation:postnuke:0.73
cpe:/a:postnuke_software_foundation:postnuke:0.71
cpe:/a:postnuke_software_foundation:postnuke:0.76_rc4
cpe:/a:postnuke_software_foundation:postnuke:0.721
cpe:/a:postnuke_software_foundation:postnuke:0.76_rc4b
cpe:/a:postnuke_software_foundation:postnuke:0.75
cpe:/a:postnuke_software_foundation:postnuke:0.64
cpe:/a:postnuke_software_foundation:postnuke:0.74
cpe:/a:postnuke_software_foundation:postnuke:0.72
cpe:/a:postnuke_software_foundation:postnuke:0.75_rc3
cpe:/a:postnuke_software_foundation:postnuke:0.76_rc4a
cpe:/a:postnuke_software_foundation:postnuke:0.7
cpe:/a:postnuke_software_foundation:postnuke:0.761a
cpe:/a:postnuke_software_foundation:postnuke:0.70
cpe:/a:postnuke_software_foundation:postnuke:0.761
cpe:/a:postnuke_software_foundation:postnuke:0.62
cpe:/a:postnuke_software_foundation:postnuke:0.63
cpe:/a:postnuke_software_foundation:postnuke:0.726.3
cpe:/a:postnuke_software_foundation:postnuke:0.703

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0800
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0800
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-308
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/24823
(PATCH)  XF  postnuke-user-nslanguages-xss(24823)
http://www.securityfocus.com/bid/16752
(PATCH)  BID  16752
http://secunia.com/advisories/18937
(VENDOR_ADVISORY)  SECUNIA  18937
http://news.postnuke.com/index.php?name=News&file=article&sid=2754
(PATCH)  CONFIRM  http://news.postnuke.com/index.php?name=News&file=article&sid=2754
http://www.vupen.com/english/advisories/2006/0673
(VENDOR_ADVISORY)  VUPEN  ADV-2006-0673
http://securityreason.com/securityalert/454
(UNKNOWN)  SREASON  454
http://securityreason.com/securityalert/454
(VENDOR_ADVISORY)  MISC  http://securityreason.com/securityalert/454
http://archives.neohapsis.com/archives/fulldisclosure/2006-02/0469.html
(UNKNOWN)  FULLDISC  20060219 Multiple vulnerabilities in PostNuke <= 0.761

- 漏洞信息

PostNuke多个输入验证漏洞
低危 跨站脚本
2006-02-20 00:00:00 2006-04-07 00:00:00
远程  
        PostNuke 0.761及之前版本中存在解释冲突。远程攻击者可以借助带有"<"字符后缀(在有些web浏览器中会被解释为">",但是会绕过(1)pnAPI.php中pnVarCleanFromInput功能、(2)pnAntiCracker.php中pnSecureInput功能和(3)对user.php进行的edituser操作中的htmltext参数的黑名单保护)的HTML标签进行跨站脚本(XSS)攻击。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        PostNuke Development Team PostNuke 0.62
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.63
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.64
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.7
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.70
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.703
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.71
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.72
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.721
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.726 -3
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.73
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.74
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.75
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.75 -RC3
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.76 RC4
        ostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.76 RC4b
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        PostNuke Development Team PostNuke 0.76 RC4a
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        Cisco Aironet 340 BR340 Firmware 0.761 a
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html
        Cisco Aironet 340 BR340 Firmware 0.761
        PostNuke Development Team PostNuke 0.762.tar.gz
        http://news.postnuke.com/Downloads-req-getit-lid-517.html

- 漏洞信息

23433
PostNuke HTML Tag Filter Bypass
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-19 Unknow
Unknow Unknow

- 解决方案

Upgrade to version .762 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站