CVE-2006-0735
CVSS4.3
发布时间 :2006-02-16 06:02:00
修订时间 :2011-03-07 21:30:43
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in BBcode.pm in M. Blom HTML::BBCode 1.04 and earlier, as used in products such as My Blog before 1.65, allows remote attackers to inject arbitrary Javascript via a javascript URI in an (1) img or (2) url BBcode tag.


[CNNVD]M. Blom HTML::BBCode ‘BBcode.pm’ 跨站脚本攻击漏洞(CNNVD-200602-244)

        M. Blom HTML::BBCode 1.04及之前版本的BBcode.pm中存在跨站脚本攻击(XSS)漏洞,当用于My Blog 1.65之前版本等产品时,远程攻击者可以借助(1) img或(2) url BBcode标签中的javascript URI注入任意Javascript。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:fuzzymonkey:my_blog:1.6
cpe:/a:fuzzymonkey:my_blog:1.64
cpe:/a:fuzzymonkey:my_blog:1.4
cpe:/a:fuzzymonkey:my_blog:1.61
cpe:/a:fuzzymonkey:my_blog:1.62
cpe:/a:fuzzymonkey:my_blog:1.51
cpe:/a:fuzzymonkey:my_blog:1.52
cpe:/a:fuzzymonkey:my_blog:1.23
cpe:/a:fuzzymonkey:my_blog:1.3
cpe:/a:fuzzymonkey:my_blog:1.63
cpe:/a:fuzzymonkey:my_blog:1.0
cpe:/a:fuzzymonkey:my_blog:1.2
cpe:/a:fuzzymonkey:my_blog:1.31
cpe:/a:m_blom:html-bbcode:1.03
cpe:/a:fuzzymonkey:my_blog:1.21
cpe:/a:m_blom:html-bbcode:1.04
cpe:/a:fuzzymonkey:my_blog:1.22
cpe:/a:fuzzymonkey:my_blog:1.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0735
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0735
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-244
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16659
(PATCH)  BID  16659
http://www.securityfocus.com/archive/1/archive/1/425113/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060215 [eVuln] M. Blom HTML::BBCode perl module XSS Vulnerabilities
http://www.securityfocus.com/archive/1/archive/1/425087/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060215 [eVuln] My Blog BBCode XSS Vulnerabilities
http://www.evuln.com/vulns/80/summary.html
(VENDOR_ADVISORY)  MISC  http://www.evuln.com/vulns/80/summary.html
http://secunia.com/advisories/18905
(VENDOR_ADVISORY)  SECUNIA  18905
http://fuzzymonkey.net/forum/viewtopic.php?t=856
(PATCH)  CONFIRM  http://fuzzymonkey.net/forum/viewtopic.php?t=856
http://evuln.com/vulns/80/summary.html
(VENDOR_ADVISORY)  MISC  http://www.evuln.com/vulns/80/summary.html
http://evuln.com/vulns/79/summary.html
(VENDOR_ADVISORY)  MISC  http://evuln.com/vulns/79/summary.html
http://xforce.iss.net/xforce/xfdb/24668
(UNKNOWN)  XF  myblog-bbcode-xss(24668)
http://www.vupen.com/english/advisories/2006/0642
(UNKNOWN)  VUPEN  ADV-2006-0642
http://www.vupen.com/english/advisories/2006/0614
(UNKNOWN)  VUPEN  ADV-2006-0614
http://secunia.com/advisories/18925
(VENDOR_ADVISORY)  SECUNIA  18925
http://menno.b10m.net/perl/HTML-BBCode/Changes
(UNKNOWN)  CONFIRM  http://menno.b10m.net/perl/HTML-BBCode/Changes
http://menno.b10m.net/perl/HTML-BBCode/Changes
(UNKNOWN)  MISC  http://menno.b10m.net/perl/HTML-BBCode/Changes
http://menno.b10m.net/perl/dists/HTML-BBCode-1.05.tar.gz
(UNKNOWN)  CONFIRM  http://menno.b10m.net/perl/dists/HTML-BBCode-1.05.tar.gz

- 漏洞信息

M. Blom HTML::BBCode ‘BBcode.pm’ 跨站脚本攻击漏洞
中危 跨站脚本
2006-02-16 00:00:00 2009-04-03 00:00:00
远程  
        M. Blom HTML::BBCode 1.04及之前版本的BBcode.pm中存在跨站脚本攻击(XSS)漏洞,当用于My Blog 1.65之前版本等产品时,远程攻击者可以借助(1) img或(2) url BBcode标签中的javascript URI注入任意Javascript。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        FuzzyMonkey My Blog 1.63
        FuzzyMonkey blog-1.65.tar.gz
        http://www.fuzzymonkey.net/files/blog-1.65.tar.gz
        M. Blom HTML-BBCode 1.04
        M. Blom HTML-BBCode-1.05.tar.gz
        http://menno.b10m.net/perl/dists/HTML-BBCode-1.05.tar.gz
        M. Blom HTML-BBCode 1.03
        M. Blom HTML-BBCode-1.05.tar.gz
        http://menno.b10m.net/perl/dists/HTML-BBCode-1.05.tar.gz

- 漏洞信息

23179
M. Blom HTML::BBCode Multiple BBCode XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-14 Unknow
2006-02-14 Unknow

- 解决方案

Upgrade to version 1.05 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds. My Blog users can upgrade to version 1.64 to fix this issue.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站