CVE-2006-0713
CVSS5.0
发布时间 :2006-02-15 06:06:00
修订时间 :2011-03-07 21:30:38
NMCO    

[原文]Directory traversal vulnerability in LinPHA 1.0 allows remote attackers to include arbitrary files via .. (dot dot) sequences in the (1) lang parameter in docs/index.php and the language parameter in (2) install/install.php, (3) install/sec_stage_install.php, (4) install/third_stage_install.php, and (5) install/forth_stage_install.php. NOTE: direct static code injection is resultant from this issue, as demonstrated by inserting PHP code into the username, which is inserted into linpha.log, which is accessible from the directory traversal.


[CNNVD]LinPHA多个目录遍历漏洞(CNNVD-200602-227)

        LinPHA 1.0中存在目录遍历漏洞。远程攻击者可以借助(1)docs/index.php中lang参数和(2) install/install.php、(3) install/sec_stage_install.php、(4) install/third_stage_install.php和(5) install/forth_stage_install.php的language参数(该参数中包含..)序列包含任意文件。 注意:可由此问题导致直接静态代码注入,如将PHP代码插入用户名所演示的那样,用户名被插入到linpha.log文件中,而linpha.log文件又可被目录遍历访问。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:linpha:linpha:0.9.3
cpe:/a:linpha:linpha:0.9.2
cpe:/a:linpha:linpha:1.0
cpe:/a:linpha:linpha:0.9.0
cpe:/a:linpha:linpha:0.9.4
cpe:/a:linpha:linpha:0.9.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0713
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0713
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-227
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/0535
(UNKNOWN)  VUPEN  ADV-2006-0535
http://www.securityfocus.com/bid/16592
(UNKNOWN)  BID  16592
http://www.securityfocus.com/archive/1/archive/1/424729/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060211 Linpha <= 1.0 multiple arbitrary local inclusion
http://secunia.com/advisories/18808
(VENDOR_ADVISORY)  SECUNIA  18808
http://retrogod.altervista.org/linpha_10_local.html
(UNKNOWN)  MISC  http://retrogod.altervista.org/linpha_10_local.html
http://xforce.iss.net/xforce/xfdb/24663
(UNKNOWN)  XF  linpha-index-file-include(24663)
http://securityreason.com/securityalert/426
(UNKNOWN)  SREASON  426

- 漏洞信息

LinPHA多个目录遍历漏洞
中危 路径遍历
2006-02-15 00:00:00 2006-02-17 00:00:00
远程  
        LinPHA 1.0中存在目录遍历漏洞。远程攻击者可以借助(1)docs/index.php中lang参数和(2) install/install.php、(3) install/sec_stage_install.php、(4) install/third_stage_install.php和(5) install/forth_stage_install.php的language参数(该参数中包含..)序列包含任意文件。 注意:可由此问题导致直接静态代码注入,如将PHP代码插入用户名所演示的那样,用户名被插入到linpha.log文件中,而linpha.log文件又可被目录遍历访问。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本。

- 漏洞信息

23112
LinPHA index.php lang Parameter Local File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-11 Unknow
2006-02-11 Unknow

- 解决方案

Upgrade to version 1.1.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站