CVE-2006-0695
CVSS7.5
发布时间 :2006-02-15 06:06:00
修订时间 :2011-03-07 21:30:37
NMCO    

[原文]Ansilove before 1.03 does not filter uploaded file extensions, which allows remote attackers to execute arbitrary code by uploading arbitrary files with dangerous extensions, then accessing them directly in the upload directory.


[CNNVD]Ansilove 输入验证漏洞(CNNVD-200602-217)

        Ansilove 1.03之前的版本没有过滤已上传文件的扩展名,从而使得远程攻击者可以借助上传带有危险扩展名的任意文件,然后直接在上传目录中进行访问来执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:ansilove:ansilove:1.02
cpe:/a:ansilove:ansilove:1.01

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0695
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0695
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-217
(官方数据源) CNNVD

- 其它链接及资源

http://sourceforge.net/project/shownotes.php?release_id=392826
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=392826
http://secunia.com/advisories/18810
(VENDOR_ADVISORY)  SECUNIA  18810
http://www.vupen.com/english/advisories/2006/0536
(UNKNOWN)  VUPEN  ADV-2006-0536
http://xforce.iss.net/xforce/xfdb/24684
(UNKNOWN)  XF  ansilove-filename-code-execution(24684)
http://www.securityfocus.com/bid/16603
(UNKNOWN)  BID  16603

- 漏洞信息

Ansilove 输入验证漏洞
高危 输入验证
2006-02-15 00:00:00 2006-02-15 00:00:00
远程  
        Ansilove 1.03之前的版本没有过滤已上传文件的扩展名,从而使得远程攻击者可以借助上传带有危险扩展名的任意文件,然后直接在上传目录中进行访问来执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Ansilove Ansilove 1.01
        Ansilove ansilove-php-1.03.tar.gz
        http://prdownloads.sourceforge.net/ansilove/ansilove-php-1.03.tar.gz?download
        Ansilove Ansilove 1.02
        Ansilove ansilove-php-1.03.tar.gz
        http://prdownloads.sourceforge.net/ansilove/ansilove-php-1.03.tar.gz?download

- 漏洞信息

23101
Ansilove File Upload Arbitrary Command Execution
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-11 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.03 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站