CVE-2006-0664
CVSS4.3
发布时间 :2006-02-13 06:06:00
修订时间 :2011-03-07 21:30:33
NMCOPS    

[原文]Cross-site scripting (XSS) vulnerability in config_defaults_inc.php in Mantis before 1.0 allows remote attackers to inject arbitrary web script or HTML via unknown attack vectors. NOTE: the provenance of this information is unknown; the details are obtained solely from third party information. An original vendor bug report is referenced, but not accessible to the general public.


[CNNVD]Mantis Config_Defaults_Inc.PHP跨站脚本攻击漏洞(CNNVD-200602-170)

        Mantis 1.0之前版本的config_defaults_inc.php中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助未明攻击向量注入任意Web脚本或HTML。注意:此信息的来源不详;详情由第三方独家提供。引用了厂商的一份原始错误报告,但是没有对公众发布。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mantis:mantis:0.19.2
cpe:/a:mantis:mantis:1.0.0a1
cpe:/a:mantis:mantis:0.19.1
cpe:/a:mantis:mantis:1.0.0_rc4
cpe:/a:mantis:mantis:0.19.0_rc1
cpe:/a:mantis:mantis:0.19.0a1
cpe:/a:mantis:mantis:0.18.0a3
cpe:/a:mantis:mantis:0.18.0_rc1
cpe:/a:mantis:mantis:1.0.0_rc2
cpe:/a:mantis:mantis:0.18.3
cpe:/a:mantis:mantis:0.17.4a
cpe:/a:mantis:mantis:0.18.0a2
cpe:/a:mantis:mantis:0.17.1
cpe:/a:mantis:mantis:1.0.0_rc1
cpe:/a:mantis:mantis:0.17.3
cpe:/a:mantis:mantis:0.18a1
cpe:/a:mantis:mantis:0.19.3
cpe:/a:mantis:mantis:0.18.0a4
cpe:/a:mantis:mantis:0.18.2
cpe:/a:mantis:mantis:0.19.0a2
cpe:/a:mantis:mantis:1.0.0a3
cpe:/a:mantis:mantis:0.18
cpe:/a:mantis:mantis:0.19.0
cpe:/a:mantis:mantis:0.17.5
cpe:/a:mantis:mantis:0.19.4
cpe:/a:mantis:mantis:1.0.0_rc3
cpe:/a:mantis:mantis:0.19.0a
cpe:/a:mantis:mantis:0.17.2
cpe:/a:mantis:mantis:0.17.4
cpe:/a:mantis:mantis:1.0.0a2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0664
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0664
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-170
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16561
(PATCH)  BID  16561
http://www.vupen.com/english/advisories/2006/0485
(UNKNOWN)  VUPEN  ADV-2006-0485
http://xforce.iss.net/xforce/xfdb/24585
(UNKNOWN)  XF  mantis-configdefaultsinc-xss(24585)
http://www.debian.org/security/2006/dsa-1133
(UNKNOWN)  DEBIAN  DSA-1133
http://secunia.com/advisories/21400
(UNKNOWN)  SECUNIA  21400

- 漏洞信息

Mantis Config_Defaults_Inc.PHP跨站脚本攻击漏洞
中危 跨站脚本
2006-02-13 00:00:00 2006-02-13 00:00:00
远程  
        Mantis 1.0之前版本的config_defaults_inc.php中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助未明攻击向量注入任意Web脚本或HTML。注意:此信息的来源不详;详情由第三方独家提供。引用了厂商的一份原始错误报告,但是没有对公众发布。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Mantis Mantis 0.10
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.10.1
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.10.2
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.11
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.12
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.13
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.13.1
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.14
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.14.1
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.14.2
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.14.3
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.14.4
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.14.5
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.14.8
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.1
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.10
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.11
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.11
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.12
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.12
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.2
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.3
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.3
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.4
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.5
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.6
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.6
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.7
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.7
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.8
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.8
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.15.9
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.16
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.16 .0
        Mantis mantis-1.0.0.tar.gz
        http://prdownloads.sourceforge.net/mantisbt/mantis-1.0.0.tar.gz
        Mantis Mantis 0.16.1
        Mantis mantis-1.0.0.tar.gz

- 漏洞信息 (F48993)

Debian Linux Security Advisory 1133-1 (PacketStormID:F48993)
2006-08-17 00:00:00
Debian  debian.org
advisory,remote,web,arbitrary,vulnerability
linux,debian
CVE-2006-0664,CVE-2006-0665,CVE-2006-0841,CVE-2006-1577
[点击下载]

Debian Security Advisory 1133-1 - Several remote vulnerabilities have been discovered in the Mantis bug tracking system, which may lead to the execution of arbitrary web scripts.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 1133-1                    security@debian.org
http://www.debian.org/security/                         Moritz Muehlenhoff
August 1st, 2006                        http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : mantis
Vulnerability  : missing input sanitising
Problem-Type   : remote
Debian-specific: no
CVE ID         : CVE-2006-0664 CVE-2006-0665 CVE-2006-0841 CVE-2006-1577
Debian Bug     : 361138 378353

Several remote vulnerabilities have been discovered in the Mantis bug
tracking system, which may lead to the execution of arbitrary web script.
The Common Vulnerabilities and Exposures project identifies the following
problems:

CVE-2006-0664

    A cross-site scripting vulnerability was discovered in
    config_defaults_inc.php.

CVE-2006-0665

    Cross-site scripting vulnerabilities were discovered in query_store.php
    and manage_proj_create.php.

CVE-2006-0841

    Multiple cross-site scripting vulnerabilities were discovered in
    view_all_set.php, manage_user_page.php, view_filters_page.php and
    proj_doc_delete.php.

CVE-2006-1577

    Multiple cross-site scripting vulnerabilities were discovered in
    view_all_set.php.

For the stable distribution (sarge) these problems have been fixed in
version 0.19.2-5sarge4.1.

For the unstable distribution (sid) these problems have been fixed in
version 0.19.4-3.1.

We recommend that you upgrade your mantis package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge4.1.dsc
      Size/MD5 checksum:      586 186850cfa7493513907212591d8c550b
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge4.1.diff.gz
      Size/MD5 checksum:    42068 74a6598eff0b5f741df8c768c060edc4
    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2.orig.tar.gz
      Size/MD5 checksum:  1298615 042c42c6de3bc536181391c1e9b25db3

  Architecture independent components:

    http://security.debian.org/pool/updates/main/m/mantis/mantis_0.19.2-5sarge4.1_all.deb
      Size/MD5 checksum:   897142 6a94215892b6efedd61e042973060022

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFEz7cQXm3vHE4uyloRArHrAJ0ciGLJ5PM/Uzdw3QqKJOQ6Cb9e5wCfUpe2
Na9wvKwxWl0wLXMD//7BQbY=
=n6Lj
-----END PGP SIGNATURE-----

    

- 漏洞信息

23080
Mantis config_defaults_inc.php Unspecified XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-03 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Mantis Config_Defaults_Inc.PHP Cross-Site Scripting Vulnerability
Input Validation Error 16561
Yes No
2006-02-09 12:00:00 2006-09-19 11:21:00
This issue was disclosed by the vendor.

- 受影响的程序版本

Mantis Mantis 1.0 .0RC4
Mantis Mantis 1.0 .0RC3
Mantis Mantis 1.0 .0rc2
Mantis Mantis 1.0 .0rc1
Mantis Mantis 1.0 .0a3
Mantis Mantis 1.0 .0a2
Mantis Mantis 1.0 .0a1
Mantis Mantis 0.19.4
Mantis Mantis 0.19.3
Mantis Mantis 0.19.2
Mantis Mantis 0.19.1
Mantis Mantis 0.19 .0RC1
Mantis Mantis 0.19 .0a2
Mantis Mantis 0.19 .0a1
Mantis Mantis 0.19 .0a
Mantis Mantis 0.19 .0
Mantis Mantis 0.18.3
Mantis Mantis 0.18.2
Mantis Mantis 0.18 a1
Mantis Mantis 0.18 0rc1
Mantis Mantis 0.18 0a4
Mantis Mantis 0.18 0a3
Mantis Mantis 0.18 0a2
Mantis Mantis 0.18
Mantis Mantis 0.17.5
Mantis Mantis 0.17.5
Mantis Mantis 0.17.4 a
Mantis Mantis 0.17.4 a
Mantis Mantis 0.17.4
Mantis Mantis 0.17.4
Mantis Mantis 0.17.3
Mantis Mantis 0.17.3
Mantis Mantis 0.17.2
Mantis Mantis 0.17.2
Mantis Mantis 0.17.1
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
Mantis Mantis 0.17.1
Mantis Mantis 0.17 .0
Mantis Mantis 0.17
Mantis Mantis 0.16.1
Mantis Mantis 0.16.1
Mantis Mantis 0.16 .0
Mantis Mantis 0.16
Mantis Mantis 0.15.12
Mantis Mantis 0.15.12
Mantis Mantis 0.15.11
Mantis Mantis 0.15.11
Mantis Mantis 0.15.10
Mantis Mantis 0.15.9
Mantis Mantis 0.15.9
Mantis Mantis 0.15.8
Mantis Mantis 0.15.8
Mantis Mantis 0.15.7
Mantis Mantis 0.15.7
Mantis Mantis 0.15.6
Mantis Mantis 0.15.6
Mantis Mantis 0.15.5
Mantis Mantis 0.15.5
Mantis Mantis 0.15.4
Mantis Mantis 0.15.4
Mantis Mantis 0.15.3
Mantis Mantis 0.15.3
Mantis Mantis 0.15.2
Mantis Mantis 0.15.1
Mantis Mantis 0.15
Mantis Mantis 0.14.8
Mantis Mantis 0.14.7
Mantis Mantis 0.14.6
Mantis Mantis 0.14.5
Mantis Mantis 0.14.4
Mantis Mantis 0.14.3
Mantis Mantis 0.14.2
Mantis Mantis 0.14.1
Mantis Mantis 0.14
Mantis Mantis 0.13.1
Mantis Mantis 0.13
Mantis Mantis 0.12
Mantis Mantis 0.11.1
Mantis Mantis 0.11
Mantis Mantis 0.10.2
Mantis Mantis 0.10.1
Mantis Mantis 0.10
Mantis Mantis 0.9.1
Mantis Mantis 0.9
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 2.2 r3 unstable
Mantis Mantis 1.0

- 不受影响的程序版本

Mantis Mantis 1.0

- 漏洞讨论

Mantis is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.


Mantis is also prone to an unknown error in the 'query_store.php' and 'manage_proj_create.php' scripts. The exact nature and possible impact of these issues is currently unknown.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released an update to address this issue.

Please see the reference and advisory section for more information.


Mantis Mantis 0.10

Mantis Mantis 0.10.1

Mantis Mantis 0.10.2

Mantis Mantis 0.11

Mantis Mantis 0.12

Mantis Mantis 0.13

Mantis Mantis 0.13.1

Mantis Mantis 0.14

Mantis Mantis 0.14.1

Mantis Mantis 0.14.2

Mantis Mantis 0.14.3

Mantis Mantis 0.14.4

Mantis Mantis 0.14.5

Mantis Mantis 0.14.8

Mantis Mantis 0.15.1

Mantis Mantis 0.15.10

Mantis Mantis 0.15.11

Mantis Mantis 0.15.11

Mantis Mantis 0.15.12

Mantis Mantis 0.15.12

Mantis Mantis 0.15.2

Mantis Mantis 0.15.3

Mantis Mantis 0.15.3

Mantis Mantis 0.15.4

Mantis Mantis 0.15.5

Mantis Mantis 0.15.6

Mantis Mantis 0.15.6

Mantis Mantis 0.15.7

Mantis Mantis 0.15.7

Mantis Mantis 0.15.8

Mantis Mantis 0.15.8

Mantis Mantis 0.15.9

Mantis Mantis 0.16

Mantis Mantis 0.16 .0

Mantis Mantis 0.16.1

Mantis Mantis 0.17 .0

Mantis Mantis 0.17

Mantis Mantis 0.17.1

Mantis Mantis 0.17.1

Mantis Mantis 0.17.2

Mantis Mantis 0.17.2

Mantis Mantis 0.17.3

Mantis Mantis 0.17.3

Mantis Mantis 0.17.4

Mantis Mantis 0.17.4 a

Mantis Mantis 0.17.4 a

Mantis Mantis 0.17.4

Mantis Mantis 0.17.5

Mantis Mantis 0.18 0a2

Mantis Mantis 0.18 0a4

Mantis Mantis 0.18 a1

Mantis Mantis 0.18 0rc1

Mantis Mantis 0.18 0a3

Mantis Mantis 0.18

Mantis Mantis 0.18.2

Mantis Mantis 0.18.3

Mantis Mantis 0.19 .0a2

Mantis Mantis 0.19 .0a1

Mantis Mantis 0.19 .0

Mantis Mantis 0.19 .0a

Mantis Mantis 0.19.1

Mantis Mantis 0.19.2

Mantis Mantis 0.19.3

Mantis Mantis 0.19.4

Mantis Mantis 0.9

Mantis Mantis 0.9.1

Mantis Mantis 1.0 .0rc2

Mantis Mantis 1.0 .0RC3

Mantis Mantis 1.0 .0a1

Mantis Mantis 1.0 .0a2

Mantis Mantis 1.0 .0rc1

Mantis Mantis 1.0 .0a3

Mantis Mantis 1.0 .0RC4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站