CVE-2006-0648
CVSS5.0
发布时间 :2006-02-13 06:06:00
修订时间 :2011-03-07 21:30:30
NMCO    

[原文]Multiple directory traversal vulnerabilities in PHP iCalendar 2.0.1, 2.1, and 2.2 allow remote attackers to include arbitrary files via the (1) getdate and possibly other parameters used in the replace_files function in search.php and (2) $file variable as used in the parse function in functions/template.php.


[CNNVD]PHP ICalendar template.php远程文件包含漏洞(CNNVD-200602-169)

        PHP iCalendar是一款基于PHP的iCal文件浏览器,可在WEB浏览器中显示iCal。
        PHP iCalendar实现上存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。在PHP iCalendar的functions/template.php文件中,parse($file)函数没有过滤变量$file便调用了include($file)。此外,在search.php文件中,没有过滤getdate参数,而参数值中可能包含有文件路径。攻击者可以利用这些漏洞包含任意远端服务器文件,导致执行任意代码。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php_icalendar:php_icalendar:2.0
cpe:/a:php_icalendar:php_icalendar:2.1
cpe:/a:php_icalendar:php_icalendar:2.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0648
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0648
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-169
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/424424/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060208 [eVuln] PHP iCalendar File Inclusion Vulnerability
http://secunia.com/advisories/18778
(VENDOR_ADVISORY)  SECUNIA  18778
http://evuln.com/vulns/70/summary.html
(VENDOR_ADVISORY)  MISC  http://evuln.com/vulns/70/summary.html
http://www.vupen.com/english/advisories/2006/0493
(UNKNOWN)  VUPEN  ADV-2006-0493
http://www.securityfocus.com/bid/16557
(UNKNOWN)  BID  16557
http://phpicalendar.net/forums/viewtopic.php?t=396
(UNKNOWN)  CONFIRM  http://phpicalendar.net/forums/viewtopic.php?t=396
http://xforce.iss.net/xforce/xfdb/24591
(UNKNOWN)  XF  phpicalendar-template-search-file-include(24591)
http://securityreason.com/securityalert/420
(UNKNOWN)  SREASON  420

- 漏洞信息

PHP ICalendar template.php远程文件包含漏洞
中危 路径遍历
2006-02-13 00:00:00 2006-02-13 00:00:00
远程  
        PHP iCalendar是一款基于PHP的iCal文件浏览器,可在WEB浏览器中显示iCal。
        PHP iCalendar实现上存在输入验证漏洞,远程攻击者可能利用此漏洞在服务器上执行任意命令。在PHP iCalendar的functions/template.php文件中,parse($file)函数没有过滤变量$file便调用了include($file)。此外,在search.php文件中,没有过滤getdate参数,而参数值中可能包含有文件路径。攻击者可以利用这些漏洞包含任意远端服务器文件,导致执行任意代码。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.phpicalendar.net

- 漏洞信息

22973
PHP iCalendar template.php file Variable File Inclusion
Remote / Network Access
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-09 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站