CVE-2006-0636
CVSS7.5
发布时间 :2006-02-10 06:02:00
修订时间 :2011-03-07 21:30:29
NMCO    

[原文]desktop.php in eyeOS 0.8.9 and earlier tests for the existence of the _SESSION variable before calling the session_start function, which allows remote attackers to execute arbitrary PHP code and possibly conduct other attacks by modifying critical assumed-immutable variables, as demonstrated using PHP code in the _SESSION[apps][eyeOptions.eyeapp][wrapup] variable.


[CNNVD]EyeOS会话远程命令执行漏洞(CNNVD-200602-135)

        eyeOS 0.8.9及之前版本中的desktop.php在调用session_start功能之前会测试_SESSION变量是否存在,从而使得远程攻击者可以通过修改关键的假定不变变量来执行任意PHP代码,并可能执行其他攻击(如演示中使用_SESSION[apps][eyeOptions.eyeapp][wrapup]变量中的PHP代码) 。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:eyeos_project:eyeos:0.8.2_r1
cpe:/o:eyeos_project:eyeos:0.8.2_r3
cpe:/o:eyeos_project:eyeos:0.8.5_r1
cpe:/o:eyeos_project:eyeos:0.8.1_r1
cpe:/o:eyeos_project:eyeos:0.8
cpe:/o:eyeos_project:eyeos:0.8.2_r2
cpe:/o:eyeos_project:eyeos:0.8.3_r2
cpe:/o:eyeos_project:eyeos:0.8.4_r1
cpe:/o:eyeos_project:eyeos:0.8.9
cpe:/o:eyeos_project:eyeos:0.8.3
cpe:/o:eyeos_project:eyeos:0.8.3_r1
cpe:/o:eyeos_project:eyeos:0.8.6
cpe:/o:eyeos_project:eyeos:0.8.1
cpe:/o:eyeos_project:eyeos:0.8.5
cpe:/o:eyeos_project:eyeos:0.8.4
cpe:/o:eyeos_project:eyeos:0.8.2
cpe:/o:eyeos_project:eyeos:0.8.8
cpe:/o:eyeos_project:eyeos:0.8.7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0636
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0636
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-135
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/424329/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060207 eyeOS <= 0.8.9 Remote Code Execution
http://www.gulftech.org/?node=research&article_id=00096-02072006
(VENDOR_ADVISORY)  MISC  http://www.gulftech.org/?node=research&article_id=00096-02072006
http://www.vupen.com/english/advisories/2006/0466
(UNKNOWN)  VUPEN  ADV-2006-0466
http://xforce.iss.net/xforce/xfdb/24569
(UNKNOWN)  XF  eyeos-desktop-file-include(24569)
http://www.securityfocus.com/bid/16537
(UNKNOWN)  BID  16537
http://securitytracker.com/id?1015609
(UNKNOWN)  SECTRACK  1015609
http://securityreason.com/securityalert/419
(UNKNOWN)  SREASON  419
http://secunia.com/advisories/18757
(UNKNOWN)  SECUNIA  18757

- 漏洞信息

EyeOS会话远程命令执行漏洞
高危 输入验证
2006-02-10 00:00:00 2006-02-10 00:00:00
远程  
        eyeOS 0.8.9及之前版本中的desktop.php在调用session_start功能之前会测试_SESSION变量是否存在,从而使得远程攻击者可以通过修改关键的假定不变变量来执行任意PHP代码,并可能执行其他攻击(如演示中使用_SESSION[apps][eyeOptions.eyeapp][wrapup]变量中的PHP代码) 。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        eyeOS eyeOS 0.8.3
        eyeOS eyeOS-0.8.10.tar.gz
        http://prdownloads.sourceforge.net/eyeos/eyeOS-0.8.10.tar.gz
        eyeOS eyeOS 0.8.3 -r2
        eyeOS eyeOS-0.8.10.tar.gz
        http://prdownloads.sourceforge.net/eyeos/eyeOS-0.8.10.tar.gz
        eyeOS eyeOS 0.8.4 -r1
        eyeOS eyeOS-0.8.10.tar.gz
        http://prdownloads.sourceforge.net/eyeos/eyeOS-0.8.10.tar.gz
        eyeOS eyeOS 0.8.4
        eyeOS eyeOS-0.8.10.tar.gz
        http://prdownloads.sourceforge.net/eyeos/eyeOS-0.8.10.tar.gz
        eyeOS eyeOS 0.8.5
        eyeOS eyeOS-0.8.10.tar.gz
        http://prdownloads.sourceforge.net/eyeos/eyeOS-0.8.10.tar.gz
        eyeOS eyeOS 0.8.9
        eyeOS eyeOS-0.8.10.tar.gz
        http://prdownloads.sourceforge.net/eyeos/eyeOS-0.8.10.tar.gz

- 漏洞信息

23002
eyeOS desktop.php _SESSION Handling Arbitrary PHP Code Execution
Remote / Network Access
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-07 Unknow
2006-02-07 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站