发布时间 :2006-02-08 18:02:00
修订时间 :2008-09-05 16:59:44

[原文]Cross-site scripting (XSS) vulnerability in add.php in Hinton Design phphd 1.0 allows remote attackers to inject arbitrary web script or HTML via unknown vectors.

[CNNVD]Hinton Design PHPHD 跨站脚本攻击漏洞(CNNVD-200602-122)

        Hinton Design phphd 1.0的add.php中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助未明向量注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  phphd-add-xss(24513)
(UNKNOWN)  BID  16586
(UNKNOWN)  BUGTRAQ  20060212 [eVuln] phphd Multiple Vulnerabilities

- 漏洞信息

Hinton Design PHPHD 跨站脚本攻击漏洞
中危 跨站脚本
2006-02-08 00:00:00 2006-02-12 00:00:00
        Hinton Design phphd 1.0的add.php中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助未明向量注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息 (F43801)

EV0060.txt (PacketStormID:F43801)
2006-02-14 00:00:00
Aliaksandr Hartsuyeu
exploit,xss,sql injection

phphd version 1.0 is susceptible to authentication bypass, SQL injection, and cross site scripting attacks.

New eVuln Advisory:
phphd Multiple Vulnerabilities

eVuln ID: EV0060
CVE: CVE-2006-0607 CVE-2006-0608 CVE-2006-0609
Vendor: Hinton Design
Vendor's Web Site:
Software: phphd
Sowtware's Web Site:
Versions: 1.0
Critical Level: Moderate
Type: Multiple Vulnerabilities
Class: Remote
Status: Unpatched. No reply from developer(s)
Exploit: Available
Solution: Not Available
Discovered by: Aliaksandr Hartsuyeu (

1. Authentication Bypass
Vulnerable script: check.php

There are two ways to bypass authentication:

a) SQL Injection
Variable $HTTP_POST_VARS[username] isn't properly sanitized before being used in a SQL query. This can be used to make any SQL query by injecting arbitrary SQL code.
Condition: magic_quotes_gpc - off

b) Cookie based authentication
check.php script dont make password comparisson when identifying user by cookies

2. Multiple Cross-Site Scripting
Vulnerable script: add.php
Most of user-defined data isn't properly sanitized. This can be used to post arbitrary html or script code.

3. Multiple SQL Injections
Vulnerable scripts: all scripts showing some data from database
Most of user-defined data isn't properly sanitized. This can be used to make any SQL query by injecting arbitrary SQL code.
Condition: magic_quotes_gpc - off

Available at:

1. Authentication Bypass

a) SQL Injection
url: http://host/ht/login.php
Username: ' or 1/*
Password: any

b) Cookie based authentication
Cookie: loged=yes
Cookie: username=admin
Cookie: user_level=1
Cookie: userid=1

2. Cross-Site Scripting Example.
Url: http://host/phphd/add.php
Download_name: <XSS>
Version: <XSS>
Download Description: <XSS>

3. SQL Injection Example:
http://host/phphd/view_link.php? file_id=99'% 20union%20select% 201,2,3,4,5, 6,7,8,9,10, 11,12,13,14, 15/*

No Patch available.

Discovered by: Aliaksandr Hartsuyeu (

- 漏洞信息

phphd add.php XSS
Remote / Network Access Input Manipulation
Loss of Integrity Discontinued Product
Exploit Public

- 漏洞描述

phphd contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate unspecified user-submited content upon submission to the 'add.php' script. This may allow a user to create a specially crafted URL that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2006-02-04 Unknow
2006-02-04 Unknow

- 解决方案

The vendor has discontinued this product and therefore has no patch or upgrade that mitigates this problem. It is recommended that an alternate software package be used in its place.

- 相关参考

- 漏洞作者

Unknown or Incomplete