CVE-2006-0597
CVSS7.5
发布时间 :2006-02-13 06:06:00
修订时间 :2008-09-05 16:59:42
NMCOPS    

[原文]Multiple stack-based buffer overflows in elogd.c in elog before 2.5.7 r1558-4 allow attackers to cause a denial of service (application crash) and possibly execute code via long "revision attributes".


[CNNVD]ELOG Web Logbook堆栈的缓冲区溢出漏洞(CNNVD-200602-162)

        elog 2.5.7 r1558-4之前版本的elogd.c中存在多个基于堆栈的缓冲区溢出漏洞。远程攻击者可以借助长"revision属性"造成拒绝服务(应用程序崩溃),并可能执行代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:stefan_ritt:elog_web_logbook:2.2.2
cpe:/a:stefan_ritt:elog_web_logbook:2.2.3
cpe:/a:stefan_ritt:elog_web_logbook:2.1.1
cpe:/a:stefan_ritt:elog_web_logbook:2.5
cpe:/a:stefan_ritt:elog_web_logbook:2.2.1
cpe:/a:stefan_ritt:elog_web_logbook:2.4
cpe:/a:stefan_ritt:elog_web_logbook:2.0.2
cpe:/a:stefan_ritt:elog_web_logbook:2.0.4
cpe:/a:stefan_ritt:elog_web_logbook:2.0.5
cpe:/a:stefan_ritt:elog_web_logbook:2.1.0
cpe:/a:stefan_ritt:elog_web_logbook:2.0.1
cpe:/a:stefan_ritt:elog_web_logbook:2.0.3
cpe:/a:stefan_ritt:elog_web_logbook:2.5.6
cpe:/a:stefan_ritt:elog_web_logbook:2.2.4
cpe:/a:stefan_ritt:elog_web_logbook:2.0.0
cpe:/a:stefan_ritt:elog_web_logbook:2.1.2
cpe:/a:stefan_ritt:elog_web_logbook:2.1.3
cpe:/a:stefan_ritt:elog_web_logbook:2.2.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0597
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0597
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-162
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2006/dsa-967
(VENDOR_ADVISORY)  DEBIAN  DSA-967
http://secunia.com/advisories/18783
(VENDOR_ADVISORY)  SECUNIA  18783
http://www.securityfocus.com/bid/16579
(UNKNOWN)  BID  16579
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=349528
(UNKNOWN)  MISC  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=349528
http://bugs.debian.org/cgi-bin/bugreport.cgi/0001-r1333-Fixed-crashes-with-very-long-revisions-attributes.txt?bug=349528;msg=15;att=1
(UNKNOWN)  MISC  http://bugs.debian.org/cgi-bin/bugreport.cgi/0001-r1333-Fixed-crashes-with-very-long-revisions-attributes.txt?bug=349528;msg=15;att=1
http://xforce.iss.net/xforce/xfdb/24704
(UNKNOWN)  XF  elog-elogd-bo(24704)

- 漏洞信息

ELOG Web Logbook堆栈的缓冲区溢出漏洞
高危 缓冲区溢出
2006-02-13 00:00:00 2006-02-14 00:00:00
远程  
        elog 2.5.7 r1558-4之前版本的elogd.c中存在多个基于堆栈的缓冲区溢出漏洞。远程攻击者可以借助长"revision属性"造成拒绝服务(应用程序崩溃),并可能执行代码。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本。
        log Web Logbook Elog Web Logbook 2.5.7
        Debian elog_2.5.7+r1558-4+sarge2_alpha.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_alpha.deb
        Debian elog_2.5.7+r1558-4+sarge2_amd64.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_amd64.deb
        Debian elog_2.5.7+r1558-4+sarge2_arm.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_arm.deb
        Debian elog_2.5.7+r1558-4+sarge2_hppa.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_hppa.deb
        Debian elog_2.5.7+r1558-4+sarge2_i386.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_i386.deb
        Debian elog_2.5.7+r1558-4+sarge2_ia64.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_ia64.deb
        Debian elog_2.5.7+r1558-4+sarge2_m68k.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_m68k.deb
        Debian elog_2.5.7+r1558-4+sarge2_mips.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_mips.deb
        Debian elog_2.5.7+r1558-4+sarge2_mipsel.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_mipsel.deb
        Debian elog_2.5.7+r1558-4+sarge2_powerpc.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_powerpc.deb
        Debian elog_2.5.7+r1558-4+sarge2_s390.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_s390.deb
        Debian elog_2.5.7+r1558-4+sarge2_sparc.debDebian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4
        +sarge2_sparc.deb

- 漏洞信息 (F43730)

Debian Linux Security Advisory 967-1 (PacketStormID:F43730)
2006-02-13 00:00:00
Debian  debian.org
advisory,vulnerability,code execution
linux,debian
CVE-2006-4439,CVE-2006-0347,CVE-2006-0348,CVE-2006-0597,CVE-2006-0598,CVE-2006-0599,CVE-2006-0600
[点击下载]

Debian Security Advisory DSA 967-1 - Several security problems have been found in elog, an electonic logbook to manage notes. These include, but are not limited to, code executions flaws, directory traversal attacks, and format string vulnerabilities.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 967-1                     security@debian.org
http://www.debian.org/security/                         Moritz Muehlenhoff
February 10th, 2006                     http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : elog
Vulnerability  : several
Problem-Type   : remote
Debian-specific: no
CVE IDs        : CVE-2006-4439 CVE-2006-0347 CVE-2006-0348 CVE-2006-0597
                 CVE-2006-0598 CVE-2006-0599 CVE-2006-0600
Debian Bug     : 349528

Several security problems have been found in elog, an electonic logbook
to manage notes.  The Common Vulnerabilities and Exposures Project
identifies the following problems:

CVE-2005-4439

    "GroundZero Security" discovered that elog insufficiently checks the
    size of a buffer used for processing URL parameters, which might lead
    to the execution of arbitrary code.

CVE-2006-0347

    It was discovered that elog contains a directory traveral vulnerability
    in the processing of "../" sequences in URLs, which might lead to
    information disclosure.

CVE-2006-0348

    The code to write the log file contained a format string vulnerability,
    which might lead to the execution of arbitrary code.

CVE-2006-0597

    Overly long revision attributes might trigger a crash due to a buffer
    overflow.

CVE-2006-0598

    The code to write the log file does not enforce bounds checks properly,
    which might lead to the execution of arbitrary code.

CVE-2006-0599

    elog emitted different errors messages for invalid passwords and invalid
    users, which allows an attacker to probe for valid user names.

CVE-2006-0600

    An attacker could be driven into infinite redirection with a crafted
    "fail" request, which has denial of service potential.

The old stable distribution (woody) does not contain elog packages.

For the stable distribution (sarge) these problems have been fixed in
version 2.5.7+r1558-4+sarge2.

For the unstable distribution (sid) these problems have been fixed in
version 2.6.1+r1642-1.

We recommend that you upgrade your elog package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2.dsc
      Size/MD5 checksum:      581 ed02ecef4eb70c7344532b1a75f893bc
    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2.diff.gz
      Size/MD5 checksum:    21652 ab45bff97bf2e7c42cd5ccca5a80103e
    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558.orig.tar.gz
      Size/MD5 checksum:   538216 e05c9fdaa02692ce20c70a5fd2748fe3

  Alpha architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_alpha.deb
      Size/MD5 checksum:   555270 5cb3aba4fc1303a65984aab4acaf32da

  AMD64 architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_amd64.deb
      Size/MD5 checksum:   511706 5e41b71ee6f3a42d5e7ac033b436c059

  ARM architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_arm.deb
      Size/MD5 checksum:   516094 95f2c045af860501a8e8bad54d0f6958

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_i386.deb
      Size/MD5 checksum:   513918 0dfe3628e07c5cea6f2609683104dbab

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_ia64.deb
      Size/MD5 checksum:   597254 7f83bb7006849edf56411255e0b55e5f

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_hppa.deb
      Size/MD5 checksum:   543576 a09646d99c692e210164fb4a7f58c05a

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_m68k.deb
      Size/MD5 checksum:   482016 b92bbd85b3d1041cbf403070e4aa43c7

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_mips.deb
      Size/MD5 checksum:   521234 33f7d96179fa0b4bd7cd314a33c54e31

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_mipsel.deb
      Size/MD5 checksum:   524336 b30ef21a7a9a958839569cf548fffebb

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_powerpc.deb
      Size/MD5 checksum:   523540 823e5cb99e854a5ba0264259d7116deb

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_s390.deb
      Size/MD5 checksum:   514274 01f3ebd90422c9d94c109f60921c2634

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/e/elog/elog_2.5.7+r1558-4+sarge2_sparc.deb
      Size/MD5 checksum:   518960 661427182cad6ca5a08663ffa505e4ef


  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iD8DBQFD7CzpW5ql+IAeqTIRAr7cAJwKu86gvdgW5UzWatM+8+EDiiSMdwCgnT2b
ttGvVBTdC3n7VV+RsftANhg=
=aKZq
-----END PGP SIGNATURE-----

    

- 漏洞信息

23162
ELOG elogd.c Long revision attributes Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-04-22 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

ELOG Web Logbook Multiple Remote Vulnerabilities
Unknown 16579
Yes No
2006-02-10 12:00:00 2006-12-13 08:53:00
These issues were disclosed in the referenced Debian security advisory.

- 受影响的程序版本

Elog Web Logbook Elog Web Logbook 2.6.1
Elog Web Logbook Elog Web Logbook 2.6 .0
Elog Web Logbook Elog Web Logbook 2.5.7
Elog Web Logbook Elog Web Logbook 2.5.6
Elog Web Logbook Elog Web Logbook 2.5
Elog Web Logbook Elog Web Logbook 2.4
Elog Web Logbook Elog Web Logbook 2.2.4
Elog Web Logbook Elog Web Logbook 2.2.3
Elog Web Logbook Elog Web Logbook 2.2.2
Elog Web Logbook Elog Web Logbook 2.2.1
Elog Web Logbook Elog Web Logbook 2.2 .0
Elog Web Logbook Elog Web Logbook 2.1.3
Elog Web Logbook Elog Web Logbook 2.1.2
Elog Web Logbook Elog Web Logbook 2.1.1
Elog Web Logbook Elog Web Logbook 2.1 .0
Elog Web Logbook Elog Web Logbook 2.0.5
Elog Web Logbook Elog Web Logbook 2.0.4
Elog Web Logbook Elog Web Logbook 2.0.3
Elog Web Logbook Elog Web Logbook 2.0.2
Elog Web Logbook Elog Web Logbook 2.0.1
Elog Web Logbook Elog Web Logbook 2.0 .0
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

ELOG Web Logbook is prone to multiple remote vulnerabilities.

These issues include boundary-condition errors, denial-of-service attacks, and information disclosure.

An attacker can exploit these issues to facilitate a compromise of the application and the underlying computer. This includes crashing the application, executing arbitrary code, and retrieving information that may aid in further attacks.

- 漏洞利用

Exploitation of some of these issues will not require an exploit.

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

Debian Linux has released an advisory to address this issue. Please see the referenced advisory for further information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com


Elog Web Logbook Elog Web Logbook 2.5.7

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站