CVE-2006-0593
CVSS4.3
发布时间 :2006-02-07 20:02:00
修订时间 :2011-03-07 21:30:25
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in PHP-Fusion before 6.00.304 allows remote attackers to inject arbitrary web script or HTML via the (1) shout_name field in shoutbox_panel.php and the (2) comments field in comments_include.php.


[CNNVD]PHP-Fusion多个跨站脚本攻击漏洞(CNNVD-200602-097)

        PHP-Fusion 6.00.304之前的版本中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助(1)shoutbox_panel.php中的shout_name 字段和(2)comments_include.php中的comments字段注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php_fusion:php_fusion:6.00.102
cpe:/a:php_fusion:php_fusion:6.00.109
cpe:/a:php_fusion:php_fusion:6.00.110
cpe:/a:php_fusion:php_fusion:6.00.103
cpe:/a:php_fusion:php_fusion:6.00.108
cpe:/a:php_fusion:php_fusion:6.00.204
cpe:/a:php_fusion:php_fusion:6.00.200
cpe:/a:php_fusion:php_fusion:6.00.205
cpe:/a:php_fusion:php_fusion:6.00.101
cpe:/a:php_fusion:php_fusion:6.00.303
cpe:/a:php_fusion:php_fusion:6.00.104
cpe:/a:php_fusion:php_fusion:6.00.207
cpe:/a:php_fusion:php_fusion:6.00.106
cpe:/a:php_fusion:php_fusion:6.00.300
cpe:/a:php_fusion:php_fusion:6.00.206
cpe:/a:php_fusion:php_fusion:6.00.105
cpe:/a:php_fusion:php_fusion:6.00.100
cpe:/a:php_fusion:php_fusion:6.00.107

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0593
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0593
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-097
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/0463
(UNKNOWN)  VUPEN  ADV-2006-0463
http://www.php-fusion.co.uk/news.php?readmore=307
(UNKNOWN)  CONFIRM  http://www.php-fusion.co.uk/news.php?readmore=307
http://xforce.iss.net/xforce/xfdb/24548
(UNKNOWN)  XF  phpfusion-multiple-xss(24548)
http://www.securityfocus.com/bid/16548
(UNKNOWN)  BID  16548
http://www.php-fusion.co.uk/downloads.php?cat_id=3
(UNKNOWN)  CONFIRM  http://www.php-fusion.co.uk/downloads.php?cat_id=3
http://www.osvdb.org/22981
(UNKNOWN)  OSVDB  22981
http://www.osvdb.org/22980
(UNKNOWN)  OSVDB  22980
http://secunia.com/advisories/18949
(UNKNOWN)  SECUNIA  18949

- 漏洞信息

PHP-Fusion多个跨站脚本攻击漏洞
中危 跨站脚本
2006-02-07 00:00:00 2006-02-08 00:00:00
远程  
        PHP-Fusion 6.00.304之前的版本中存在跨站脚本攻击(XSS)漏洞。远程攻击者可以借助(1)shoutbox_panel.php中的shout_name 字段和(2)comments_include.php中的comments字段注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        PHP-Fusion PHP-Fusion 6.0 303
        PHP-Fusion php-fusion-6.00.304.zip
        PHP-Fusion 6.00.304 fixing PHP-Fusion 6.00.303
        http://ovh.dl.sourceforge.net/sourceforge/php-fusion/php-fusion-6.00.304.zip

- 漏洞信息

22980
PHP-Fusion shoutbox_panel.php shout_name XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

PHP-Fusion contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'shout_name' variable upon submission to the shoutbox_panel.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-02-05 Unknow
2006-02-05 Unknow

- 解决方案

Upgrade to version v6.00.304 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PHP-Fusion Multiple Cross-Site Scripting Vulnerabilities
Input Validation Error 16548
Yes No
2006-02-08 12:00:00 2006-02-08 09:23:00
saxible is credited with the discovery of these vulnerabilities.

- 受影响的程序版本

PHP-Fusion PHP-Fusion 6.0.204
PHP-Fusion PHP-Fusion 6.0.110
PHP-Fusion PHP-Fusion 6.0.109
PHP-Fusion PHP-Fusion 6.0.107
PHP-Fusion PHP-Fusion 6.0.105
PHP-Fusion PHP-Fusion 6.0 303
PHP-Fusion PHP-Fusion 6.0 0.3
PHP-Fusion PHP-Fusion 6.0 .206
PHP-Fusion PHP-Fusion 6.0 .106
PHP-Fusion PHP-Fusion 5.0 1 Service Pack
PHP-Fusion PHP-Fusion 5.0
PHP-Fusion PHP-Fusion 4.0 1
PHP-Fusion PHP-Fusion 4.00
PHP-Fusion PHP-Fusion 6.0 304

- 不受影响的程序版本

PHP-Fusion PHP-Fusion 6.0 304

- 漏洞讨论


PHP-Fusion is prone to multiple cross-site scripting vulnerabilities. These issues are due to a lack of proper sanitization of user-supplied input.

An attacker may leverage these issues to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

Versions 6.00.303 and prior are vulnerable; other versions may also be affected.

- 漏洞利用

No exploit is required.

- 解决方案


The vendor has released version 6.00.304 to address this issue; please see the reference section for further details.


PHP-Fusion PHP-Fusion 6.0 303

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站