CVE-2006-0553
CVSS6.5
发布时间 :2006-02-14 14:06:00
修订时间 :2011-03-07 21:30:17
NMCOS    

[原文]PostgreSQL 8.1.0 through 8.1.2 allows authenticated database users to gain additional privileges via "knowledge of the backend protocol" using a crafted SET ROLE to other database users, a different vulnerability than CVE-2006-0678.


[CNNVD]PostgreSQL远程SET ROLE命令权限提升漏洞(CNNVD-200602-196)

        PostgreSQL是一款高级对象-关系型数据库管理系统,支持扩展的SQL标准子集。
        PostgreSQL在处理特定的SET ROLE处理时存在漏洞,远程攻击者可能利用此漏洞控制服务器的操作系统。远程攻击者可以向PostgreSQL发送有特制参数的SET ROLE命令导致任何登录到数据库的用户都可以获得其他数据库用户的权限,包括超级用户权限。这意味着任何用户都可以访问机器的文件系统并有可能控制服务器的操作系统。

- CVSS (基础分值)

CVSS分值: 6.5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: [--]

- CWE (弱点类目)

CWE-264 [权限、特权与访问控制]

- CPE (受影响的平台与产品)

cpe:/a:postgresql:postgresql:8.1.0
cpe:/a:postgresql:postgresql:8.1.1PostgreSQL 8.1.1
cpe:/a:postgresql:postgresql:8.1.2PostgreSQL 8.1.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0553
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0553
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-196
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/567452
(UNKNOWN)  CERT-VN  VU#567452
http://secunia.com/advisories/18890
(VENDOR_ADVISORY)  SECUNIA  18890
http://xforce.iss.net/xforce/xfdb/24718
(UNKNOWN)  XF  postgresql-setrole-privilege-elevation(24718)
http://www.vupen.com/english/advisories/2006/0605
(UNKNOWN)  VUPEN  ADV-2006-0605
http://www.securityfocus.com/bid/16649
(UNKNOWN)  BID  16649
http://www.securityfocus.com/archive/1/archive/1/425037/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060215 PostgreSQL security releases 8.1.3, 8.0.7, 7.4.12, 7.3.14
http://www.postgresql.org/docs/8.1/static/release.html#RELEASE-8-1-3
(UNKNOWN)  CONFIRM  http://www.postgresql.org/docs/8.1/static/release.html#RELEASE-8-1-3
http://www.openpkg.org/security/OpenPKG-SA-2006.004-postgresql.html
(VENDOR_ADVISORY)  OPENPKG  OpenPKG-SA-2006.004
http://securitytracker.com/id?1015636
(UNKNOWN)  SECTRACK  1015636
http://archives.postgresql.org/pgsql-announce/2006-02/msg00008.php
(UNKNOWN)  MLIST  [pgsql-announce] 20060214 Minor Releases 7.3 thru 8.1 Available to Fix Security Issue

- 漏洞信息

PostgreSQL远程SET ROLE命令权限提升漏洞
中危 访问验证错误
2006-02-14 00:00:00 2006-02-28 00:00:00
远程  
        PostgreSQL是一款高级对象-关系型数据库管理系统,支持扩展的SQL标准子集。
        PostgreSQL在处理特定的SET ROLE处理时存在漏洞,远程攻击者可能利用此漏洞控制服务器的操作系统。远程攻击者可以向PostgreSQL发送有特制参数的SET ROLE命令导致任何登录到数据库的用户都可以获得其他数据库用户的权限,包括超级用户权限。这意味着任何用户都可以访问机器的文件系统并有可能控制服务器的操作系统。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载
        PostgreSQL postgresql-8.1.3.tar.bz2
        http://wwwmaster.postgresql.org/download/mirrors-ftp?file=source%2Fv8.1.3%2Fpostgresql-8.1.3.tar.bz2

- 漏洞信息

23223
PostgreSQL SET ROLE Crafted Argument Privilege Escalation

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 8.1.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PostgreSQL Remote SET ROLE Privilege Escalation Vulnerability
Access Validation Error 16649
Yes No
2006-02-14 12:00:00 2006-02-22 04:22:00
Akio Ishida is credited with the discovery of this vulnerability.

- 受影响的程序版本

PostgreSQL PostgreSQL 8.1.1
PDGSoft Shopping Cart 8.1.2
PDGSoft Shopping Cart 8.1
OpenPKG OpenPKG 2.5
OpenPKG OpenPKG 2.4
OpenPKG OpenPKG 2.3
OpenPKG OpenPKG Current
PostgreSQL PostgreSQL 8.1.3

- 不受影响的程序版本

PostgreSQL PostgreSQL 8.1.3

- 漏洞讨论

PostgreSQL is susceptible to a remote privilege-escalation vulnerability. This issue is due to a flaw in the error path of the 'SET ROLE' function.

This issue allows remote attackers with database access to gain administrative access to affected database servers. Since such access also allows filesystem access, other attacks against the underlying operating system may also be possible.

- 漏洞利用

An exploit is not required.

- 解决方案

Please see the referenced advisories for further information:

- The vendor has released PostgreSQL version 8.1.3, along with an advisory to address this issue.
- OpenPKG has released security advisory OpenPKG-SA-2006.004 to address this issue.


PDGSoft Shopping Cart 8.1

PostgreSQL PostgreSQL 8.1.1

PDGSoft Shopping Cart 8.1.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站