CVE-2006-0539
CVSS4.6
发布时间 :2006-02-03 21:02:00
修订时间 :2011-03-07 21:30:16
NMCO    

[原文]The convert-fcrontab program in fcron 3.0.0 might allow local users to gain privileges via a long command-line argument, which causes Linux glibc to report heap memory corruption, possibly because a strcpy in the strdup2 function can "overwrite some data."


[CNNVD]Fcron Convert-FCronTab本地缓冲区溢出漏洞(CNNVD-200602-050)

        fcron 3.0.0 中的convert-fcrontab程序存在缓存区溢出漏洞,本地用户可以通过长命令行参数获取权限。这会导致Linux glibc报告堆内存损坏,可能是由于strdup2函数中的strcpy"覆盖了某些数据"。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0539
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0539
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-050
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/0435
(UNKNOWN)  VUPEN  ADV-2006-0435
http://www.securityfocus.com/bid/16467
(UNKNOWN)  BID  16467
http://www.securityfocus.com/archive/1/archive/1/423697/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060201 Fcrontab - memory corruption on heap.
http://secunia.com/advisories/18719
(UNKNOWN)  SECUNIA  18719
https://bugs.trustix.org/show_bug.cgi?id=1754
(UNKNOWN)  CONFIRM  https://bugs.trustix.org/show_bug.cgi?id=1754
http://xforce.iss.net/xforce/xfdb/24444
(UNKNOWN)  XF  fcron-syslog-bo(24444)
http://www.trustix.org/errata/2006/0036
(UNKNOWN)  TRUSTIX  2006-0036
http://fcron.free.fr/news.php#a20060206a.xml
(UNKNOWN)  CONFIRM  http://fcron.free.fr/news.php#a20060206a.xml
http://fcron.free.fr/doc/en/changes.html
(UNKNOWN)  CONFIRM  http://fcron.free.fr/doc/en/changes.html
http://archives.neohapsis.com/archives/fulldisclosure/2006-01/0999.html
(UNKNOWN)  FULLDISC  20060201 Fcrontab - memory corruption on heap.

- 漏洞信息

Fcron Convert-FCronTab本地缓冲区溢出漏洞
中危 边界条件错误
2006-02-03 00:00:00 2006-09-05 00:00:00
本地  
        fcron 3.0.0 中的convert-fcrontab程序存在缓存区溢出漏洞,本地用户可以通过长命令行参数获取权限。这会导致Linux glibc报告堆内存损坏,可能是由于strdup2函数中的strcpy"覆盖了某些数据"。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本。

- 漏洞信息

22904
Fcron convert-fcrontab Filename Processing Local Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-02-01 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站