CVE-2006-0517
CVSS7.5
发布时间 :2006-02-02 06:02:00
修订时间 :2011-03-07 21:30:14
NMCO    

[原文]Multiple SQL injection vulnerabilities in formulaires/inc-formulaire_forum.php3 in SPIP 1.8.2-e and earlier and 1.9 Alpha 2 (5539) and earlier allow remote attackers to execute arbitrary SQL commands via the (1) id_forum, (2) id_article, or (3) id_breve parameters to forum.php3; (4) unspecified vectors related to "session handling"; and (5) when posting "petitions".


[CNNVD]SPIP多个SQL注入漏洞(CNNVD-200602-029)

        SPIP 1.8.2-e及之前版本和1.9 Alpha 2 (5539)及之前版本的formulaires/inc-formulaire_forum.php3中存在多个SQL注入漏洞。远程攻击者可以借助(1) id_forum, (2) id_article, (3) id_breve参数(均指向forum.php3);(4) 与"线程处理"相关的未明向量;和(5) 张贴"申请"时来执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:spip:spip:1.9_alpha2_5539
cpe:/a:spip:spip:1.8.2e

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0517
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0517
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-029
(官方数据源) CNNVD

- 其它链接及资源

http://www.zone-h.org/en/advisories/read/id=8650/
(VENDOR_ADVISORY)  MISC  http://www.zone-h.org/en/advisories/read/id=8650/
http://www.vupen.com/english/advisories/2006/0398
(UNKNOWN)  VUPEN  ADV-2006-0398
http://secunia.com/advisories/18676
(VENDOR_ADVISORY)  SECUNIA  18676
http://xforce.iss.net/xforce/xfdb/24397
(UNKNOWN)  XF  spip-forum-sql-injection(24397)
http://www.securityfocus.com/bid/24397
(UNKNOWN)  BID  24397
http://www.securityfocus.com/bid/16458
(UNKNOWN)  BID  16458
http://www.securityfocus.com/archive/1/archive/1/423655/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060131 ZRCSA-200601: SPIP - Multiple Vulnerabilities
http://www.osvdb.org/22848
(UNKNOWN)  OSVDB  22848
http://www.osvdb.org/22845
(UNKNOWN)  OSVDB  22845
http://www.osvdb.org/22844
(UNKNOWN)  OSVDB  22844
http://securitytracker.com/id?1015556
(UNKNOWN)  SECTRACK  1015556
http://securityreason.com/securityalert/395
(UNKNOWN)  SREASON  395
http://archives.neohapsis.com/archives/fulldisclosure/2006-01/0990.html
(UNKNOWN)  FULLDISC  20060131 ZRCSA-200601: SPIP - Multiple Vulnerabilities

- 漏洞信息

SPIP多个SQL注入漏洞
高危 SQL注入
2006-02-02 00:00:00 2006-02-03 00:00:00
远程  
        SPIP 1.8.2-e及之前版本和1.9 Alpha 2 (5539)及之前版本的formulaires/inc-formulaire_forum.php3中存在多个SQL注入漏洞。远程攻击者可以借助(1) id_forum, (2) id_article, (3) id_breve参数(均指向forum.php3);(4) 与"线程处理"相关的未明向量;和(5) 张贴"申请"时来执行任意SQL命令。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本。
        SPIP SPIP 1.9.Alpha 2
        SPIP SPIP
        spip.zip
        http://trac.rezo.net/files/spip/spip.zip
        SPIP SPIP 1.8.2-e
        SPIP SPIP
        spip.zip
        http://trac.rezo.net/files/spip/spip.zip
        SPIP SPIP 1.9.Alpha 1
        SPIP SPIP
        spip.zip
        http://trac.rezo.net/files/spip/spip.zip
        SPIP SPIP 1.8.2-d
        SPIP SPIP
        spip.zip
        http://trac.rezo.net/files/spip/spip.zip

- 漏洞信息

22845
SPIP forum.php3 Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

SPIP contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to forum.php3 not properly sanitizing user input supplied to the 'id_article' and 'id_forum' variables. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-01-31 Unknow
Unknow Unknow

- 解决方案

Upgrade to SVN snapshot 5546 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站