CVE-2006-0497
CVSS7.5
发布时间 :2006-02-01 15:46:00
修订时间 :2011-03-07 21:30:10
NMCOS    

[原文]Multiple SQL injection vulnerabilities in PHP GEN before 1.4 allow remote attackers to inject arbitrary SQL commands via unknown attack vectors.


[CNNVD]PHP GEN 多个SQL注入漏洞(CNNVD-200602-010)

        PHP GEN 1.4之前版本中存在多个SQL注入漏洞。远程攻击者可以通过未知攻击向量注入任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php_gen:php_gen:1.2
cpe:/a:php_gen:php_gen:0.8
cpe:/a:php_gen:php_gen:0.5
cpe:/a:php_gen:php_gen:0.7
cpe:/a:php_gen:php_gen:1.3
cpe:/a:php_gen:php_gen:1.1
cpe:/a:php_gen:php_gen:1.0
cpe:/a:php_gen:php_gen:0.6

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0497
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0497
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-010
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/0408
(UNKNOWN)  VUPEN  ADV-2006-0408
http://www.eyce.be/php_gen/NEWS
(UNKNOWN)  CONFIRM  http://www.eyce.be/php_gen/NEWS
http://xforce.iss.net/xforce/xfdb/24441
(UNKNOWN)  XF  phpgen-multiple-sql-injection(24441)
http://www.securityfocus.com/bid/15458
(UNKNOWN)  BID  15458
http://www.osvdb.org/22885
(UNKNOWN)  OSVDB  22885
http://secunia.com/advisories/18715
(UNKNOWN)  SECUNIA  18715

- 漏洞信息

PHP GEN 多个SQL注入漏洞
高危 SQL注入
2006-02-01 00:00:00 2006-02-03 00:00:00
远程  
        PHP GEN 1.4之前版本中存在多个SQL注入漏洞。远程攻击者可以通过未知攻击向量注入任意SQL命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        PHP GEN PHP GEN 1.3
        PHP GEN php_gen-1.4.tgz
        http://www.eyce.be/php_gen/downloads/php_gen-1.4.tgz

- 漏洞信息

22885
PHP GEN Multiple Unspecified SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

PHP-GEN contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to unspecified script not properly sanitizing user-supplied input to unspecified variable(s). This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-02-01 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHP GEN Unspecified Cross-Site Scripting Vulnerabilities
Input Validation Error 15458
Yes No
2005-05-20 12:00:00 2006-02-07 08:56:00
These issues were announced by the vendor.

- 受影响的程序版本

PHP GEN PHP GEN 1.3
PHP GEN PHP GEN 1.4

- 不受影响的程序版本

PHP GEN PHP GEN 1.4

- 漏洞讨论

PHP GEN is prone to unspecified cross-site scripting vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage these issues to have arbitrary script code executed in the browser of an unsuspecting user in the context of the affected site. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required.

- 解决方案


The vendor has addressed this issue in PHP GEN version 1.3 and in PHP GEN version 1.4. Please see the reference section for further details.


PHP GEN PHP GEN 1.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站