CVE-2006-0477
CVSS7.5
发布时间 :2006-01-31 06:03:00
修订时间 :2011-03-07 21:30:08
NMCO    

[原文]Buffer overflow in git-checkout-index in GIT before 1.1.5 allows remote attackers to execute arbitrary code via an index file with a long symbolic link.


[CNNVD]GIT 缓冲区溢出漏洞(CNNVD-200601-370)

        GIT 1.1.5之前版本的git-checkout-index中存在缓冲区溢出,远程攻击者可以通过具有长符号链接的索引文件执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:git:git:1.0.8
cpe:/a:git:git:1.0.7
cpe:/a:git:git:1.1.2
cpe:/a:git:git:1.1.4
cpe:/a:git:git:1.0.6
cpe:/a:git:git:1.0.5
cpe:/a:git:git:1.1.0
cpe:/a:git:git:1.0.3
cpe:/a:git:git:1.0.0
cpe:/a:git:git:1.0.0b
cpe:/a:git:git:1.0.4
cpe:/a:git:git:1.1.1
cpe:/a:git:git:1.1.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0477
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0477
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-370
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/18643
(VENDOR_ADVISORY)  SECUNIA  18643
http://lwn.net/Articles/169623/
(PATCH)  CONFIRM  http://lwn.net/Articles/169623/
http://www.vupen.com/english/advisories/2006/0367
(UNKNOWN)  VUPEN  ADV-2006-0367
http://xforce.iss.net/xforce/xfdb/24360
(UNKNOWN)  XF  git-gitcheckoutindex-bo(24360)
http://www.securityfocus.com/bid/16417
(UNKNOWN)  BID  16417

- 漏洞信息

GIT 缓冲区溢出漏洞
高危 缓冲区溢出
2006-01-31 00:00:00 2006-02-01 00:00:00
远程  
        GIT 1.1.5之前版本的git-checkout-index中存在缓冲区溢出,远程攻击者可以通过具有长符号链接的索引文件执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        GIT GIT 1.1.4
        GIT git-1.1.5.tar.gz
        http://www.kernel.org/pub/software/scm/git/git-1.1.5.tar.gz

- 漏洞信息

22794
GIT git-checkout-index Symbolic Link Handling Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-01-27 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.1.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站