发布时间 :2006-01-26 17:03:00
修订时间 :2008-09-05 16:59:17

[原文]index.php in Phpclanwebsite 1.23.1 allows remote authenticated users to obtain the installation path by specifying an invalid file name to the uploader page, as demonstrated by "\", which will display the full path of uploader.php. NOTE: this might be the result of a file inclusion vulnerability.

[CNNVD]Phpclanwebsite 输入验证漏洞(CNNVD-200601-342)

        Phpclanwebsite 1.23.1中的index.php存在输入验证漏洞,远程认证的用户可以对上传程序页面指定无效文件名(如以"\"表示),从而导致显示uploader.php的完整路径,以此来获取安装路径。注意:这可能是文件包含漏洞导致的。

- CVSS (基础分值)

CVSS分值: 4 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BID  16391
(VENDOR_ADVISORY)  BUGTRAQ  20060125 HYSA-2006-002 Phpclanwebsite 1.23.1 Multiple Vulnerabilities

- 漏洞信息

Phpclanwebsite 输入验证漏洞
中危 输入验证
2006-01-26 00:00:00 2006-02-21 00:00:00
        Phpclanwebsite 1.23.1中的index.php存在输入验证漏洞,远程认证的用户可以对上传程序页面指定无效文件名(如以"\"表示),从而导致显示uploader.php的完整路径,以此来获取安装路径。注意:这可能是文件包含漏洞导致的。

- 公告与补丁

        Phpclanwebsite Phpclanwebsite 1.23.1
        Phpclanwebsite Phpclanwebsite_1231_fix.rar

- 漏洞信息

Phpclanwebsite uploader.php Path Disclosure
Remote / Network Access Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

Phpclanwebsite contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when a remote attacker who is logged in as a clan administrator assigns a backslash to an the "page" variable, which will disclose the software's installation path in an error message, resulting in a loss of confidentiality. While such information is relatively low risk, it is often useful in carrying out additional, more focused attacks.

- 时间线

2006-01-25 Unknow
2006-01-25 Unknow

- 解决方案

Currently, there are no known upgrades or patches to correct this issue. It is possible to correct the flaw by implementing the following workaround: add the following code to the end of the config.php file: ini_set('display_errors', false)

- 相关参考

- 漏洞作者