CVE-2006-0440
CVSS5.0
发布时间 :2006-01-26 17:03:00
修订时间 :2008-09-05 16:59:16
NMCOS    

[原文]Text Rider 2.4 allows attackers to bypass authentication and upload files without providing a valid password by obtaining the MD5 hash of the password (possibly via another vulnerability that reads it from a data file), then including the hash in a cookie.


[CNNVD]Imagemagick 堆缓冲区溢出漏洞(CNNVD-200601-347)

        Text Rider 2.4存在堆缓存区溢出漏洞,远程攻击者可以通过获取密码的MD5散列(可能是通过其他漏洞从数据文件中读取的)然后将散列包含在cookie中来绕过认证并上传文件,而无需提供有效的密码。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0440
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0440
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-347
(官方数据源) CNNVD

- 其它链接及资源

http://evuln.com/vulns/46/summary.html
(VENDOR_ADVISORY)  MISC  http://evuln.com/vulns/46/summary.html
http://www.securityfocus.com/archive/1/archive/1/423130/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060124 [eVuln] Text Rider Sensitive Information Disclosure
http://securitytracker.com/id?1015533
(UNKNOWN)  SECTRACK  1015533

- 漏洞信息

Imagemagick 堆缓冲区溢出漏洞
中危 边界条件错误
2006-01-26 00:00:00 2006-01-27 00:00:00
远程  
        Text Rider 2.4存在堆缓存区溢出漏洞,远程攻击者可以通过获取密码的MD5散列(可能是通过其他漏洞从数据文件中读取的)然后将散列包含在cookie中来绕过认证并上传文件,而无需提供有效的密码。

- 公告与补丁

        供应商已发布了更新来解决此问题。请参阅引用的内容了解更多信息。

- 漏洞信息

23659
Text Rider Cookie Credential Authentication Bypass
Remote / Network Access Authentication Management
Loss of Integrity Solution Unknown

- 漏洞描述

- 时间线

2006-03-06 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Imagemagick Image Index Array Remote Heap Buffer Overflow Vulnerability
Boundary Condition Error 22692
Yes No
2006-01-02 12:00:00 2007-02-23 09:16:00
Damian Put <pucik@overflow.pl> discovered this vulnerability.

- 受影响的程序版本

RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux WS 2.1 IA64
RedHat Enterprise Linux WS 2.1
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Enterprise Linux ES 2.1 IA64
RedHat Enterprise Linux ES 2.1
RedHat Desktop 4.0
RedHat Desktop 3.0
RedHat Advanced Workstation for the Itanium Processor 2.1 IA64
RedHat Advanced Workstation for the Itanium Processor 2.1
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Red Hat Enterprise Linux AS 2.1 IA64
Red Hat Enterprise Linux AS 2.1
ImageMagick ImageMagick 6.2.8
ImageMagick ImageMagick 6.2.7
ImageMagick ImageMagick 6.2.6
ImageMagick ImageMagick 6.2.5
ImageMagick ImageMagick 6.2.4 .5
ImageMagick ImageMagick 6.2.4
ImageMagick ImageMagick 6.2.3
ImageMagick ImageMagick 6.2.2
+ Gentoo Linux
ImageMagick ImageMagick 6.2.1
ImageMagick ImageMagick 6.2 .0.7
+ Red Hat Fedora Core3
+ Red Hat Fedora Core2
ImageMagick ImageMagick 6.2 .0.4
+ Gentoo Linux
ImageMagick ImageMagick 6.2
ImageMagick ImageMagick 6.1.8
+ Gentoo Linux
ImageMagick ImageMagick 6.1.7
ImageMagick ImageMagick 6.1.6
ImageMagick ImageMagick 6.1.5
ImageMagick ImageMagick 6.1.4
ImageMagick ImageMagick 6.1.3
ImageMagick ImageMagick 6.1.2
ImageMagick ImageMagick 6.1.1
ImageMagick ImageMagick 6.1
ImageMagick ImageMagick 6.0.8
ImageMagick ImageMagick 6.0.7
+ Red Hat Enterprise Linux AS 4
+ RedHat Desktop 4.0
+ RedHat Enterprise Linux Desktop version 4
+ RedHat Enterprise Linux ES 4
+ RedHat Enterprise Linux WS 4
+ S.u.S.E. Linux Personal 9.2 x86_64
+ S.u.S.E. Linux Personal 9.2
ImageMagick ImageMagick 6.0.6
+ Ubuntu Ubuntu Linux 5.0 4 powerpc
+ Ubuntu Ubuntu Linux 5.0 4 i386
+ Ubuntu Ubuntu Linux 5.0 4 amd64
ImageMagick ImageMagick 6.0.5
+ Turbolinux Home
+ Turbolinux Turbolinux Desktop 10.0
+ Turbolinux Turbolinux Server 10.0
ImageMagick ImageMagick 6.0.4
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
ImageMagick ImageMagick 6.0.3
ImageMagick ImageMagick 6.0.2 .5
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
ImageMagick ImageMagick 6.0.2
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
ImageMagick ImageMagick 6.0.1
ImageMagick ImageMagick 6.0
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
ImageMagick ImageMagick 6.2.9

- 不受影响的程序版本

ImageMagick ImageMagick 6.2.9

- 漏洞讨论

ImageMagick is prone to a remote heap-based buffer-overflow vulnerability because the application fails to properly bounds-check user-supplied input before copying it to an insufficiently sized memory buffer.

Exploiting this issue allows attackers to execute arbitrary machine code in the context of applications that use the ImageMagick library.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: mailto:vuldb@securityfocus.com.

- 解决方案

The vendor released an update to address this issue. Please see the references for more information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站