CVE-2006-0438
CVSS5.0
发布时间 :2006-02-06 17:02:00
修订时间 :2011-03-07 21:30:02
NMCO    

[原文]Cross-site request forgery (CSRF) vulnerability in phpBB 2.0.19, when Link to off-site Avatar or bbcode (IMG) are enabled, allows remote attackers to perform unauthorized actions as a logged in user via a link or IMG tag in a user profile, as demonstrated using links to (1) admin/admin_users.php and (2) modcp.php.


[CNNVD]phpBB 跨站请求伪造漏洞(CNNVD-200602-069)

        phpBB 2.0.19中存在跨站请求伪造(CSRF)漏洞。启用到远程Avatar或bbcode (IMG)的链接后,远程攻击者可以借助用户配置文件中的一个链接或IMG标签(演示中使用到(1) admin/admin_users.php和(2) modcp.php的链接)作为已登录的用户执行未授权的操作。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:phpbb_group:phpbb:2.0.0
cpe:/a:phpbb_group:phpbb:2.0_beta1
cpe:/a:phpbb_group:phpbb:2.0.6c
cpe:/a:phpbb_group:phpbb:2.0.17
cpe:/a:phpbb_group:phpbb:2.0.6
cpe:/a:phpbb_group:phpbb:2.0.9
cpe:/a:phpbb_group:phpbb:2.0.12
cpe:/a:phpbb_group:phpbb:2.0.1
cpe:/a:phpbb_group:phpbb:2.0.6d
cpe:/a:phpbb_group:phpbb:2.0_rc4
cpe:/a:phpbb_group:phpbb:2.0.7a
cpe:/a:phpbb_group:phpbb:2.0.3
cpe:/a:phpbb_group:phpbb:2.0.5
cpe:/a:phpbb_group:phpbb:2.0.16
cpe:/a:phpbb_group:phpbb:2.0.4
cpe:/a:phpbb_group:phpbb:2.0.14
cpe:/a:phpbb_group:phpbb:2.0.10
cpe:/a:phpbb_group:phpbb:2.0_rc3
cpe:/a:phpbb_group:phpbb:2.0.7
cpe:/a:phpbb_group:phpbb:2.0.19
cpe:/a:phpbb_group:phpbb:2.0_rc1
cpe:/a:phpbb_group:phpbb:2.0.18
cpe:/a:phpbb_group:phpbb:2.0.8
cpe:/a:phpbb_group:phpbb:2.0.8a
cpe:/a:phpbb_group:phpbb:2.0.2
cpe:/a:phpbb_group:phpbb:2.0.13
cpe:/a:phpbb_group:phpbb:2.0.11
cpe:/a:phpbb_group:phpbb:2.0.15
cpe:/a:phpbb_group:phpbb:2.0_rc2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0438
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0438
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-069
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/0445
(UNKNOWN)  VUPEN  ADV-2006-0445
http://securityreason.com/achievement_securityalert/31
(UNKNOWN)  SREASONRES  20060203 phpBB 2.0.19 Cross Site Request Forgeries and XSS Admin
http://secunia.com/advisories/18693
(VENDOR_ADVISORY)  SECUNIA  18693
http://xforce.iss.net/xforce/xfdb/24497
(UNKNOWN)  XF  phpbb-referer-header-http-xss(24497)
http://www.osvdb.org/22929
(UNKNOWN)  OSVDB  22929
http://securityreason.com/securityalert/406
(UNKNOWN)  SREASON  406
http://lists.grok.org.uk/pipermail/full-disclosure/2006-February/041920.html
(UNKNOWN)  FULLDISC  20060203 phpBB 2.0.19 Cross Site Request Forgeries and XSS Admin

- 漏洞信息

phpBB 跨站请求伪造漏洞
中危 未知
2006-02-06 00:00:00 2006-02-08 00:00:00
远程  
        phpBB 2.0.19中存在跨站请求伪造(CSRF)漏洞。启用到远程Avatar或bbcode (IMG)的链接后,远程攻击者可以借助用户配置文件中的一个链接或IMG标签(演示中使用到(1) admin/admin_users.php和(2) modcp.php的链接)作为已登录的用户执行未授权的操作。

- 公告与补丁

        

- 漏洞信息

22929
phpBB External Avatar Referer Header Session ID Disclosure
Remote / Network Access
Loss of Confidentiality Solution Unknown

- 漏洞描述

- 时间线

2006-02-03 Unknow
Unknow Unknow

- 解决方案

OSVDB is not aware of a solution for this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站