CVE-2006-0436
CVSS7.2
发布时间 :2006-01-26 06:07:00
修订时间 :2011-03-07 21:30:02
NMCOS    

[原文]Unspecified vulnerability in HP HP-UX B.11.00, B.11.04, and B.11.11 allows local users to gain privileges via unknown attack vectors.


[CNNVD]HP-UX LIBC TZ环境变量本地溢出漏洞(CNNVD-200601-348)

        HP-UX是一款HP公司开发的UNIX操作系统。
        HP-UX的LIBC实现在处理TZ环境变量时存在缓冲区溢出漏洞,本地攻击者可能利用此漏洞提升权限。由于没有在localtime_r()及相关函数中执行充分的边界检查,HP-UX的libc库在处理TZ环境变量时存在栈溢出漏洞。任何使用timezone函数的suid或sgid程序都受这个漏洞影响。成功攻击可能导致权限提升。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:hp:hp-ux:11.4HP HP-UX 11.4
cpe:/o:hp:hp-ux:11.00HP-UX 11.00
cpe:/o:hp:hp-ux:11.11HP-UX 11.11

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:1586HP-UX Local Increased Privilege
oval:org.mitre.oval:def:1577HP-UX Shared Library Privilege Escalation Vulnerability (B.11.00)
oval:org.mitre.oval:def:1453HP-UX Shared Library Privilege Escalation Vulnerability (B.11.11)
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0436
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0436
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-348
(官方数据源) CNNVD

- 其它链接及资源

http://securitytracker.com/id?1015530
(PATCH)  SECTRACK  1015530
http://www2.itrc.hp.com/service/cki/docDisplay.do?docId=c00591401
(UNKNOWN)  HP  HPSBUX02091
http://www2.itrc.hp.com/service/cki/docDisplay.do?docId=c00591401
(UNKNOWN)  HP  SSRT061099
http://www.vupen.com/english/advisories/2006/0322
(UNKNOWN)  VUPEN  ADV-2006-0322
http://xforce.iss.net/xforce/xfdb/24318
(UNKNOWN)  XF  hpux-unspecified-privilege-escalation(24318)
http://support.avaya.com/elmodocs2/security/ASA-2006-025.htm
(UNKNOWN)  CONFIRM  http://support.avaya.com/elmodocs2/security/ASA-2006-025.htm
http://secunia.com/advisories/18600
(UNKNOWN)  SECUNIA  18600
http://secunia.com/advisories/18596
(UNKNOWN)  SECUNIA  18596

- 漏洞信息

HP-UX LIBC TZ环境变量本地溢出漏洞
高危 边界条件错误
2006-01-26 00:00:00 2006-01-26 00:00:00
本地  
        HP-UX是一款HP公司开发的UNIX操作系统。
        HP-UX的LIBC实现在处理TZ环境变量时存在缓冲区溢出漏洞,本地攻击者可能利用此漏洞提升权限。由于没有在localtime_r()及相关函数中执行充分的边界检查,HP-UX的libc库在处理TZ环境变量时存在栈溢出漏洞。任何使用timezone函数的suid或sgid程序都受这个漏洞影响。成功攻击可能导致权限提升。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www1.itrc.hp.com/service/cki/docDisplay.do?hpweb_printable=true&docId=c00591401

- 漏洞信息

22745
HP-UX Unspecified Local Privilege Escalation
Patch / RCS

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-01-12 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

HP-UX LibC TZ Environment Variable Local Buffer Overflow Vulnerability
Boundary Condition Error 20718
No Yes
2006-10-24 12:00:00 2006-11-02 04:57:00
NCC Group reported this issue to the vendor.

- 受影响的程序版本

HP HP-UX B.11.11
HP HP-UX B.11.04
HP HP-UX B.11.00

- 漏洞讨论

HP-UX is prone to a local buffer-overflow vulnerability because it fails to properly bounds-check user-supplied input before copying it into an insufficiently sized buffer.

An attacker can exploit this issue to execute arbitrary code with superuser privileges, completely compromising affected computers.

- 漏洞利用

The following exploit code is available:

- 解决方案

HP has released an advisory along with fixes to address this issue. Please see the referenced advisory for information on obtaining and applying fixes.


HP HP-UX B.11.04

HP HP-UX B.11.00

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站