CVE-2006-0410
CVSS5.0
发布时间 :2006-01-24 21:03:00
修订时间 :2011-03-07 21:30:00
NMCOS    

[原文]SQL injection vulnerability in ADOdb before 4.71, when using PostgreSQL, allows remote attackers to execute arbitrary SQL commands via unspecified attack vectors involving binary strings.


[CNNVD]ADOdb PostgreSQL SQL注入漏洞(CNNVD-200601-311)

        ADOdb 4.71之前版本中存在SQL注入漏洞,在使用PostgreSQL时,远程攻击者可以通过与二进制字符串有关的未指定攻击矢量执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:john_lim:adodb:4.70
cpe:/a:john_lim:adodb:4.66
cpe:/a:john_lim:adodb:4.68

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0410
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0410
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-311
(官方数据源) CNNVD

- 其它链接及资源

http://sourceforge.net/project/shownotes.php?release_id=387862&group_id=42718
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=387862&group_id=42718
http://secunia.com/advisories/18575
(VENDOR_ADVISORY)  SECUNIA  18575
http://xforce.iss.net/xforce/xfdb/24314
(UNKNOWN)  XF  adodb-postgresql-sql-injection(24314)
http://www.vupen.com/english/advisories/2006/0448
(UNKNOWN)  VUPEN  ADV-2006-0448
http://www.vupen.com/english/advisories/2006/0315
(UNKNOWN)  VUPEN  ADV-2006-0315
http://www.securityfocus.com/bid/16364
(UNKNOWN)  BID  16364
http://www.osvdb.org/22705
(UNKNOWN)  OSVDB  22705
http://www.gentoo.org/security/en/glsa/glsa-200604-07.xml
(UNKNOWN)  GENTOO  GLSA-200604-07
http://www.gentoo.org/security/en/glsa/glsa-200602-02.xml
(UNKNOWN)  GENTOO  GLSA-200602-02
http://www.debian.org/security/2006/dsa-1031
(UNKNOWN)  DEBIAN  DSA-1031
http://www.debian.org/security/2006/dsa-1030
(UNKNOWN)  DEBIAN  DSA-1030
http://www.debian.org/security/2006/dsa-1029
(UNKNOWN)  DEBIAN  DSA-1029
http://secunia.com/advisories/19591
(UNKNOWN)  SECUNIA  19591
http://secunia.com/advisories/19590
(UNKNOWN)  SECUNIA  19590
http://secunia.com/advisories/19555
(UNKNOWN)  SECUNIA  19555
http://secunia.com/advisories/18745
(UNKNOWN)  SECUNIA  18745
http://secunia.com/advisories/18732
(UNKNOWN)  SECUNIA  18732
http://secunia.com/advisories/19691
(UNKNOWN)  SECUNIA  19691

- 漏洞信息

ADOdb PostgreSQL SQL注入漏洞
中危 SQL注入
2006-01-24 00:00:00 2006-09-08 00:00:00
远程  
        ADOdb 4.71之前版本中存在SQL注入漏洞,在使用PostgreSQL时,远程攻击者可以通过与二进制字符串有关的未指定攻击矢量执行任意SQL命令。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        ADOdb ADOdb 4.66
        ADOdb adodb471.zip
        http://prdownloads.sourceforge.net/adodb/adodb471.zip
        ADOdb ADOdb 4.68
        ADOdb adodb471.zip
        http://prdownloads.sourceforge.net/adodb/adodb471.zip
        ADOdb ADOdb 4.70
        ADOdb adodb471.zip
        http://prdownloads.sourceforge.net/adodb/adodb471.zip

- 漏洞信息

22705
ADOdb PostgreSQL Binary String SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

ADOdb for PHP contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the software not properly sanitizing user-supplied input containing binary strings submitted to an unspecified script. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-01-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 4.71 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

ADOdb PostgreSQL SQL Injection Vulnerability
Input Validation Error 16364
Yes No
2006-01-24 12:00:00 2006-04-17 08:32:00
Andy Staudacher is credited with the discovery of this vulnerability.

- 受影响的程序版本

PHP Link Directory PHPLD 2.0
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0
ADOdb ADOdb 4.70
ADOdb ADOdb 4.68
ADOdb ADOdb 4.66
ADOdb ADOdb 4.71

- 不受影响的程序版本

ADOdb ADOdb 4.71

- 漏洞讨论


ADOdb is prone to an SQL-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

Successful exploitation could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

This issue affects only ADOdb implementations using PostgreSQL; other databases are not affected.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released an update addressing this issue. Please see the referenced vendor advisories for further information.


ADOdb ADOdb 4.66

ADOdb ADOdb 4.68

ADOdb ADOdb 4.70

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站