CVE-2006-0405
CVSS5.0
发布时间 :2006-01-24 21:03:00
修订时间 :2011-03-07 00:00:00
NMCOS    

[原文]The TIFFFetchShortPair function in tif_dirread.c in libtiff 3.8.0 allows remote attackers to cause a denial of service (application crash) via a crafted TIFF image that triggers a NULL pointer dereference, possibly due to changes in type declarations and/or the TIFFVSetField function.


[CNNVD]LibTIFF TIFFFetchShortPair 拒绝服务漏洞(CNNVD-200601-310)

        libtiff 3.8.0的tif_dirread.c中的TIFFFetchShortPair函数存在拒绝服务漏洞,远程攻击者可以通过可能由于类型声明和/或TIFFVSetField函数中的变更而触发空指针解引用的特制TIFF图像使系统拒绝服务(应用程序崩溃)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0405
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0405
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-310
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/24275
(UNKNOWN)  XF  libtiff-tiffvsetfield-dos(24275)
http://www.vupen.com/english/advisories/2006/0302
(VENDOR_ADVISORY)  VUPEN  ADV-2006-0302
http://www.securityfocus.com/bid/18172
(UNKNOWN)  BID  18172
http://www.gentoo.org/security/en/glsa/glsa-200605-17.xml
(UNKNOWN)  GENTOO  GLSA-200605-17
http://secunia.com/advisories/20345
(VENDOR_ADVISORY)  SECUNIA  20345
http://secunia.com/advisories/18587
(VENDOR_ADVISORY)  SECUNIA  18587
http://bugzilla.remotesensing.org/show_bug.cgi?id=1034
(UNKNOWN)  MISC  http://bugzilla.remotesensing.org/show_bug.cgi?id=1034
http://bugzilla.remotesensing.org/show_bug.cgi?id=1029
(UNKNOWN)  MISC  http://bugzilla.remotesensing.org/show_bug.cgi?id=1029

- 漏洞信息

LibTIFF TIFFFetchShortPair 拒绝服务漏洞
中危 其他
2006-01-24 00:00:00 2006-04-30 00:00:00
远程  
        libtiff 3.8.0的tif_dirread.c中的TIFFFetchShortPair函数存在拒绝服务漏洞,远程攻击者可以通过可能由于类型声明和/或TIFFVSetField函数中的变更而触发空指针解引用的特制TIFF图像使系统拒绝服务(应用程序崩溃)。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本。

- 漏洞信息

22748
LibTIFF TIFFVSetField Null Dereference DoS
Denial of Service
Loss of Availability
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-01-09 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

LibTIFF TIFFFetchShortPair Null Pointer Dereference Denial of Service Vulnerability
Failure to Handle Exceptional Conditions 18172
Yes No
2006-01-23 12:00:00 2006-05-31 05:37:00
Herve Drolon is credited with the discovery of this vulnerability.

- 受影响的程序版本

LibTIFF LibTIFF 3.8
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
LibTIFF LibTIFF 3.7.3
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
LibTIFF LibTIFF 3.7.2
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
LibTIFF LibTIFF 3.7.1
LibTIFF LibTIFF 3.7
+ Slackware Linux 10.0
+ Slackware Linux -current
LibTIFF LibTIFF 3.6.1
+ Gentoo Linux 1.4
+ Gentoo Linux
+ OpenPKG OpenPKG Current
+ Turbolinux Turbolinux Server 10.0
+ Ubuntu Ubuntu Linux 5.0 4 powerpc
+ Ubuntu Ubuntu Linux 5.0 4 i386
+ Ubuntu Ubuntu Linux 5.0 4 amd64
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
LibTIFF LibTIFF 3.6 .0
LibTIFF LibTIFF 3.5.7
+ Red Hat Fedora Core2
+ Slackware Linux 9.1
+ Slackware Linux 9.0
+ Slackware Linux 8.1
+ Turbolinux Appliance Server Hosting Edition 1.0
+ Turbolinux Appliance Server Workgroup Edition 1.0
+ Turbolinux Turbolinux Desktop 10.0
+ Turbolinux Turbolinux Server 8.0
LibTIFF LibTIFF 3.5.5
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Turbolinux Turbolinux Server 7.0
+ Turbolinux Turbolinux Workstation 8.0
+ Turbolinux Turbolinux Workstation 7.0
LibTIFF LibTIFF 3.5.4
LibTIFF LibTIFF 3.5.3
LibTIFF LibTIFF 3.5.2
LibTIFF LibTIFF 3.5.1
LibTIFF LibTIFF 3.4
Gentoo Linux

- 漏洞讨论

The LibTIFF library is prone to a denial-of-service vulnerability. The library fails to handle exceptional conditions.

Successful exploits of this vulnerability will cause the application using the affected library to crash, effectively denying service to legitimate users.

Version 3.8.0 and prior are considered vulnerable to this issue.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

Currently we are not aware of any official vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com.

Please see the referenced third-party vendor advisories for further information.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站