发布时间 :2006-01-24 21:03:00
修订时间 :2011-03-07 21:29:57

[原文]SQL injection vulnerability in Zoph before 0.5pre1 allows remote attackers to execute arbitrary SQL commands.

[CNNVD]Zoph SQL注入漏洞(CNNVD-200601-307)

        Zoph 0.5pre1之前版本中存在SQL注入漏洞,远程攻击者可以执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  XF  zoph-sql-injection(24264)
(UNKNOWN)  VUPEN  ADV-2006-0297
(UNKNOWN)  BID  16347

- 漏洞信息

Zoph SQL注入漏洞
高危 SQL注入
2006-01-24 00:00:00 2006-01-26 00:00:00
        Zoph 0.5pre1之前版本中存在SQL注入漏洞,远程攻击者可以执行任意SQL命令。

- 公告与补丁

        Zoph Zoph 0.4 pre2
        Zoph zoph-0.5pre1.tar.gz
        Zoph Zoph 0.4
        Zoph zoph-0.5pre1.tar.gz
        Zoph Zoph 0.3.3
        Debian zoph_0.3.3-12sarge1_all.debDebian GNU/Linux 3.1 alias sarge

- 漏洞信息

Zoph Multiple Unspecified SQL Injections
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Zoph contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to unspecified script not properly sanitizing user-supplied input to an unspecified variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-01-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.5pre1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Zoph Unspecified SQL Injection Vulnerability
Input Validation Error 16347
Yes No
2006-01-23 12:00:00 2006-07-05 11:14:00
The vendor disclosed this vulnerability.

- 受影响的程序版本

Zoph Zoph 0.3.3
Zoph Zoph 0.4 pre2
Zoph Zoph 0.4
Zoph Zoph 0.3
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Zoph Zoph 0.5 pre1

- 不受影响的程序版本

Zoph Zoph 0.5 pre1

- 漏洞讨论

Zoph is prone to an unspecified SQL-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in an SQL query.

Successful exploitation could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

- 漏洞利用

An exploit is not required.

- 解决方案

The vendor has released an update to address this issue. Please see the referenced advisories for more information and fixes.

Zoph Zoph 0.4 pre2

Zoph Zoph 0.4

Zoph Zoph 0.3.3

- 相关参考