CVE-2006-0353
CVSS3.6
发布时间 :2006-01-22 14:03:00
修订时间 :2011-05-19 00:00:00
NMCOS    

[原文]unix_random.c in lshd for lsh 2.0.1 leaks file descriptors related to the randomness generator, which allows local users to cause a denial of service by truncating the seed file, which prevents the server from starting, or obtain sensitive seed information that could be used to crack keys.


[CNNVD]LSH 访问验证错误(CNNVD-200601-284)

        lsh 2.0.1的lshd中的unix_random.c会泄漏与随机生成器相关的文件描述符,本地用户可以通过截断种子文件从而阻止服务器启动,使系统拒绝服务,或者获取可用来破解密钥的敏感种子信息。

- CVSS (基础分值)

CVSS分值: 3.6 [轻微(LOW)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-200 [信息暴露]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0353
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0353
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-284
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16357
(PATCH)  BID  16357
http://www.debian.org/security/2006/dsa-956
(VENDOR_ADVISORY)  DEBIAN  DSA-956
http://secunia.com/advisories/18623
(VENDOR_ADVISORY)  SECUNIA  18623
http://secunia.com/advisories/18564
(VENDOR_ADVISORY)  SECUNIA  18564
http://xforce.iss.net/xforce/xfdb/24263
(UNKNOWN)  XF  lsh-file-descriptor-leak(24263)
http://www.vupen.com/english/advisories/2006/0301
(VENDOR_ADVISORY)  VUPEN  ADV-2006-0301
http://www.osvdb.org/22695
(UNKNOWN)  OSVDB  22695
http://lists.lysator.liu.se/pipermail/lsh-bugs/2006q1/000467.html
(VENDOR_ADVISORY)  MLIST  [lsh-bugs] SECURITY: lshd leaks fd:s to user shells

- 漏洞信息

LSH 访问验证错误
低危 访问验证错误
2006-01-22 00:00:00 2006-05-01 00:00:00
本地  
        lsh 2.0.1的lshd中的unix_random.c会泄漏与随机生成器相关的文件描述符,本地用户可以通过截断种子文件从而阻止服务器启动,使系统拒绝服务,或者获取可用来破解密钥的敏感种子信息。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        LSH LSH 2.0.1
        Debian lsh-client_2.0.1-3sarge1_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_2. 0.1-3sarge1_alpha.deb
        Debian lsh-client_2.0.1-3sarge1_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_2. 0.1-3sarge1_arm.deb
        Debian lsh-client_2.0.1-3sarge1_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_2. 0.1-3sarge1_hppa.deb
        Debian lsh-client_2.0.1-3sarge1_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_2. 0.1-3sarge1_i386.deb
        Debian lsh-client_2.0.1-3sarge1_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_2. 0.1-3sarge1_ia64.deb
        Debian lsh-client_2.0.1-3sarge1_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_2. 0.1-3sarge1_m68k.deb
        Debian lsh-client_2.0.1-3sarge1_mips.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_2. 0.1-3sarge1_mips.deb
        Debian lsh-client_2.0.1-3sarge1_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_2. 0.1-3sarge1_mipsel.deb
        Debian lsh-client_2.0.1-3sarge1_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_2. 0.1-3sarge1_powerpc.deb
        Debian lsh-client_2.0.1-3sarge1_s390.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_2. 0.1-3sarge1_s390.deb
        Debian lsh-client_2.0.1-3sarge1_sparc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_2. 0.1-3sarge1_sparc.deb
        Debian lsh-server_2.0.1-3sarge1_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_2. 0.1-3sarge1_alpha.deb
        Debian lsh-server_2.0.1-3sarge1_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_2. 0.1-3sarge1_arm.deb
        Debian lsh-server_2.0.1-3sarge1_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_2. 0.1-3sarge1_hppa.deb
        Debian lsh-server_2.0.1-3sarge1_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_2. 0.1-3sarge1_i386.deb
        Debian lsh-server_2.0.1-3sarge1_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_2. 0.1-3sarge1_ia64.deb
        Debian lsh-server_2.0.1-3sarge1_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_2. 0.1-3sarge1_m68k.deb
        Debian lsh-server_2.0.1-3sarge1_mips.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_2. 0.1-3sarge1_mips.deb
        Debian lsh-server_2.0.1-3sarge1_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_2. 0.1-3sarge1_mipsel.deb
        Debian lsh-server_2.0.1-3sarge1_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_2. 0.1-3sarge1_powerpc.deb
        Debian lsh-server_2.0.1-3sarge1_s390.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_2. 0.1-3sarge1_s390.deb
        Debian lsh-utils-doc_2.0.1-3sarge1_all.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-utils-doc _2.0.1-3sarge1_all.deb
        Debian lsh-utils/lsh-server_2.0.1-3sarge1_sparc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_2. 0.1-3sarge1_sparc.deb
        Debian lsh-utils/lsh-utils_2.0.1-3sarge1_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/upda

- 漏洞信息

22695
LSH lshd Seed-file File Descriptor Leak
Local Access Required Denial of Service, Information Disclosure
Loss of Confidentiality, Loss of Integrity
Exploit Unknown

- 漏洞描述

LSH contains a flaw that may lead to an unauthorized information disclosure. The issue is triggered when LSH spawns a new shell for a user. This will leak file descriptors from the 'lshd' daemon to the new process, potentially allowing the user to obtain keying material from the random number generator seed file. This will result in a loss of confidentiality. In addition, the user could truncate that file, denying the 'lshd' daemon access to keying material, causing a Denial-of-Service condition.

- 时间线

2006-01-20 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, the author has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

LSH Seed File File Descriptor Leakage Vulnerability
Access Validation Error 16357
No Yes
2006-01-23 12:00:00 2006-08-16 04:10:00
Discovered by Stefan Pfetzing.

- 受影响的程序版本

LSH LSH 2.0.1
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1

- 漏洞讨论

lsh may leak file descriptors that may allow a local attacker to access sensitive information or to cause a denial-of-service condition.

lsh 2.0.1 is reportedly vulnerable. Other versions may be affected as well.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

The vendor has released a source-code patch to address this issue. The patch is available from the following location:

http://lists.lysator.liu.se/pipermail/lsh-bugs/2006q1/000467.html

Debian has released advisory DSA 956-1 to address this issue. Please see the referenced advisory for more information.


LSH LSH 2.0.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站