发布时间 :2006-01-18 20:03:00
修订时间 :2011-03-07 21:29:45

[原文]Cross-site scripting (XSS) vulnerability in aoblogger 2.3 allows remote attackers to inject arbitrary Javascript via a javascript URI in the BBcode url tag.

[CNNVD]AOblogger 跨站脚本攻击漏洞(CNNVD-200601-206)

        aoblogger 2.3中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过BBcode url标记中的javascript URI注入任意javascript。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-0240
(UNKNOWN)  BID  16286
(UNKNOWN)  XF  aoblogger-url-xss(24141)
(UNKNOWN)  BUGTRAQ  20060117 [eVuln] aoblogger Multiple Vulnerabilities

- 漏洞信息

AOblogger 跨站脚本攻击漏洞
中危 跨站脚本
2006-01-18 00:00:00 2006-01-20 00:00:00
        aoblogger 2.3中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过BBcode url标记中的javascript URI注入任意javascript。

- 公告与补丁

        aoblogger aoblogger 2.3

- 漏洞信息

aoblogger url BBcode XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

aoblogger contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate url BBcode tags upon posting comments. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-01-16 Unknow
2006-01-16 Unknow

- 解决方案

Upgrade to version 2.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

AOblogger Multiple Input Validation Vulnerabilities
Input Validation Error 16286
Yes No
2006-01-17 12:00:00 2006-04-17 10:27:00
Aliaksandr Hartsuyeu is credited with the discovery of these vulnerabilities.

- 受影响的程序版本

aoblogger aoblogger 2.3
aoblogger aoblogger 2.4

- 不受影响的程序版本

aoblogger aoblogger 2.4

- 漏洞讨论

AOblogger is prone to multiple input-validation vulnerabilities. These issues are due to a failure in the application to properly sanitize user-supplied input.

Successful exploitation of these vulnerabilities could allow an attacker to:

- compromise the application
- access, modify, or create data
- steal cookie-based authentication credentials.

An attacker may also be able to exploit vulnerabilities in the underlying database implementation and to launch other attacks.

Version 2.3 is vulnerable; other versions may also be affected.

- 漏洞利用

An exploit is not required.

A BBCode tag script-injection example has been provided:

An SQ- injection example has been provided:
username: username'/*
password: any

An example of new entry creation without proper authorization has been provided:

<form action="" method="post">
<input name="uza" value=1>
<input name="title" value="anytitle">
<textarea name="message">anymessage</textarea>

- 解决方案

The vendor has released version 2.4 to address this.

aoblogger aoblogger 2.3

- 相关参考