发布时间 :2006-01-17 20:51:00
修订时间 :2011-03-07 21:29:39

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Apache Geronimo 1.0 allow remote attackers to inject arbitrary web script or HTML via the (1) time parameter to cal2.jsp and (2) any invalid parameter, which causes an XSS when the log file is viewed by the Web-Access-Log viewer.

[CNNVD]Apache Geronimo跨站脚本攻击漏洞(CNNVD-200601-181)

        Apache Geronimo是Apache软件基金会的开放源码J2EE服务器。
        Apache Geronimo由于没有正确的验证用户输入,导致Geronimo中存在跨站脚本攻击漏洞,远程攻击者可以利用这些漏洞执行任意代码或窃取敏感信息。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  VUPEN  ADV-2006-0217
(UNKNOWN)  BID  16260
(VENDOR_ADVISORY)  BUGTRAQ  20060115 Apache Geronimo 1.0 - CSS and persistent HTML-Injectionvulnerabilities
(UNKNOWN)  XF  geronimo-webaccesslog-viewer-xss(24159)
(UNKNOWN)  XF  geronimo-jspexamples-xss(24158)

- 漏洞信息

Apache Geronimo跨站脚本攻击漏洞
中危 跨站脚本
2006-01-17 00:00:00 2006-02-03 00:00:00
        Apache Geronimo是Apache软件基金会的开放源码J2EE服务器。
        Apache Geronimo由于没有正确的验证用户输入,导致Geronimo中存在跨站脚本攻击漏洞,远程攻击者可以利用这些漏洞执行任意代码或窃取敏感信息。

- 公告与补丁


- 漏洞信息

Apache Tomcat / Geronimo Sample Script cal2.jsp time Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

Apache Tomcat and Geronimo contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'time' variable upon submission to the cal2.jsp script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-01-15 Unknow
2006-01-15 Unknow

- 解决方案

Upgrade to version 1.0.1, 1.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Apache Geronimo Multiple Input Validation Vulnerabilities
Input Validation Error 16260
Yes No
2006-01-16 12:00:00 2008-08-25 10:45:00
Oliver Karow is credited with the discovery of this vulnerability.

- 受影响的程序版本

RedHat Network Satellite (for RHEL 4) 5.1
RedHat Network Satellite (for RHEL 4) 4.2
Red Hat Red Hat Network Satellite Server 5.0
Red Hat Red Hat Network Satellite Server 4.2
Red Hat Network Satellite (for RHEL 3) 4.2
Apache Software Foundation Geronimo 1.0
Apache Software Foundation Geronimo 1.1
Apache Software Foundation Geronimo 1.0.1

- 不受影响的程序版本

Apache Software Foundation Geronimo 1.1
Apache Software Foundation Geronimo 1.0.1

- 漏洞讨论

Apache Geronimo is prone to multiple input-validation vulnerabilities because the application fails to properly sanitize user-supplied input.

A successful exploit could allow an attacker to compromise the application, access or modify data, or steal cookie-based authentication credentials. The attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

- 漏洞利用

An exploit is not required.

Example URIs have been provided:"/><script>alert('Gotcha')</script>"/><script>alert(document.cookie)</script>

- 解决方案

The vendor has released updates to address this issue. Contact the vendor for details on obtaining and applying the appropriate updates.

- 相关参考