CVE-2006-0245
CVSS4.3
发布时间 :2006-01-17 20:51:00
修订时间 :2011-03-07 21:29:38
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in CubeCart 3.0.7-pl1 allow remote attackers to inject arbitrary web script or HTML via the (3) redir, (4) productId, (5) docId, (6) act, and (7) catId parameters in index.php; and the (8) username field in a login action in index.php. NOTE: the cart.php/redir and index.php/searchStr vectors are already covered by CVE-2005-3152.


[CNNVD]CubeCart多个跨站脚本攻击漏洞(CNNVD-200601-163)

        CubeCart 3.0.7-pl1中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以通过以下方式注入任意Web脚本或HTML:index.php中的(3) redir、(4) productId、(5) docId、(6) act和(7) catId参数;以及index.php的登录操作中的(8)用户名字段。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0245
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0245
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-163
(官方数据源) CNNVD

- 其它链接及资源

http://www.vupen.com/english/advisories/2006/0227
(UNKNOWN)  VUPEN  ADV-2006-0227
http://www.securityfocus.com/bid/16259
(UNKNOWN)  BID  16259
http://www.osvdb.org/22471
(UNKNOWN)  OSVDB  22471
http://secunia.com/advisories/18519
(VENDOR_ADVISORY)  SECUNIA  18519
http://lostmon.blogspot.com/2006/01/cubecart-307-pl1-indexphp-multiple.html
(VENDOR_ADVISORY)  MISC  http://lostmon.blogspot.com/2006/01/cubecart-307-pl1-indexphp-multiple.html
http://bugs.cubecart.com/?do=details&id=459
(VENDOR_ADVISORY)  MISC  http://bugs.cubecart.com/?do=details&id=459
http://xforce.iss.net/xforce/xfdb/24177
(UNKNOWN)  XF  cubecart-index-script-xss(24177)

- 漏洞信息

CubeCart多个跨站脚本攻击漏洞
中危 跨站脚本
2006-01-17 00:00:00 2006-08-30 00:00:00
远程  
        CubeCart 3.0.7-pl1中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以通过以下方式注入任意Web脚本或HTML:index.php中的(3) redir、(4) productId、(5) docId、(6) act和(7) catId参数;以及index.php的登录操作中的(8)用户名字段。

- 公告与补丁

        

- 漏洞信息

22471
CubeCart index.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

CubeCart contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'productId', 'docId', 'viewProd', or 'catId' variables upon submission to the index.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-01-16 2005-12-24
2006-01-16 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站