CVE-2006-0228
CVSS7.2
发布时间 :2006-01-17 16:03:00
修订时间 :2011-03-07 21:29:36
NMCO    

[原文]The RBAC functionality in grsecurity before 2.1.8 does not properly handle when the admin role creates a service and then exits the shell without unauthenticating, which causes the service to be restarted with the admin role still active.


[CNNVD]GRSecurity Linux服务以高权限执行漏洞(CNNVD-200601-185)

        Grsecurity Linux是一款开放源代码操作系统。
        Grsecurity Linux处理服务的运行权限时存在漏洞,某些情况下可能导致服务以不必要的高权限执行。Grsecurity安全补丁可能错误地允许服务以高权限运行,如果从管理角色启动服务然后退出Shell的话,就会导致重启的服务仍然存在管理角色。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:grsecurity:grsecurity_kernel_patch:2.0.2
cpe:/a:grsecurity:grsecurity_kernel_patch:2.1.6
cpe:/a:grsecurity:grsecurity_kernel_patch:2.1.2
cpe:/a:grsecurity:grsecurity_kernel_patch:2.1.1
cpe:/a:grsecurity:grsecurity_kernel_patch:2.1.5
cpe:/a:grsecurity:grsecurity_kernel_patch:2.0.1
cpe:/a:grsecurity:grsecurity_kernel_patch:2.1.7
cpe:/a:grsecurity:grsecurity_kernel_patch:2.1.4
cpe:/a:grsecurity:grsecurity_kernel_patch:2.1.3
cpe:/a:grsecurity:grsecurity_kernel_patch:2.1.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0228
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0228
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-185
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16261
(PATCH)  BID  16261
http://secunia.com/advisories/18458
(VENDOR_ADVISORY)  SECUNIA  18458
http://www.vupen.com/english/advisories/2006/0199
(UNKNOWN)  VUPEN  ADV-2006-0199
http://www.grsecurity.org/news.php#grsec218
(UNKNOWN)  CONFIRM  http://www.grsecurity.org/news.php#grsec218
http://xforce.iss.net/xforce/xfdb/24156
(UNKNOWN)  XF  grsecurity-rbac-admin-privileges(24156)

- 漏洞信息

GRSecurity Linux服务以高权限执行漏洞
高危 设计错误
2006-01-17 00:00:00 2006-01-18 00:00:00
远程※本地  
        Grsecurity Linux是一款开放源代码操作系统。
        Grsecurity Linux处理服务的运行权限时存在漏洞,某些情况下可能导致服务以不必要的高权限执行。Grsecurity安全补丁可能错误地允许服务以高权限运行,如果从管理角色启动服务然后退出Shell的话,就会导致重启的服务仍然存在管理角色。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        http://www.grsecurity.org/download.php

- 漏洞信息

22464
grsecurity gradm RBAC Admin Role Unauthentication Security Issue
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-01-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.1.8 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站