CVE-2006-0224
CVSS4.6
发布时间 :2006-01-24 21:03:00
修订时间 :2011-03-07 21:29:36
NMCOS    

[原文]Buffer overflow in Library of Assorted Spiffy Things (LibAST) 0.6.1 and earlier, as used in Eterm and possibly other software, allows local users to execute arbitrary code as the utmp user via a long -X command line argument (alternative configuration file name).


[CNNVD]Eterm LibAST Library缓冲区溢出漏洞(CNNVD-200601-305)

        Library of Assorted Spiffy Things (LibAST) 0.6.1及更早版本中的缓冲区溢出漏洞(用在Eterm和可能的其他软件中),可让本地用户通过长-X命令行参数(备用配置文件名)作为utmp用户执行任意代码。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:libast:libast:0.4
cpe:/a:libast:libast:0.6.1
cpe:/a:libast:libast:0.6
cpe:/a:libast:libast:0.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0224
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0224
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-305
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/423207/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060123 [ Rosiello Security ] Eterm-LibAST Advisory
http://www.securityfocus.com/archive/1/archive/1/423088/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060125 Rosiello Security - Eterm-LibAST Advisory
http://www.rosiello.org/en/read_bugs.php?id=25
(VENDOR_ADVISORY)  MISC  http://www.rosiello.org/en/read_bugs.php?id=25
http://www.vupen.com/english/advisories/2006/0314
(UNKNOWN)  VUPEN  ADV-2006-0314
http://www.securityfocus.com/bid/16350
(UNKNOWN)  BID  16350
http://www.securityfocus.com/archive/1/archive/1/423366/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060123 LibAST 0.7 Release Fixes Security Vulnerability
http://freshmeat.net/projects/libast/?branch_id=17907&release_id=217840
(UNKNOWN)  CONFIRM  http://freshmeat.net/projects/libast/?branch_id=17907&release_id=217840
http://xforce.iss.net/xforce/xfdb/24303
(UNKNOWN)  XF  eterm-libast-filename-bo(24303)
http://www.osvdb.org/22735
(UNKNOWN)  OSVDB  22735
http://www.mandriva.com/security/advisories?name=MDKSA-2006:029
(UNKNOWN)  MANDRIVA  MDKSA-2006:029
http://www.gentoo.org/security/en/glsa/glsa-200601-14.xml
(UNKNOWN)  GENTOO  GLSA-200601-14
http://www.debian.org/security/2006/dsa-976
(UNKNOWN)  DEBIAN  DSA-976
http://securityreason.com/securityalert/373
(UNKNOWN)  SREASON  373
http://secunia.com/advisories/18916
(UNKNOWN)  SECUNIA  18916
http://secunia.com/advisories/18632
(UNKNOWN)  SECUNIA  18632
http://secunia.com/advisories/18586
(UNKNOWN)  SECUNIA  18586

- 漏洞信息

Eterm LibAST Library缓冲区溢出漏洞
中危 缓冲区溢出
2006-01-24 00:00:00 2006-01-31 00:00:00
本地  
        Library of Assorted Spiffy Things (LibAST) 0.6.1及更早版本中的缓冲区溢出漏洞(用在Eterm和可能的其他软件中),可让本地用户通过长-X命令行参数(备用配置文件名)作为utmp用户执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        LibAST LibAST 0.6
        Debian libast2-dev_0.6-0pre2003010606sarge1_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_alpha.deb
        Debian libast2-dev_0.6-0pre2003010606sarge1_amd64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_amd64.deb
        Debian libast2-dev_0.6-0pre2003010606sarge1_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_arm.deb
        Debian libast2-dev_0.6-0pre2003010606sarge1_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_hppa.deb
        Debian libast2-dev_0.6-0pre2003010606sarge1_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_i386.deb
        Debian libast2-dev_0.6-0pre2003010606sarge1_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_ia64.deb
        Debian libast2-dev_0.6-0pre2003010606sarge1_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_m68k.deb
        Debian libast2-dev_0.6-0pre2003010606sarge1_mips.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_mips.deb
        Debian libast2-dev_0.6-0pre2003010606sarge1_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_mipsel.deb
        Debian libast2-dev_0.6-0pre2003010606sarge1_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_powerpc.deb
        Debian libast2-dev_0.6-0pre2003010606sarge1_s390.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_s390.deb
        Debian libast2-dev_0.6-0pre2003010606sarge1_sparc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2-dev_0 .6-0pre2003010606sarge1_sparc.deb
        Debian libast2_0.6-0pre2003010606sarge1_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2_0.6-0 pre2003010606sarge1_alpha.deb
        Debian libast2_0.6-0pre2003010606sarge1_amd64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2_0.6-0 pre2003010606sarge1_amd64.deb
        Debian libast2_0.6-0pre2003010606sarge1_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2_0.6-0 pre2003010606sarge1_arm.deb
        Debian libast2_0.6-0pre2003010606sarge1_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2_0.6-0 pre2003010606sarge1_hppa.deb
        Debian libast2_0.6-0pre2003010606sarge1_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2_0.6-0 pre2003010606sarge1_i386.deb
        Debian libast2_0.6-0pre2003010606sarge1_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2_0.6-0 pre2003010606sarge1_ia64.deb
        Debian libast2_0.6-0pre2003010606sarge1_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2_0.6-0 pre2003010606sarge1_m68k.deb
        Debian libast2_0.6-0pre2003010606sarge1_mips.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2_0.6-0 pre2003010606sarge1_mips.deb
        Debian libast2_0.6-0pre2003010606sarge1_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/pool/updates/main/liba/libast/libast2_0.6-0 pre2003010606sarge1_mipsel.deb
        Debian libast2_0.6-0pre2003010606sarge1_powe

- 漏洞信息

22735
LibAST conf_find_file() Configuration Filename Processing Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-01-23 2006-01-15
Unknow Unknow

- 解决方案

Upgrade to version 0.7 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Eterm LibAST Library Local Buffer Overflow Vulnerability
Boundary Condition Error 16350
No Yes
2006-01-23 12:00:00 2006-12-13 08:13:00
Discovered by Johnny Mast from Rosiello Security.

- 受影响的程序版本

Mandriva Linux Mandrake 2006.0 x86_64
Mandriva Linux Mandrake 2006.0
LibAST LibAST 0.6.1
LibAST LibAST 0.6
LibAST LibAST 0.5
LibAST LibAST 0.4
Gentoo Linux
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0

- 漏洞讨论

Eterm LibAST library is prone to a local buffer-overflow vulnerability.

An attacker can trigger this issue by supplying a long filename through the '-X' option of Eterm. A successful attack can corrupt memory and facilitate arbitrary code execution with the privileges of the 'utmp' user.

LibAST versions 0.6.1 and prior are vulnerable to this issue.

Note that other applications using the affected library may be vulnerable as well.

- 漏洞利用


Exploit code is available.

- 解决方案

LibAST 0.7 has been released to address this issue. Please see the referenced vendor advisories for further information.


LibAST LibAST 0.6

LibAST LibAST 0.5

LibAST LibAST 0.4

LibAST LibAST 0.6.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站