发布时间 :2006-01-16 16:03:00
修订时间 :2008-09-05 16:58:40

[原文]Cross-site scripting (XSS) vulnerability in fullview.php in AlstraSoft Template Seller Pro allows remote attackers to inject arbitrary web script or HTML via the tempid parameter.

[CNNVD]AlstraSoft Template Seller Pro Fullview.PHP跨站脚本攻击漏洞(CNNVD-200601-156)

        AlstraSoft Template Seller Pro的fullview.php中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过tempid参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  template-seller-fullview-xss(24235)
(UNKNOWN)  BID  16233
(UNKNOWN)  BUGTRAQ  20060113 AlstraSoft Template Seller Pro Cross-Site Scripting Vulnerability

- 漏洞信息

AlstraSoft Template Seller Pro Fullview.PHP跨站脚本攻击漏洞
中危 跨站脚本
2006-01-16 00:00:00 2006-05-02 00:00:00
        AlstraSoft Template Seller Pro的fullview.php中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过tempid参数注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

AlstraSoft Template Seller Pro fullview.php tempid Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

AlstraSoft Template Seller Pro contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'tempid' variable upon submission to the 'fullview.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-01-13 Unknow
2006-01-13 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

AlstraSoft Template Seller Pro Fullview.PHP Cross-Site Scripting Vulnerability
Input Validation Error 16233
Yes No
2006-01-13 12:00:00 2007-07-06 06:37:00
Night_Warrior is credited with the discovery of this vulnerability.

- 受影响的程序版本

AlstraSoft Template Seller Pro 3.25
AlstraSoft Template Seller Pro

- 漏洞讨论

Template Seller Pro is prone to a cross-site scripting vulnerability because the application fails to properly sanitize user-supplied input.

An attacker may leverage this issue to execute arbitrary code in the browser of an unsuspecting user in the context of the affected site. This may help the attacker steal cookie-based authentication credentials and launch other attacks.

The discoverer of this vulnerability did not specify which version of this application is vulnerable.

- 漏洞利用

An exploit is not required.

An example URI has been provided:[XSS]

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at:

- 相关参考