CVE-2006-0218
CVSS10.0
发布时间 :2006-01-16 16:03:00
修订时间 :2013-01-03 00:00:00
NMCO    

[原文]Multiple unspecified vulnerabilities in MyBulletinBoard (MyBB) before 1.0.2 have unspecified impact and attack vectors, related to (1) admin/moderate.php, (2) admin/themes.php, (3) inc/functions.php, (4) inc/functions_upload.php, (5) printthread.php, and (6) usercp.php, and probably related to SQL injection. NOTE: it is likely that this issue subsumes CVE-2005-4602 and CVE-2005-4603. However, since the vendor advisory is vague and additional files are mentioned, is is likely that this contains at least one distinct vulnerability from CVE-2005-4602 and CVE-2005-4603.


[CNNVD]MyBulletinBoard 多个未明漏洞(CNNVD-200601-161)

        MyBulletinBoard (MyBB) 1.0.2之前版本中存在多个未指定漏洞,具有未指定的影响和攻击矢量,与以下文件相关:(1) admin/moderate.php、(2) admin/themes.php、(3) inc/functions.php、(4) inc/functions_upload.php、(5) printthread.php和(6) usercp.php,也可能与SQL注入相关。

- CVSS (基础分值)

CVSS分值: 10 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mybb:mybb:1.0:rc2MyBB1.0 Release Candidate 2
cpe:/a:mybb:mybb:1.0:rc1MyBB1.0 Release Candidate 1
cpe:/a:mybb:mybb:1.0:pr2MyBB1.0 Preview Release 2
cpe:/a:mybb:mybb:1.01MyBB1.01
cpe:/a:mybb:mybb:1.0:beta4MyBB1.0 Beta 4
cpe:/a:mybb:mybb:1.0:rc4MyBB1.0 Release Candidate 4
cpe:/a:mybb:mybb:1.0:pr1MyBB1.0 Preview Release 1
cpe:/a:mybb:mybb:1.00MyBB1.00
cpe:/a:mybb:mybb:1.0:rc3MyBB1.0 Release Candidate 3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0218
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0218
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-161
(官方数据源) CNNVD

- 其它链接及资源

http://community.mybboard.net/showthread.php?tid=5852
(VENDOR_ADVISORY)  CONFIRM  http://community.mybboard.net/showthread.php?tid=5852

- 漏洞信息

MyBulletinBoard 多个未明漏洞
危急 SQL注入
2006-01-16 00:00:00 2006-01-17 00:00:00
远程  
        MyBulletinBoard (MyBB) 1.0.2之前版本中存在多个未指定漏洞,具有未指定的影响和攻击矢量,与以下文件相关:(1) admin/moderate.php、(2) admin/themes.php、(3) inc/functions.php、(4) inc/functions_upload.php、(5) printthread.php和(6) usercp.php,也可能与SQL注入相关。

- 公告与补丁

        

- 漏洞信息

22156
MyBulletinBoard (MyBB) usercp.php Multiple Variable POST Method SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

MyBulletinBoard (MyBB) contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the usercp.php script not properly sanitizing user-supplied input to the 'threadmode', 'showcodebuttons' or 'list' variables. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2005-12-09 2005-11-07
Unknow Unknow

- 解决方案

Upgrade to version 1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站