CVE-2006-0200
CVSS9.3
发布时间 :2006-01-13 18:03:00
修订时间 :2011-03-07 21:29:33
NMCO    

[原文]Format string vulnerability in the error-reporting feature in the mysqli extension in PHP 5.1.0 and 5.1.1 might allow remote attackers to execute arbitrary code via format string specifiers in MySQL error messages.


[CNNVD]PHP ext/mysqli格式串处理漏洞(CNNVD-200601-148)

        PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。
        PHP5的mysqli扩展在处理错误信息的输出时存在格式串处理问题,远程攻击者可能利用此漏洞在服务器上执行任意指令,PHP5捆绑了新的mysqli扩展,可使用异常信息得到错误报告。在发送这种错误的异常信息时,会将错误消息用作格式串。在某些条件和配置中,恶意的MySQL服务器或错误的SQL查询(如通过SQL注入)可以触发格式串漏洞,导致远程执行代码。

- CVSS (基础分值)

CVSS分值: 9.3 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-134 []

- CPE (受影响的平台与产品)

cpe:/a:php:php:5.1
cpe:/a:php:php:5.1.1PHP PHP 5.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0200
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0200
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-148
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/24095
(PATCH)  XF  php-extmysqli-format-string(24095)
http://www.securityfocus.com/bid/16219
(PATCH)  BID  16219
http://www.php.net/release_5_1_2.php
(PATCH)  CONFIRM  http://www.php.net/release_5_1_2.php
http://secunia.com/advisories/18431
(VENDOR_ADVISORY)  SECUNIA  18431
http://www.vupen.com/english/advisories/2006/0369
(UNKNOWN)  VUPEN  ADV-2006-0369
http://www.vupen.com/english/advisories/2006/0177
(UNKNOWN)  VUPEN  ADV-2006-0177
http://www.securityfocus.com/archive/1/archive/1/421705/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060112 Advisory 02/2006: PHP ext/mysqli Format String Vulnerability
http://www.hardened-php.net/advisory_022006.113.html
(VENDOR_ADVISORY)  MISC  http://www.hardened-php.net/advisory_022006.113.html
http://securitytracker.com/id?1015485
(UNKNOWN)  SECTRACK  1015485
http://securityreason.com/securityalert/337
(UNKNOWN)  SREASON  337

- 漏洞信息

PHP ext/mysqli格式串处理漏洞
高危 格式化字符串
2006-01-13 00:00:00 2006-01-17 00:00:00
远程  
        PHP是广泛使用的通用目的脚本语言,特别适合于Web开发,可嵌入到HTML中。
        PHP5的mysqli扩展在处理错误信息的输出时存在格式串处理问题,远程攻击者可能利用此漏洞在服务器上执行任意指令,PHP5捆绑了新的mysqli扩展,可使用异常信息得到错误报告。在发送这种错误的异常信息时,会将错误消息用作格式串。在某些条件和配置中,恶意的MySQL服务器或错误的SQL查询(如通过SQL注入)可以触发格式串漏洞,导致远程执行代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        http://www.hardened-php.net/downloads.13.html

- 漏洞信息

22479
PHP mysqli Extension Error Message Format String
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-01-12 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 5.1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站