CVE-2006-0193
CVSS4.3
发布时间 :2006-01-13 06:03:00
修订时间 :2011-03-07 21:29:33
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in the Hosting Control Panel (psoft.hsphere.CP) in Positive Software H-Sphere 2.4.3 Patch 8 and earlier allows remote attackers to inject arbitrary web script or HTML via the login parameter in a login action.


[CNNVD]Positive Software H-Sphere Hosting Control Panel (psoft.hsphere.CP)跨站脚本攻击漏洞(CNNVD-200601-145)

        Positive Software H-Sphere 2.4.3 Patch 8及更早版本的Hosting Control Panel (psoft.hsphere.CP)中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过登录操作中的登录参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:positive_software:h-sphere:2.4.2_patch_2
cpe:/a:positive_software:h-sphere:2.4.1_patch_7
cpe:/a:positive_software:h-sphere:2.4.2
cpe:/a:positive_software:h-sphere:2.4.1
cpe:/a:positive_software:h-sphere:2.4.3_beta_2
cpe:/a:positive_software:h-sphere:2.4.3_patch_8
cpe:/a:positive_software:h-sphere:2.4.2_patch_4
cpe:/a:positive_software:h-sphere:2.4.1_patch_6
cpe:/a:positive_software:h-sphere:2.4.3_patch_1
cpe:/a:positive_software:h-sphere:2.4.3_patch_2
cpe:/a:positive_software:h-sphere:2.4.3_patch_4
cpe:/a:positive_software:h-sphere:2.4.2_patch_3
cpe:/a:positive_software:h-sphere:2.4.3_rc2
cpe:/a:positive_software:h-sphere:2.4.2_rc2
cpe:/a:positive_software:h-sphere:2.4.1_patch_3
cpe:/a:positive_software:h-sphere:2.4.1_patch_1
cpe:/a:positive_software:h-sphere:2.4.3_rc1
cpe:/a:positive_software:h-sphere:2.4.3_patch_3
cpe:/a:positive_software:h-sphere:2.4.3
cpe:/a:positive_software:h-sphere:2.4.2_patch_5
cpe:/a:positive_software:h-sphere:2.4.2_beta_3
cpe:/a:positive_software:h-sphere:2.4.1_patch_5
cpe:/a:positive_software:h-sphere:2.4.2_beta_2
cpe:/a:positive_software:h-sphere:2.4.1_patch_4
cpe:/a:positive_software:h-sphere:2.4.2_beta_1
cpe:/a:positive_software:h-sphere:2.4.3_patch_6
cpe:/a:positive_software:h-sphere:2.4.3_patch_5
cpe:/a:positive_software:h-sphere:2.4.3_beta_1
cpe:/a:positive_software:h-sphere:2.4.1_patch_2
cpe:/a:positive_software:h-sphere:2.4.2_rc1
cpe:/a:positive_software:h-sphere:2.4.2_patch_1
cpe:/a:positive_software:h-sphere:2.4.3_patch_7

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0193
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0193
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-145
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/archive/1/archive/1/421704/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060112 H-Sphere Security Vulnerability
http://www.vupen.com/english/advisories/2006/0172
(UNKNOWN)  VUPEN  ADV-2006-0172
http://www.psoft.net/HSdocumentation/versions/?v=all&p=r
(UNKNOWN)  CONFIRM  http://www.psoft.net/HSdocumentation/versions/?v=all&p=r
http://xforce.iss.net/xforce/xfdb/24096
(UNKNOWN)  XF  hsphere-login-xss(24096)
http://www.psoft.net/HSdocumentation/versions/index.php?v=243p9&p=r
(UNKNOWN)  CONFIRM  http://www.psoft.net/HSdocumentation/versions/index.php?v=243p9&p=r
http://www.osvdb.org/22372
(UNKNOWN)  OSVDB  22372
http://secunia.com/advisories/18447
(UNKNOWN)  SECUNIA  18447

- 漏洞信息

Positive Software H-Sphere Hosting Control Panel (psoft.hsphere.CP)跨站脚本攻击漏洞
中危 跨站脚本
2006-01-13 00:00:00 2006-01-13 00:00:00
远程  
        Positive Software H-Sphere 2.4.3 Patch 8及更早版本的Hosting Control Panel (psoft.hsphere.CP)中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过登录操作中的登录参数注入任意Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

22372
H-Sphere psoft.hsphere.CP login Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

H-Sphere contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'login' variable upon submission to the 'psoft.hsphere.CP' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2006-01-12 2005-12-29
2006-01-12 Unknow

- 解决方案

Upgrade to version 2.4.3 Patch 9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站