CVE-2006-0164
CVSS7.5
发布时间 :2006-01-11 16:03:00
修订时间 :2011-03-07 21:29:28
NMCOS    

[原文]phgstats.inc.php in phgstats before 0.5.1, if register_globals is enabled, allows remote attackers to include arbitrary files and execute arbitrary PHP code by modifying the PHGDIR variable.


[CNNVD]Phgstats Phgstats.Inc.PHP远程文件包含漏洞(CNNVD-200601-113)

        phgstats 0.5.1之前版本中的phgstats.inc.php存在远程文件包含漏洞,在启用register_globals时,远程攻击者可以通过修改PHGDIR来包含任意文件,并执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:woah-projekt:phgstats:0.2
cpe:/a:woah-projekt:phgstats:0.1
cpe:/a:woah-projekt:phgstats:0.4.1
cpe:/a:woah-projekt:phgstats:0.3.1
cpe:/a:woah-projekt:phgstats:0.4
cpe:/a:woah-projekt:phgstats:0.5
cpe:/a:woah-projekt:phgstats:0.4.2
cpe:/a:woah-projekt:phgstats:0.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0164
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0164
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-113
(官方数据源) CNNVD

- 其它链接及资源

http://sourceforge.net/project/shownotes.php?release_id=384232
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=384232
http://secunia.com/advisories/18346
(VENDOR_ADVISORY)  SECUNIA  18346
http://www.vupen.com/english/advisories/2006/0123
(UNKNOWN)  VUPEN  ADV-2006-0123
http://xforce.iss.net/xforce/xfdb/24062
(UNKNOWN)  XF  phgstats-php-file-include(24062)
http://www.securityfocus.com/bid/17469
(UNKNOWN)  BID  17469
http://www.osvdb.org/22302
(UNKNOWN)  OSVDB  22302

- 漏洞信息

Phgstats Phgstats.Inc.PHP远程文件包含漏洞
高危 输入验证
2006-01-11 00:00:00 2006-01-13 00:00:00
远程  
        phgstats 0.5.1之前版本中的phgstats.inc.php存在远程文件包含漏洞,在启用register_globals时,远程攻击者可以通过修改PHGDIR来包含任意文件,并执行任意PHP代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Woah-Projekt Phgstats 0.3
        Woah-Projekt phgstats_0.6.2.tar.gz
        http://prdownloads.sourceforge.net/phgstats/phgstats_0.6.2.tar.gz
        Woah-Projekt Phgstats 0.1
        Woah-Projekt phgstats_0.6.2.tar.gz
        http://prdownloads.sourceforge.net/phgstats/phgstats_0.6.2.tar.gz
        Woah-Projekt Phgstats 0.2
        Woah-Projekt phgstats_0.6.2.tar.gz
        http://prdownloads.sourceforge.net/phgstats/phgstats_0.6.2.tar.gz
        Woah-Projekt Phgstats 0.5
        Woah-Projekt phgstats_0.6.2.tar.gz
        http://prdownloads.sourceforge.net/phgstats/phgstats_0.6.2.tar.gz
        Woah-Projekt Phgstats 0.3.1
        Woah-Projekt phgstats_0.6.2.tar.gz
        http://prdownloads.sourceforge.net/phgstats/phgstats_0.6.2.tar.gz
        Woah-Projekt Phgstats 0.4.1
        Woah-Projekt phgstats_0.6.2.tar.gz
        http://prdownloads.sourceforge.net/phgstats/phgstats_0.6.2.tar.gz
        Woah-Projekt Phgstats 0.4.2
        Woah-Projekt phgstats_0.6.2.tar.gz
        http://prdownloads.sourceforge.net/phgstats/phgstats_0.6.2.tar.gz
        Woah-Projekt Phgstats 0.4.3
        Woah-Projekt phgstats_0.6.2.tar.gz
        http://prdownloads.sourceforge.net/phgstats/phgstats_0.6.2.tar.gz
        Woah-Projekt Phgstats 0.5.1
        Woah-Projekt phgstats_0.6.2.tar.gz
        http://prdownloads.sourceforge.net/phgstats/phgstats_0.6.2.tar.gz

- 漏洞信息

22302
Phgstats phgstats.inc.php phgdir Parameter Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Phgstats contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to phgstats.inc.php not properly sanitizing user input supplied to the 'phgdir' variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2006-01-03 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.5.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Phgstats Phgstats.Inc.PHP Remote File Include Vulnerability
Input Validation Error 17469
Yes No
2006-01-03 12:00:00 2006-04-12 06:27:00
Bjoern Knorr is credited with the discovery of this vulnerability.

- 受影响的程序版本

Woah-Projekt Phgstats 0.5.1
Woah-Projekt Phgstats 0.4.3
Woah-Projekt Phgstats 0.4.2
Woah-Projekt Phgstats 0.4.1
Woah-Projekt Phgstats 0.3.1
Woah-Projekt Phgstats 0.5
Woah-Projekt Phgstats 0.3
Woah-Projekt Phgstats 0.2
Woah-Projekt Phgstats 0.1
Woah-Projekt Phgstats 0.5.2

- 不受影响的程序版本

Woah-Projekt Phgstats 0.5.2

- 漏洞讨论

Phgstats is prone to a remote file-include vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker can exploit this issue to include an arbitrary remote file containing malicious PHP code and execute it in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system; other attacks are also possible.

- 漏洞利用


This issue can be exploited through a web client.

- 解决方案

The vendor has addressed this issue in versions 0.5.2 and later.


Woah-Projekt Phgstats 0.3

Woah-Projekt Phgstats 0.1

Woah-Projekt Phgstats 0.2

Woah-Projekt Phgstats 0.5

Woah-Projekt Phgstats 0.3.1

Woah-Projekt Phgstats 0.4.1

Woah-Projekt Phgstats 0.4.2

Woah-Projekt Phgstats 0.4.3

Woah-Projekt Phgstats 0.5.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站