发布时间 :2006-01-11 16:03:00
修订时间 :2011-03-07 21:29:28

[原文]SQL injection vulnerability in the search module (modules/Search/index.php) of PHPNuke EV 7.7 -R1 allows remote attackers to execute arbitrary SQL commands via the query parameter, which is used by the search field. NOTE: This is a different vulnerability than CVE-2005-3792.

[CNNVD]PHPNuke EV 搜索模块SQL注入漏洞(CNNVD-200601-108)

        PHPNuke EV 7.7 -R1的搜索模块(modules/Search/index.php)中存在SQL注入漏洞,远程攻击者可以通过搜索字段使用的查询参数执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  phpnukeev-search-sql-injection(44978)
(UNKNOWN)  VUPEN  ADV-2006-0120
(UNKNOWN)  BID  16186

- 漏洞信息

PHPNuke EV 搜索模块SQL注入漏洞
高危 SQL注入
2006-01-11 00:00:00 2006-09-23 00:00:00
        PHPNuke EV 7.7 -R1的搜索模块(modules/Search/index.php)中存在SQL注入漏洞,远程攻击者可以通过搜索字段使用的查询参数执行任意SQL命令。

- 公告与补丁


- 漏洞信息

PHPNuke EV modules/Search/index.php query Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

PHPNuke EV contains a flaw that may allow an attacker to carry out an SQL injection attack. The issue is due to the 'modules/Search/index.php' script not properly sanitizing user-supplied input to the 'query' variable. This may allow an attacker to inject or manipulate SQL queries in the back-end database.

- 时间线

2006-01-09 2005-11-21
2006-01-09 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

PHPNuke EV Search Module SQL Injection Vulnerability
Input Validation Error 16186
Yes No
2006-01-09 12:00:00 2007-02-14 11:47:00
lostmon is credited with the discovery of this vulnerability.

- 受影响的程序版本

PHP-Nuke PHP-Nuke 7.7
Firefly Studios Stronghold 2 7.7

- 漏洞讨论

PHPNuke EV is prone to an SQL-injection vulnerability because the application fails to properly sanitize user-supplied input before using it in an SQL query.

A successful exploit could allow an attacker to compromise the application, access or modify data, or exploit vulnerabilities in the underlying database implementation.

PHPNuke EV version 7.7 is vulnerable; earlier versions may also be affected.

- 漏洞利用

No exploit is required.

Example proof-of-concept code has been provided:

navigate to and type in

s%') UNION SELECT 0,user_id,username,user_password,0,0,0,0,0,0 FROM nuke_users/*

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at:

- 相关参考