CVE-2006-0150
CVSS7.5
发布时间 :2006-01-09 18:03:00
修订时间 :2011-09-09 00:00:00
NMCOS    

[原文]Multiple format string vulnerabilities in the auth_ldap_log_reason function in Apache auth_ldap 1.6.0 and earlier allows remote attackers to execute arbitrary code via various vectors, including the username.


[CNNVD]Dave Carrigan Auth_LDAP远程格式化字符串漏洞(CNNVD-200601-049)

        Apache auth_ldap 1.6.0及更早版本的auth_ldap_log_reason函数中存在多个格式化字符串漏洞,远程攻击者可以通过包括用户名在内的各种矢量执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-134 []

- CPE (受影响的平台与产品)

cpe:/a:dave_carrigan:auth_ldap:1.3.3
cpe:/a:dave_carrigan:auth_ldap:1.4.2
cpe:/a:dave_carrigan:auth_ldap:1.3.0
cpe:/a:dave_carrigan:auth_ldap:1.4.3
cpe:/a:dave_carrigan:auth_ldap:1.2.1
cpe:/a:dave_carrigan:auth_ldap:1.2.3
cpe:/a:dave_carrigan:auth_ldap:1.3.2
cpe:/a:dave_carrigan:auth_ldap:1.2.2
cpe:/a:dave_carrigan:auth_ldap:1.2.4
cpe:/a:dave_carrigan:auth_ldap:1.4.0
cpe:/a:dave_carrigan:auth_ldap:1.3.4
cpe:/a:dave_carrigan:auth_ldap:1.6.0
cpe:/a:dave_carrigan:auth_ldap:1.3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0150
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0150
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-049
(官方数据源) CNNVD

- 其它链接及资源

http://wwwnew.mandriva.com/security/advisories?name=MDKSA-2006:017
(VENDOR_ADVISORY)  MANDRIVA  MDKSA-2006:017
http://www.securityfocus.com/bid/16177
(PATCH)  BID  16177
http://www.redhat.com/support/errata/RHSA-2006-0179.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2006:0179
http://www.debian.org/security/2006/dsa-952
(VENDOR_ADVISORY)  DEBIAN  DSA-952
http://secunia.com/advisories/18568
(VENDOR_ADVISORY)  SECUNIA  18568
http://secunia.com/advisories/18412
(VENDOR_ADVISORY)  SECUNIA  18412
http://secunia.com/advisories/18405
(VENDOR_ADVISORY)  SECUNIA  18405
http://secunia.com/advisories/18382
(VENDOR_ADVISORY)  SECUNIA  18382
http://xforce.iss.net/xforce/xfdb/24030
(UNKNOWN)  XF  apache-authldap-format-string(24030)
http://www.vupen.com/english/advisories/2006/0117
(VENDOR_ADVISORY)  VUPEN  ADV-2006-0117
http://www.securityfocus.com/archive/1/archive/1/421286/100/0/threaded
(VENDOR_ADVISORY)  BUGTRAQ  20060109 Digital Armaments Security Advisory 01.09.2006: Apache auth_ldap module Multiple Format Strings Vulnerability
http://www.rudedog.org/auth_ldap/Changes.html
(UNKNOWN)  CONFIRM  http://www.rudedog.org/auth_ldap/Changes.html
http://www.digitalarmaments.com/2006090173928420.html
(VENDOR_ADVISORY)  MISC  http://www.digitalarmaments.com/2006090173928420.html
http://securitytracker.com/id?1015456
(UNKNOWN)  SECTRACK  1015456

- 漏洞信息

Dave Carrigan Auth_LDAP远程格式化字符串漏洞
高危 格式化字符串
2006-01-09 00:00:00 2006-05-10 00:00:00
远程  
        Apache auth_ldap 1.6.0及更早版本的auth_ldap_log_reason函数中存在多个格式化字符串漏洞,远程攻击者可以通过包括用户名在内的各种矢量执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Dave Carrigan auth_ldap 1.2 .X
        Dave Carrigan auth_ldap-1.6.1.tar.gz
        http://www.rudedog.org/auth_ldap/auth_ldap-1.6.1.tar.gz
        Dave Carrigan auth_ldap 1.3 .X
        Dave Carrigan auth_ldap-1.6.1.tar.gz
        http://www.rudedog.org/auth_ldap/auth_ldap-1.6.1.tar.gz
        Dave Carrigan auth_ldap 1.4 .X
        Dave Carrigan auth_ldap-1.6.1.tar.gz
        http://www.rudedog.org/auth_ldap/auth_ldap-1.6.1.tar.gz
        Dave Carrigan auth_ldap 1.6 .0
        Dave Carrigan auth_ldap-1.6.1.tar.gz
        http://www.rudedog.org/auth_ldap/auth_ldap-1.6.1.tar.gz
        Fedora Legacy auth_ldap-1.6.0-4.2.legacy.i386.rpmRed Hat Linux 7.3:
        http://download.fedoralegacy.org/redhat/7.3/updates/i386/auth_ldap-1.6.0-4.2.legacy.i386.rpm

- 漏洞信息

22301
auth_ldap for Apache HTTP Server auth_ldap_log_reason() Function Remote Format String
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade

- 漏洞描述

The auth_ldap module for Apache is susceptible to a remote format-string vulnerability. This issue is due to the application's failure to properly sanitize user-supplied input before using it in the format-specifier of a formatted printing function. This may allow a remote attacker to execute arbitrary code.

- 时间线

2006-01-09 2005-12-22
Unknow Unknow

- 解决方案

Upgrade to version 1.6.1 or higher, as it has been reported to fix this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Dave Carrigan Auth_LDAP Remote Format String Vulnerability
Input Validation Error 16177
Yes No
2006-01-09 12:00:00 2006-08-16 11:40:00
Seregorn <seregon@bughunter.net> discovered this vulnerability.

- 受影响的程序版本

RedHat Linux 7.3 i386
RedHat Enterprise Linux WS 2.1 IA64
RedHat Enterprise Linux WS 2.1
RedHat Enterprise Linux ES 2.1 IA64
RedHat Enterprise Linux ES 2.1
RedHat Advanced Workstation for the Itanium Processor 2.1 IA64
RedHat Advanced Workstation for the Itanium Processor 2.1
Red Hat Enterprise Linux AS 2.1 IA64
Red Hat Enterprise Linux AS 2.1
MandrakeSoft Corporate Server 2.1 x86_64
MandrakeSoft Corporate Server 2.1
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0
Dave Carrigan auth_ldap 1.6 .0
Dave Carrigan auth_ldap 1.4 .X
Dave Carrigan auth_ldap 1.3 .X
Dave Carrigan auth_ldap 1.2 .X
Dave Carrigan auth_ldap 1.6.1

- 不受影响的程序版本

Dave Carrigan auth_ldap 1.6.1

- 漏洞讨论

Dave Carrigan's auth_ldap is susceptible to a remote format-string vulnerability. This issue is due to the application's failure to properly sanitize user-supplied input before using it in the format-specifier of a formatted printing function.

This issue likely arises only if auth_ldap has been enabled and is used for user authentication.

This issue allows remote attackers to execute arbitrary machine code in the context of Apache webservers that use the affected module. This may facilitate the compromise of affected computers.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

Please see the referenced advisories for more information.


Dave Carrigan auth_ldap 1.2 .X

Dave Carrigan auth_ldap 1.3 .X

Dave Carrigan auth_ldap 1.4 .X

Dave Carrigan auth_ldap 1.6 .0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站