CVE-2006-0147
CVSS7.5
发布时间 :2006-01-09 18:03:00
修订时间 :2013-08-30 00:52:39
NMCO    

[原文]Dynamic code evaluation vulnerability in tests/tmssql.php test script in ADOdb for PHP before 4.70, as used in multiple products including (1) Mantis, (2) PostNuke, (3) Moodle, (4) Cacti, (5) Xaraya, (6) PhpOpenChat, possibly (7) MAXdev MD-Pro, and (8) Simplog, allows remote attackers to execute arbitrary PHP functions via the do parameter, which is saved in a variable that is then executed as a function, as demonstrated using phpinfo.


[CNNVD]ADOdb for PHP 'tmssql.php'测试脚本动态代码求值漏洞(CNNVD-200601-079)

        ADOdb for PHP 4.70之前版本的tests/tmssql.php测试脚本中的动态代码求值漏洞(用在多个产品中,包括(1) Mantis、(2) PostNuke、(3) Moodle、(4) Cacti、(5) Xaraya、(6) PhpOpenChat,可能还有(7) MAXdev MD-Pro和(8) Simplog),远程攻击者可以通过保存在随后作为函数执行的变量中的do参数执行任意PHP函数,如使用phpinfo所示。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:moodle:moodle:1.5.3Moodle 1.5.3
cpe:/a:john_lim:adodb:4.66
cpe:/a:mantis:mantis:1.0.0_rc4
cpe:/a:mantis:mantis:0.19.4
cpe:/a:postnuke_software_foundation:postnuke:0.761
cpe:/a:the_cacti_group:cacti:0.8.6g
cpe:/a:john_lim:adodb:4.68

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0147
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0147
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-079
(官方数据源) CNNVD

- 其它链接及资源

http://www.gentoo.org/security/en/glsa/glsa-200604-07.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200604-07
http://www.debian.org/security/2006/dsa-1030
(VENDOR_ADVISORY)  DEBIAN  DSA-1030
http://www.debian.org/security/2006/dsa-1029
(VENDOR_ADVISORY)  DEBIAN  DSA-1029
http://secunia.com/secunia_research/2005-64/advisory/
(VENDOR_ADVISORY)  MISC  http://secunia.com/secunia_research/2005-64/advisory/
http://secunia.com/advisories/19628
(VENDOR_ADVISORY)  SECUNIA  19628
http://secunia.com/advisories/19591
(VENDOR_ADVISORY)  SECUNIA  19591
http://secunia.com/advisories/19590
(VENDOR_ADVISORY)  SECUNIA  19590
http://secunia.com/advisories/19555
(VENDOR_ADVISORY)  SECUNIA  19555
http://secunia.com/advisories/18276
(VENDOR_ADVISORY)  SECUNIA  18276
http://secunia.com/advisories/18260
(VENDOR_ADVISORY)  SECUNIA  18260
http://secunia.com/advisories/18254
(VENDOR_ADVISORY)  SECUNIA  18254
http://secunia.com/advisories/18233
(VENDOR_ADVISORY)  SECUNIA  18233
http://secunia.com/advisories/17418
(VENDOR_ADVISORY)  SECUNIA  17418
http://www.vupen.com/english/advisories/2006/1332
(UNKNOWN)  VUPEN  ADV-2006-1332
http://www.vupen.com/english/advisories/2006/1305
(UNKNOWN)  VUPEN  ADV-2006-1305
http://www.vupen.com/english/advisories/2006/0104
(UNKNOWN)  VUPEN  ADV-2006-0104
http://www.vupen.com/english/advisories/2006/0103
(UNKNOWN)  VUPEN  ADV-2006-0103
http://www.vupen.com/english/advisories/2006/0102
(UNKNOWN)  VUPEN  ADV-2006-0102
http://www.vupen.com/english/advisories/2006/0101
(UNKNOWN)  VUPEN  ADV-2006-0101
http://www.securityfocus.com/archive/1/archive/1/430743/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060412 Simplog <=0.9.2 multiple vulnerabilities
http://www.securityfocus.com/archive/1/archive/1/430448/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060409 PhpOpenChat 3.0.x ADODB Server.php "sql" SQL injection
http://www.osvdb.org/22291
(UNKNOWN)  OSVDB  22291
http://www.debian.org/security/2006/dsa-1031
(UNKNOWN)  DEBIAN  DSA-1031
http://secunia.com/advisories/19600
(VENDOR_ADVISORY)  SECUNIA  19600
http://secunia.com/advisories/18267
(VENDOR_ADVISORY)  SECUNIA  18267
http://retrogod.altervista.org/simplog_092_incl_xpl.html
(UNKNOWN)  MISC  http://retrogod.altervista.org/simplog_092_incl_xpl.html
http://retrogod.altervista.org/phpopenchat_30x_sql_xpl.html
(UNKNOWN)  MISC  http://retrogod.altervista.org/phpopenchat_30x_sql_xpl.html
http://milw0rm.com/exploits/1663
(UNKNOWN)  MILW0RM  1663
http://xforce.iss.net/xforce/xfdb/24052
(UNKNOWN)  XF  adodb-tmssql-command-execution(24052)
http://secunia.com/advisories/19691
(UNKNOWN)  SECUNIA  19691

- 漏洞信息

ADOdb for PHP 'tmssql.php'测试脚本动态代码求值漏洞
高危 未知
2006-01-09 00:00:00 2006-09-08 00:00:00
远程  
        ADOdb for PHP 4.70之前版本的tests/tmssql.php测试脚本中的动态代码求值漏洞(用在多个产品中,包括(1) Mantis、(2) PostNuke、(3) Moodle、(4) Cacti、(5) Xaraya、(6) PhpOpenChat,可能还有(7) MAXdev MD-Pro和(8) Simplog),远程攻击者可以通过保存在随后作为函数执行的变量中的do参数执行任意PHP函数,如使用phpinfo所示。

- 公告与补丁

        

- 漏洞信息

22291
ADOdb tmssql.php do Variable Arbitrary PHP Function Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public, Exploit Unknown Vendor Verified

- 漏洞描述

ADOdb contains a flaw that may allow a malicious user to execute arbitrary PHP functions via the 'do' parameter. The issue is triggered due to the insecure tests/tmssql.php test script. It is possible that the flaw may result in a loss of integrity.

- 时间线

2006-01-09 2005-12-30
2006-01-09 Unknow

- 解决方案

Upgrade to version 4.70 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround: remove adodb/tests/tmssql.php file.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站