CVE-2006-0105
CVSS5.0
发布时间 :2006-01-10 15:03:00
修订时间 :2011-03-07 21:29:20
NMCOS    

[原文]PostgreSQL 8.0.x before 8.0.6 and 8.1.x before 8.1.2, when running on Windows, allows remote attackers to cause a denial of service (postmaster exit and no new connections) via a large number of simultaneous connection requests.


[CNNVD]PostgreSQL 拒绝服务漏洞(CNNVD-200601-099)

        PostgreSQL存在拒绝服务漏洞,当运行在Windows上时,远程攻击者可以通过大量同时连接请求使系统拒绝服务。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:postgresql:postgresql:8.1.0
cpe:/a:postgresql:postgresql:8.0.2PostgreSQL PostgreSQL 8.0.2
cpe:/a:postgresql:postgresql:8.1.1PostgreSQL 8.1.1
cpe:/a:postgresql:postgresql:8.0PostgreSQL 8.0
cpe:/a:postgresql:postgresql:8.0.5PostgreSQL PostgreSQL 8.0.5
cpe:/a:postgresql:postgresql:8.0.4PostgreSQL PostgreSQL 8.0.4
cpe:/a:postgresql:postgresql:8.0.3PostgreSQL PostgreSQL 8.0.3
cpe:/a:postgresql:postgresql:8.0.1PostgreSQL PostgreSQL 8.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0105
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0105
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-099
(官方数据源) CNNVD

- 其它链接及资源

http://archives.postgresql.org/pgsql-announce/2006-01/msg00001.php
(PATCH)  MLIST  [pgsql-announce] 20060109 CRITICAL RELEASE: Minor Releases to Fix DoS Vulnerability
http://www.vupen.com/english/advisories/2006/0114
(UNKNOWN)  VUPEN  ADV-2006-0114
http://xforce.iss.net/xforce/xfdb/24049
(UNKNOWN)  XF  postgresql-connection-request-dos(24049)
http://www.securityfocus.com/bid/16201
(UNKNOWN)  BID  16201
http://www.securityfocus.com/archive/1/archive/1/421592/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060111 PostgreSQL security releases 8.0.6 and 8.1.2
http://www.postgresql.org/about/news.456
(UNKNOWN)  CONFIRM  http://www.postgresql.org/about/news.456
http://securitytracker.com/id?1015482
(UNKNOWN)  SECTRACK  1015482
http://securityreason.com/securityalert/327
(UNKNOWN)  SREASON  327
http://secunia.com/advisories/18419
(UNKNOWN)  SECUNIA  18419

- 漏洞信息

PostgreSQL 拒绝服务漏洞
中危 其他
2006-01-10 00:00:00 2006-01-11 00:00:00
远程  
        PostgreSQL存在拒绝服务漏洞,当运行在Windows上时,远程攻击者可以通过大量同时连接请求使系统拒绝服务。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        PostgreSQL PostgreSQL 8.0
        PostgreSQL postgresql-8.0.6.tar.gz
        http://wwwmaster.postgresql.org/download/mirrors-ftp?file=source/v8.0.
        6/postgresql-8.0.6.tar.gz
        PostgreSQL PostgreSQL 8.0.1
        PostgreSQL postgresql-8.0.6.tar.gz
        http://wwwmaster.postgresql.org/download/mirrors-ftp?file=source/v8.0.
        6/postgresql-8.0.6.tar.gz
        PostgreSQL PostgreSQL 8.0.2
        PostgreSQL postgresql-8.0.6.tar.gz
        http://wwwmaster.postgresql.org/download/mirrors-ftp?file=source/v8.0.
        6/postgresql-8.0.6.tar.gz
        PDGSoft Shopping Cart 8.1
        PostgreSQL postgresql-8.1.2.tar.gz
        http://wwwmaster.postgresql.org/download/mirrors-ftp?file=source/v8.1.
        2/postgresql-8.1.2.tar.gz

- 漏洞信息

22349
PostgreSQL Connection Saturation Service Shutdown DoS
Denial of Service
Loss of Availability Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2006-01-09 2005-12-22
2006-01-09 Unknow

- 解决方案

Upgrade to version 8.0.6, 8.1.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PostgreSQL Postmaster Denial Of Service Vulnerability
Failure to Handle Exceptional Conditions 16201
Yes No
2006-01-10 12:00:00 2006-01-11 04:50:00
This issue was disclosed by the vendor. The vendor credits Yoshiyuki Asaba with the discovery of this vulnerability.

- 受影响的程序版本

PostgreSQL PostgreSQL 8.0.2
+ Trustix Secure Linux 2.2
PostgreSQL PostgreSQL 8.0.1
PostgreSQL PostgreSQL 8.0
+ Trustix Secure Linux 2.2
PostgreSQL PostgreSQL 7.4.9
PostgreSQL PostgreSQL 7.4.8
PostgreSQL PostgreSQL 7.4.7
+ Gentoo Linux
+ S.u.S.E. Linux Personal 9.2 x86_64
+ S.u.S.E. Linux Personal 9.2
+ S.u.S.E. Linux Personal 9.1 x86_64
+ S.u.S.E. Linux Personal 9.1
+ Trustix Secure Linux 2.1
+ Ubuntu Ubuntu Linux 5.0 4 powerpc
+ Ubuntu Ubuntu Linux 5.0 4 i386
+ Ubuntu Ubuntu Linux 5.0 4 amd64
PostgreSQL PostgreSQL 7.4.6
+ Trustix Secure Linux 2.1
PostgreSQL PostgreSQL 7.4.5
+ Turbolinux Appliance Server 1.0 Workgroup Edition
+ Turbolinux Appliance Server 1.0 Hosting Edition
+ Turbolinux Appliance Server Hosting Edition 1.0
+ Turbolinux Appliance Server Workgroup Edition 1.0
+ Turbolinux Home
+ Turbolinux Turbolinux Desktop 10.0
+ Turbolinux Turbolinux Server 10.0
+ Turbolinux Turbolinux Server 9.0
+ Turbolinux Turbolinux Server 8.0
+ Turbolinux Turbolinux Server 7.0
+ Turbolinux Turbolinux Workstation 8.0
+ Turbolinux Turbolinux Workstation 7.0
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
PostgreSQL PostgreSQL 7.4.3
PostgreSQL PostgreSQL 7.4
PostgreSQL PostgreSQL 7.3.9
+ Red Hat Enterprise Linux AS 3
+ RedHat Desktop 3.0
+ RedHat Enterprise Linux ES 3
+ RedHat Enterprise Linux WS 3
+ S.u.S.E. Linux Personal 9.0 x86_64
+ S.u.S.E. Linux Personal 9.0
+ S.u.S.E. Linux Personal 8.2
PostgreSQL PostgreSQL 7.3.8
+ Trustix Secure Linux 2.0
PostgreSQL PostgreSQL 7.3.6
PostgreSQL PostgreSQL 7.3.4
+ OpenPKG OpenPKG Current
PostgreSQL PostgreSQL 7.3.3
+ OpenPKG OpenPKG Current
PostgreSQL PostgreSQL 7.3.2
+ Conectiva Linux 9.0
PostgreSQL PostgreSQL 7.3.1
+ OpenPKG OpenPKG 1.2
PostgreSQL PostgreSQL 7.3
PDGSoft Shopping Cart 8.1
PDGSoft Shopping Cart 8.1.2
PDGSoft Shopping Cart 8.0.6

- 不受影响的程序版本

PDGSoft Shopping Cart 8.1.2
PDGSoft Shopping Cart 8.0.6

- 漏洞讨论

PostgreSQL is prone to a denial of service vulnerability. This issue is due to a failure in the application to properly handle exceptional conditions.

A remote attacker can exploit this issue to crash the postmaster service, thus denying future connections until the service is manually restarted.

This issue only affects PostgreSQL for Microsoft Windows.

- 漏洞利用

No exploit is required.

- 解决方案

The vendor has released updated versions addressing this issue:


PostgreSQL PostgreSQL 8.0

PostgreSQL PostgreSQL 8.0.1

PostgreSQL PostgreSQL 8.0.2

PDGSoft Shopping Cart 8.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站