CVE-2006-0083
CVSS4.6
发布时间 :2006-01-09 15:03:00
修订时间 :2008-09-05 16:58:18
NMCOPS    

[原文]Format string vulnerability in the logging code of SMS Server Tools (smstools) 1.14.8 and earlier allows local users to execute arbitrary code via unspecified attack vectors.


[CNNVD]Stefan Frings SMS Server Tools本地格式化字符串漏洞(CNNVD-200601-078)

        SMS Server Tools (smstools) 1.14.8及更早版本的日志记录代码中存在格式化字符串漏洞,本地用户可以通过未指定的攻击矢量执行任意代码。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0083
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0083
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-078
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/18357
(VENDOR_ADVISORY)  SECUNIA  18357
http://xforce.iss.net/xforce/xfdb/24034
(UNKNOWN)  XF  smstools-logging-format-string(24034)
http://www.securityfocus.com/bid/16188
(UNKNOWN)  BID  16188
http://www.osvdb.org/22287
(UNKNOWN)  OSVDB  22287
http://www.debian.org/security/2005/dsa-930
(UNKNOWN)  DEBIAN  DSA-930
http://secunia.com/advisories/18343
(VENDOR_ADVISORY)  SECUNIA  18343

- 漏洞信息

Stefan Frings SMS Server Tools本地格式化字符串漏洞
中危 格式化字符串
2006-01-09 00:00:00 2006-05-10 00:00:00
本地  
        SMS Server Tools (smstools) 1.14.8及更早版本的日志记录代码中存在格式化字符串漏洞,本地用户可以通过未指定的攻击矢量执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        NewLife Blogger NewLife Blogger 1.14.8
        Debian smstools_1.14.8-1sarge0_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.14.8-1sarge0_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_alpha.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.14.8-1sarge0_amd64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_amd64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.14.8-1sarge0_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_arm.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.14.8-1sarge0_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_hppa.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.14.8-1sarge0_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_i386.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.14.8-1sarge0_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_ia64.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.14.8-1sarge0_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_m68k.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.14.8-1sarge0_mips.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_mips.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.14.8-1sarge0_mipsel.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_powerpc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.14.8-1sarge0_s390.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_s390.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.14.8-1sarge0_sparc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main
        Debian smstools_1.14.8-1sarge0_sparc.deb
        Debian GNU/Linux 3.1 alias sarge
        http://security.debian.org/ stable/updates main/
        Debian smstools_1.5.0-2woody0_alpha.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0 -2woody0_alpha.deb
        Debian smstools_1.5.0-2woody0_arm.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0 -2woody0_arm.deb
        Debian smstools_1.5.0-2woody0_hppa.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0 -2woody0_hppa.deb
        Debian smstools_1.5.0-2woody0_i386.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0 -2woody0_i386.deb
        Debian smstools_1.5.0-2woody0_ia64.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0 -2woody0_ia64.deb
        Debian smstools_1.5.0-2woody0_m68k.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0 -2woody0_m68k.deb
        Debian smstools_1.5.0-2woody0_mips.de

- 漏洞信息 (F42966)

Debian Linux Security Advisory 930-2 (PacketStormID:F42966)
2006-01-11 00:00:00
Debian  debian.org
advisory,arbitrary,root
linux,debian
CVE-2006-0083
[点击下载]

Debian Security Advisory DSA 930-2 - Ulf Harnhammar from the Debian Security Audit project discovered a format string attack in the logging code of smstools, which may be exploited to execute arbitrary code with root privileges.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 930-2                     security@debian.org
http://www.debian.org/security/                                 Steve Kemp
January 10, 2006                        http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : smstools
Vulnerability  : format string attack
Problem-Type   : local
Debian-specific: no
CVE ID         : CVE-2006-0083

Ulf Harnhammar from the Debian Security Audit project discovered a
format string attack in the logging code of smstools, which may be
exploited to execute arbitary code with root privileges.

The original advisory for this issue said that the old stable
distribution (woody) was not affected because it did not contain
smstools. This was incorrect, and the only change in this updated
advisory is the inclusion of corrected packages for woody.

For the old stable distribution (woody) this problem has been fixed in
version 1.5.0-2woody0.

For the stable distribution (sarge) this problem has been fixed in
version 1.14.8-1sarge0.

For the unstable distribution the package will be updated shortly.

We recommend that you upgrade your smstools package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0.dsc
      Size/MD5 checksum:      595 3b125f8d494769561c579a2afb8eedf3
    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0.diff.gz
      Size/MD5 checksum:     7441 8fd87155404a99eb88ff06e5e7bccd4b
    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0.orig.tar.gz
      Size/MD5 checksum:    42987 0286109d2011a5b8ab2fbd2cda6085be

  Alpha architecture:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0_alpha.deb
      Size/MD5 checksum:    56840 8d84dd61b7002fbb5f5ff1411345cdf6

  ARM architecture:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0_arm.deb
      Size/MD5 checksum:    44604 af22b10857060a0fe0f1db651ea54689

  Intel IA-32 architecture:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0_i386.deb
      Size/MD5 checksum:    43106 af2b3c3a8a18d71481fbadeef60846f8

  Intel IA-64 architecture:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0_ia64.deb
      Size/MD5 checksum:    74424 96904451a1a06e22d4fcee797dc68450

  HP Precision architecture:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0_hppa.deb
      Size/MD5 checksum:    44432 70d55071bbdf08f2d3265da85cb43458

  Motorola 680x0 architecture:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0_m68k.deb
      Size/MD5 checksum:    41598 d25cce8dcfed54f7f9b62e7764775907

  Big endian MIPS architecture:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0_mips.deb
      Size/MD5 checksum:    52646 2edd9efcca5f608c09d6903335d7dc14

  Little endian MIPS architecture:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0_mipsel.deb
      Size/MD5 checksum:    52290 5f019a902c94b8d4c0a6b9781afa2664

  PowerPC architecture:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0_powerpc.deb
      Size/MD5 checksum:    43316 df4f00d5ccc813274a3936455ff39b70

  IBM S/390 architecture:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0_s390.deb
      Size/MD5 checksum:    43812 9e6f27fb09a8e1152db4238eb851b659

  Sun Sparc architecture:

    http://security.debian.org/pool/updates/main/s/smstools/smstools_1.5.0-2woody0_sparc.deb
      Size/MD5 checksum:    51388 d98ca0bc6bbeecb8d19e630528c6fd9f

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iQCVAwUBQ8O64A0hVr09l8FJAQJktAP+Lz1FQMEN7DDexdkjHCmr4i7ppBNBc37v
OIaWqECUgdo6HaKuwVxqI3MQ/w0knMydjM3h4/KygnAQUlesol5Egd9WhiVxO7BH
nmaVedl8tiQM6mtCmTKlVw9dlEtykGUdYYC3qXtPV3suzuqsDLtPlTfKmQWqevy6
V0TLiivO8m4=
=HaD3
-----END PGP SIGNATURE-----

    

- 漏洞信息 (F42924)

Debian Linux Security Advisory 930-1 (PacketStormID:F42924)
2006-01-10 00:00:00
Debian  debian.org
advisory,arbitrary,root
linux,debian
CVE-2006-0083
[点击下载]

Debian Security Advisory DSA 930-1 - Ulf Harnhammar from the Debian Security Audit project discovered a format string attack in the logging code of smstools, which may be exploited to execute arbitrary code with root privileges.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 930-1                     security@debian.org
http://www.debian.org/security/                                 Steve Kemp
Jan 9, 2006                             http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Vulnerability  : format string attack
Problem-Type   : local
Debian-specific: no
CVE ID         : CVE-2006-0083

Ulf Harnhammar from the Debian Security Audit project discovered a
format string attack in the logging code of smstools, which may be
exploited to execute arbitary code with root privileges.

The old stable distribution (woody) does not contain smstools package.

For the stable distribution (sarge) this problem has been fixed in
version 1.14.8-1sarge0.

For the unstable distribution the package will be updated shortly.

We recommend that you upgrade your smstools package.


Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.


Debian GNU/Linux 3.1 alias sarge
- --------------------------------

  Source archives:

    smstools_1.14.8-1sarge0.diff.gz
      Size/MD5 checksum:     5106 ef55852ce6da003ef5f45df6eed1a8c5
    smstools_1.14.8-1sarge0.dsc
      Size/MD5 checksum:      624 1e69b0c4a20ce7f08bce8a8b51b8504d
    smstools_1.14.8.orig.tar.gz
      Size/MD5 checksum:   158423 85b342e53d7fdde89ef25ad21e1c5fe0

  Alpha architecture:

    smstools_1.14.8-1sarge0_alpha.deb
      Size/MD5 checksum:   184268 59ca41ecd61cc94de2b63c8698464732

  AMD64 architecture:

    smstools_1.14.8-1sarge0_amd64.deb
      Size/MD5 checksum:   178130 f957b798e9de3075e013521bbf6241d6

  ARM architecture:

    smstools_1.14.8-1sarge0_arm.deb
      Size/MD5 checksum:   173506 aa2b0df1d47ad50070aebacc266f729d

  HP Precision architecture:

    smstools_1.14.8-1sarge0_hppa.deb
      Size/MD5 checksum:   180032 168dba93586bc10214fbb6a5914f962e

  Intel IA-32 architecture:

    smstools_1.14.8-1sarge0_i386.deb
      Size/MD5 checksum:   166816 aee3afc84707f7190c255ed3739c2958

  Intel IA-64 architecture:

    smstools_1.14.8-1sarge0_ia64.deb
      Size/MD5 checksum:   201440 9868ead0f8885bc3851137b23d76877d

  Motorola 680x0 architecture:

    smstools_1.14.8-1sarge0_m68k.deb
      Size/MD5 checksum:   166452 d713ee667bee3c3186ba477f9d0f91a8

  Big endian MIPS architecture:

    smstools_1.14.8-1sarge0_mips.deb
      Size/MD5 checksum:   182332 846d0a829680db2b3662982c9fe49d4f

  Little endian MIPS architecture:

    smstools_1.14.8-1sarge0_mipsel.deb
      Size/MD5 checksum:   182004 db7200f1504ea22681e23e749435c22a

  PowerPC architecture:

    smstools_1.14.8-1sarge0_powerpc.deb
      Size/MD5 checksum:   172100 183e00f44548fce56df228441593bb90

  IBM S/390 architecture:

    smstools_1.14.8-1sarge0_s390.deb
      Size/MD5 checksum:   179978 ab77f608c71a908bc51e7781b51c416d

  Sun Sparc architecture:

    smstools_1.14.8-1sarge0_sparc.deb
      Size/MD5 checksum:   175994 a03ff752a8910e397e73f53649c5a931

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb http://security.debian.org/ stable/updates main
For dpkg-ftp: ftp://security.debian.org/debian-security dists/stable/updates/main
Mailing list: debian-security-announce@lists.debian.org
Package info: `apt-cache show <pkg>' and http://packages.debian.org/<pkg>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)

iQCVAwUBQ8JqBw0hVr09l8FJAQJy/gP/UZSH1kGcChkhTtfJpoKg3nlY+J/52zz/
ntrygXJXVHOcVd6RJmtquhhKEaQ1z9Z2e3m4EEXKC4AIIO2xtT0hKvMogWgO9khV
aF/OPBOI5xhwxqMzdRHE9aUwvEfgjITKwsvF+kU1TSJQpqqxYXmdW0CiTfiWJujy
FMeeVok9jHM=
=6NPA
-----END PGP SIGNATURE-----

    

- 漏洞信息

22287
SMS Server Tools Logging Function Local Format String
Local Access Required, Local / Remote, Context Dependent Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

SMS Server Tools contains a flaw that may allow a malicious user to execute arbitrary code. The issue is triggered by the logging of malicious user input in some error messages. It is possible that the flaw may allow arbitrary code execution with increased privileges resulting in a loss of integrity.

- 时间线

2006-01-09 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

Stefan Frings SMS Server Tools Local Format String Vulnerability
Input Validation Error 16188
No Yes
2006-01-09 12:00:00 2006-07-05 06:49:00
Ulf Harnhammar from the Debian Security Audit project discovered this vulnerability.

- 受影响的程序版本

NewLife Blogger NewLife Blogger 1.14.8
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0

- 漏洞讨论

A local format-string vulnerability affects Stefan Frings SMS Server Tools.

The problem presents itself when the affected application tries to log messages using a formatted-print function. The application fails to properly sanitize user-supplied input before including it in the format-specifier argument of a formatted-print function.

An attacker may leverage this issue to execute arbitrary code with superuser privileges, ultimately facilitating privilege escalation.

Version 1.14.8 of SMS Server Tools is vulnerable to this issue; other versions may also be affected.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

Please see the referenced advisories for more information.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.commailto:vuldb@securityfocus.com.


NewLife Blogger NewLife Blogger 1.14.8

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站