CVE-2006-0077
CVSS2.1
发布时间 :2006-01-03 20:03:00
修订时间 :2011-03-07 21:29:15
NMCO    

[原文]Off-by-one error in the getfattr function in File::ExtAttr before 0.03 allows attackers to trigger a buffer overflow via unspecified attack vectors.


[CNNVD]ExtAttr扩展的文件属性Off-By-One缓冲区溢出漏洞(CNNVD-200601-007)

        File::ExtAttr 0.03之前版本的getfattr函数中的Off-by-one错误,可让攻击者通过未指定的攻击矢量触发缓冲区溢出。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:richard_dawe:file_extattr:0.1
cpe:/a:richard_dawe:file_extattr:0.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0077
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0077
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200601-007
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/16118
(PATCH)  BID  16118
http://sourceforge.net/project/shownotes.php?release_id=382199&group_id=153116
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=382199&group_id=153116
http://secunia.com/advisories/18253
(VENDOR_ADVISORY)  SECUNIA  18253
http://www.vupen.com/english/advisories/2006/0013
(UNKNOWN)  VUPEN  ADV-2006-0013
http://www.osvdb.org/22160
(UNKNOWN)  OSVDB  22160

- 漏洞信息

ExtAttr扩展的文件属性Off-By-One缓冲区溢出漏洞
低危 缓冲区溢出
2006-01-03 00:00:00 2006-01-05 00:00:00
本地  
        File::ExtAttr 0.03之前版本的getfattr函数中的Off-by-one错误,可让攻击者通过未指定的攻击矢量触发缓冲区溢出。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        File::ExtAttr File::ExtAttr 0.1
        File::ExtAttr File::ExtAttr 0.03
        http://sourceforge.net/project/showfiles.php?group_id=153116&package_i
        d=169603&release_id=382199
        File::ExtAttr File::ExtAttr 0.2
        File::ExtAttr File::ExtAttr 0.03
        http://sourceforge.net/project/showfiles.php?group_id=153116&package_i
        d=169603&release_id=382199

- 漏洞信息

22160
File::ExtAttr XS getfattr() Overflow
Local Access Required Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Unknown Vendor Verified

- 漏洞描述

A local overflow exists in the File::ExtAttr perl module. The getfattr function fails to correctly validate the length of special attributes of files resulting in an off-by-one overflow. With a specially crafted file, an attacker can cause perl to crash resulting in a loss of availability.

- 时间线

2006-01-01 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.03 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站