CVE-2006-0059
CVSS7.5
发布时间 :2006-05-19 15:02:00
修订时间 :2011-03-07 21:29:14
NMCOS    

[原文]Heap-based buffer overflow in the ISO Transport Service over TCP (RFC 1006) implementation of LiveData ICCP Server before 5.00.035 allows remote attackers to cause a denial of service or execute arbitrary code via malformed packets.


[CNNVD]LiveData ICCP ISO Transport Service over TCP implementation 溢出漏洞(CNNVD-200605-376)

        LiveData ICCP Server 5.00.035之前版本的ISO Transport Service over TCP (RFC 1006) implementation存在基于堆的缓冲区溢出。远程攻击者可以借助畸形数据包引起拒绝服务或执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0059
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0059
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200605-376
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/190617
(PATCH)  CERT-VN  VU#190617
http://www.vupen.com/english/advisories/2006/1830
(UNKNOWN)  VUPEN  ADV-2006-1830
http://www.kb.cert.org/vuls/id/JGEI-6MMS9T
(UNKNOWN)  MISC  http://www.kb.cert.org/vuls/id/JGEI-6MMS9T
http://xforce.iss.net/xforce/xfdb/26490
(UNKNOWN)  XF  livedata-iccp-rfc1006-bo(26490)
http://www.securityfocus.com/bid/18010
(UNKNOWN)  BID  18010
http://www.digitalbond.com/SCADA_Blog/2006/05/us-cert-livedata-iccp-vulnerability.html
(UNKNOWN)  MISC  http://www.digitalbond.com/SCADA_Blog/2006/05/us-cert-livedata-iccp-vulnerability.html
http://securitytracker.com/id?1016113
(UNKNOWN)  SECTRACK  1016113
http://secunia.com/advisories/20146
(UNKNOWN)  SECUNIA  20146

- 漏洞信息

LiveData ICCP ISO Transport Service over TCP implementation 溢出漏洞
高危 缓冲区溢出
2006-05-19 00:00:00 2006-05-19 00:00:00
远程  
        LiveData ICCP Server 5.00.035之前版本的ISO Transport Service over TCP (RFC 1006) implementation存在基于堆的缓冲区溢出。远程攻击者可以借助畸形数据包引起拒绝服务或执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        LiveData LiveData ICCP Server 5.0.34
        LiveData LiveData ICCP Server 5.00.039
        ftp://ftp.livedata.com/

- 漏洞信息

25576
LiveData ICCP Server TPTK Implementation Remote Overflow
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade

- 漏洞描述

LiveData ICCP Server contains an overflow condition in the RFC 1006 (ISO Transport Service on top of TCP) implementation. The issue is triggered as user-supplied input is not properly validated when parsing packet data. With a specially crafted request, a remote attacker can cause a heap-based buffer overflow, resulting in a denial of service or potentially execution of arbitrary code.

- 时间线

2006-05-17 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 5.00.035 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

LiveData ICCP Server Remote Heap Overflow Vulnerability
Boundary Condition Error 18010
Yes No
2006-05-17 12:00:00 2006-05-17 08:44:00
Discovery is credited to Matt Franz of Digital Bond Inc.

- 受影响的程序版本

LiveData LiveData ICCP Server 5.0.34
LiveData LiveData ICCP Server 5.0.39
LiveData LiveData ICCP Server 5.0.35

- 不受影响的程序版本

LiveData LiveData ICCP Server 5.0.39
LiveData LiveData ICCP Server 5.0.35

- 漏洞讨论

LiveData ICCP Server is susceptible to a remote heap-overflow vulnerability. This issue is due to the application's failure to properly bounds-check user-supplied input before copying it to an insufficiently sized memory buffer.

This issue allows remote attackers to crash a vulnerable server. Reports indicate that this issue does not allow attackers to execute arbitrary code, but this has not been confirmed.

LiveData ICCP Server versions prior to 5.00.035 are vulnerable.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

The vendor has released updates to address this issue. Versions 5.00.035 and subsequent are not vulnerable.


LiveData LiveData ICCP Server 5.0.34

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站