CVE-2006-0056
CVSS7.5
发布时间 :2006-02-13 06:06:00
修订时间 :2011-03-07 21:29:14
NMCOS    

[原文]Double free vulnerability in the authentication and authentication token alteration code in PAM-MySQL 0.6.x before 0.6.2 and 0.7.x before 0.7pre3 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via crafted passwords, which lead to a double free of a pointer that was created by the pam_get_item function. NOTE: this issue only occurs in certain configurations in which there are multiple PAM modules, PAM-MySQL is not evaluated first, and there are no requisite modules before PAM-MySQL.


[CNNVD]PAM-MySQL双重释放漏洞(CNNVD-200602-173)

        PAM-MySQL 0.6.2之前的0.6.x版以及0.7pre3之前的0.7.x版的认证和认证令牌更改代码中存在双重释放漏洞。远程攻击者可以借助特制密码(会导致由pam_get_item功能创建的指针双重释放)造成拒绝服务(应用程序崩溃),并可能执行任意代码。注意:只有在特定配置中才可能出现这个问题,即有多个PAM模块,不首先计算PAM-MySQL,而且在PAM-MySQL之前没有必要的模块。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: NONE [漏洞利用无需身份认证]

- CWE (弱点类目)

CWE-119 [内存缓冲区边界内操作的限制不恰当]

- CPE (受影响的平台与产品)

cpe:/a:pam-mysql:pam-mysql:0.6
cpe:/a:pam-mysql:pam-mysql:0.4
cpe:/a:pam-mysql:pam-mysql:0.7_pre1
cpe:/a:pam-mysql:pam-mysql:0.5
cpe:/a:pam-mysql:pam-mysql:0.7_pre2
cpe:/a:pam-mysql:pam-mysql:0.3
cpe:/a:pam-mysql:pam-mysql:0.4.7
cpe:/a:pam-mysql:pam-mysql:0.2
cpe:/a:pam-mysql:pam-mysql:0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0056
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0056
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200602-173
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/693909
(VENDOR_ADVISORY)  CERT-VN  VU#693909
http://www.securityfocus.com/bid/16564
(PATCH)  BID  16564
http://securitytracker.com/id?1015603
(PATCH)  SECTRACK  1015603
http://secunia.com/advisories/18598
(VENDOR_ADVISORY)  SECUNIA  18598
http://www.vupen.com/english/advisories/2006/0490
(UNKNOWN)  VUPEN  ADV-2006-0490
http://www.osvdb.org/22995
(UNKNOWN)  OSVDB  22995
http://www.osvdb.org/22994
(UNKNOWN)  OSVDB  22994
http://www.gentoo.org/security/en/glsa/glsa-200606-18.xml
(UNKNOWN)  GENTOO  GLSA-200606-18
http://sourceforge.net/forum/forum.php?forum_id=499394
(UNKNOWN)  CONFIRM  http://sourceforge.net/forum/forum.php?forum_id=499394
http://secunia.com/advisories/20690
(VENDOR_ADVISORY)  SECUNIA  20690
http://jvn.jp/cert/JVNVU%23693909/index.html
(UNKNOWN)  MISC  http://jvn.jp/cert/JVNVU%23693909/index.html

- 漏洞信息

PAM-MySQL双重释放漏洞
高危 资料不足
2006-02-13 00:00:00 2006-02-14 00:00:00
远程※本地  
        PAM-MySQL 0.6.2之前的0.6.x版以及0.7pre3之前的0.7.x版的认证和认证令牌更改代码中存在双重释放漏洞。远程攻击者可以借助特制密码(会导致由pam_get_item功能创建的指针双重释放)造成拒绝服务(应用程序崩溃),并可能执行任意代码。注意:只有在特定配置中才可能出现这个问题,即有多个PAM模块,不首先计算PAM-MySQL,而且在PAM-MySQL之前没有必要的模块。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        pam_mysql pam_mysql 0.5
        pam_mysql pam_mysql-0.6.2.tar.gz
        http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.6.2.tar.gz
        pam_mysql pam_mysql 0.7pre2
        pam_mysql pam_mysql-0.7pre3.tar.gz
        http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.7pre3.tar.gz
        pam_mysql pam_mysql 0.6
        pam_mysql pam_mysql-0.6.2.tar.gz
        http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.6.2.tar.gz
        pam_mysql pam_mysql 0.7pre1
        pam_mysql pam_mysql-0.7pre3.tar.gz
        http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.7pre3.tar.gz
        pam_mysql pam_mysql 0.1
        pam_mysql pam_mysql-0.6.2.tar.gz
        http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.6.2.tar.gz
        pam_mysql pam_mysql 0.2
        pam_mysql pam_mysql-0.6.2.tar.gz
        http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.6.2.tar.gz
        pam_mysql pam_mysql 0.3
        pam_mysql pam_mysql-0.6.2.tar.gz
        http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.6.2.tar.gz
        pam_mysql pam_mysql 0.4
        pam_mysql pam_mysql-0.6.2.tar.gz
        http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.6.2.tar.gz
        pam_mysql pam_mysql 0.4.7
        pam_mysql pam_mysql-0.6.2.tar.gz
        http://prdownloads.sourceforge.net/pam-mysql/pam_mysql-0.6.2.tar.gz

- 漏洞信息

22995
PAM-MySQL Authentication pam_get_item() Function Unspecified Privilege Escalation
Remote / Network Access Denial of Service, Input Manipulation
Loss of Integrity, Loss of Availability
Exploit Unknown Vendor Verified

- 漏洞描述

PAM-MySQL contains a flaw that may allow a malicious user to cause a double-free in the pam_get_item function. The issue is triggered when a malicious user sends crafted authentication credentials. It is possible that the flaw may cause the PAM-MySQL process to crash or allow arbitrary code execution resulting in a loss of integrity or availability.

- 时间线

2005-09-28 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.6.2 or 0.7pre3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PAM-MySQL Code Execution And Denial Of Service Vulnerabilities
Unknown 16564
Yes Yes
2006-02-09 12:00:00 2006-06-15 06:26:00
The vendor disclosed these issues.

- 受影响的程序版本

pam_mysql pam_mysql 0.4.7
pam_mysql pam_mysql 0.4
pam_mysql pam_mysql 0.3
pam_mysql pam_mysql 0.2
pam_mysql pam_mysql 0.1
pam_mysql pam_mysql 0.7pre2
pam_mysql pam_mysql 0.7pre1
pam_mysql pam_mysql 0.6
pam_mysql pam_mysql 0.5
Gentoo Linux
pam_mysql pam_mysql 0.6.2
pam_mysql pam_mysql 0.7pre3

- 不受影响的程序版本

pam_mysql pam_mysql 0.6.2
pam_mysql pam_mysql 0.7pre3

- 漏洞讨论

PAM-MySQL is susceptible to two vulnerabilities:

- a denial-of-service vulnerability in its logging facility
- a double-free vulnerability.

These issues allow local and remote attackers to execute arbitrary machine code in the context of the affected module. Attackers may also crash applications that use the PAM module, denying service to legitimate users. Applications that execute the PAM module with superuser privileges will allow attackers to completely compromise affected computers.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

The vendor has released versions 0.6.2 and 0.7pre3 of the affected package to address these issues.

Please see the referenced vendor advisories for more information.


pam_mysql pam_mysql 0.5

pam_mysql pam_mysql 0.7pre2

pam_mysql pam_mysql 0.6

pam_mysql pam_mysql 0.7pre1

pam_mysql pam_mysql 0.1

pam_mysql pam_mysql 0.2

pam_mysql pam_mysql 0.3

pam_mysql pam_mysql 0.4

pam_mysql pam_mysql 0.4.7

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站