CVE-2006-0051
CVSS5.1
发布时间 :2006-04-05 06:04:00
修订时间 :2011-03-07 21:29:13
NMCOS    

[原文]Buffer overflow in playlistimport.cpp in Kaffeine Player 0.4.2 through 0.7.1 allows user-assisted attackers to execute arbitrary code via long HTTP request headers when Kaffeine is "fetching remote playlists", which triggers the overflow in the http_peek function.


[CNNVD]Kaffeine http_peek()函数远程溢出漏洞(CNNVD-200604-045)

        Kaffeine是一款简单易用的媒体播放器,基于xine-lib,完全集成于KDE3。
        Kaffeine的http_peek()函数在创建HTTP请求首部获取远程播放列表时存在缓冲区溢出,在某些环境下可能导致应用程序崩溃或执行任意代码。

- CVSS (基础分值)

CVSS分值: 5.1 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:kaffeine:kaffeine_player:0.4.3b
cpe:/a:kaffeine:kaffeine_player:0.5_rc1
cpe:/a:kaffeine:kaffeine_player:0.7.1
cpe:/a:kaffeine:kaffeine_player:0.4.3
cpe:/a:kaffeine:kaffeine_player:0.4.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2006-0051
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2006-0051
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200604-045
(官方数据源) CNNVD

- 其它链接及资源

http://www.kde.org/info/security/advisory-20060404-1.txt
(VENDOR_ADVISORY)  CONFIRM  http://www.kde.org/info/security/advisory-20060404-1.txt
http://secunia.com/advisories/19525
(VENDOR_ADVISORY)  SECUNIA  19525
http://xforce.iss.net/xforce/xfdb/25631
(UNKNOWN)  XF  kaffeine-http-peek-bo(25631)
http://www.vupen.com/english/advisories/2006/1229
(UNKNOWN)  VUPEN  ADV-2006-1229
http://www.ubuntulinux.org/support/documentation/usn/usn-268-1
(UNKNOWN)  UBUNTU  USN-268-1
http://www.securityfocus.com/bid/17372
(UNKNOWN)  BID  17372
http://www.securityfocus.com/archive/1/archive/1/430319/100/0/threaded
(UNKNOWN)  BUGTRAQ  20060405 [Kaffeine Security Advisory] Heap based buffer overflow in http_peek()
http://www.novell.com/linux/security/advisories/2006_08_sr.html
(UNKNOWN)  SUSE  SUSE-SR:2006:008
http://www.gentoo.org/security/en/glsa/glsa-200604-04.xml
(UNKNOWN)  GENTOO  GLSA-200604-04
http://www.debian.org/security/2006/dsa-1023
(UNKNOWN)  DEBIAN  DSA-1023
http://securitytracker.com/id?1015863
(UNKNOWN)  SECTRACK  1015863
http://secunia.com/advisories/19571
(UNKNOWN)  SECUNIA  19571
http://secunia.com/advisories/19557
(UNKNOWN)  SECUNIA  19557
http://secunia.com/advisories/19549
(UNKNOWN)  SECUNIA  19549
http://secunia.com/advisories/19542
(UNKNOWN)  SECUNIA  19542
http://secunia.com/advisories/19540
(UNKNOWN)  SECUNIA  19540
http://www.mandriva.com/security/advisories?name=MDKSA-2006:065
(UNKNOWN)  MANDRIVA  MDKSA-2006:065

- 漏洞信息

Kaffeine http_peek()函数远程溢出漏洞
中危 缓冲区溢出
2006-04-05 00:00:00 2006-09-21 00:00:00
远程  
        Kaffeine是一款简单易用的媒体播放器,基于xine-lib,完全集成于KDE3。
        Kaffeine的http_peek()函数在创建HTTP请求首部获取远程播放列表时存在缓冲区溢出,在某些环境下可能导致应用程序崩溃或执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Kaffeine Media Player 0.7
        Mandriva kaffeine-0.7-6.1.20060mdk.i586.rpm
        Mandriva Linux 2006.0:
        http://wwwnew.mandriva.com/en/downloads/
        Mandriva kaffeine-0.7-6.1.20060mdk.x86_64.rpm
        Mandriva Linux 2006.0/X86_64:
        http://wwwnew.mandriva.com/en/downloads/
        Mandriva lib64kaffeine0-0.7-6.1.20060mdk.x86_64.rpm
        Mandriva Linux 2006.0/X86_64:
        http://wwwnew.mandriva.com/en/downloads/
        Mandriva lib64kaffeine0-devel-0.7-6.1.20060mdk.x86_64.rpm
        Mandriva Linux 2006.0/X86_64:
        http://wwwnew.mandriva.com/en/downloads/
        Mandriva libkaffeine0-0.7-6.1.20060mdk.i586.rpm
        Mandriva Linux 2006.0:
        http://wwwnew.mandriva.com/en/downloads/
        Mandriva libkaffeine0-devel-0.7-6.1.20060mdk.i586.rpm
        Mandriva Linux 2006.0:
        http://wwwnew.mandriva.com/en/downloads/
        Kaffeine Media Player 0.4.2
        Kaffeine kaffeine-0.8.1.tar.bz2
        http://prdownloads.sourceforge.net/kaffeine/kaffeine-0.8.1.tar.bz2?dow nload
        KDE kaffeine-0.4.x-CVE-2006-0051.patch
        ftp://ftp.kde.org/pub/kde/security_patches/kaffeine-0.4.x-CVE-2006-005 1.patch
        Kaffeine Media Player 0.4.3 b
        Kaffeine kaffeine-0.8.1.tar.bz2
        http://prdownloads.sourceforge.net/kaffeine/kaffeine-0.8.1.tar.bz2?dow nload
        KDE kaffeine-0.4.x-CVE-2006-0051.patch
        ftp://ftp.kde.org/pub/kde/security_patches/kaffeine-0.4.x-CVE-2006-005 1.patch
        Kaffeine Media Player 0.4.3
        Kaffeine kaffeine-0.8.1.tar.bz2
        http://prdownloads.sourceforge.net/kaffeine/kaffeine-0.8.1.tar.bz2?dow nload
        KDE kaffeine-0.4.x-CVE-2006-0051.patch
        ftp://ftp.kde.org/pub/kde/security_patches/kaffeine-0.4.x-CVE-2006-005 1.patch
        Kaffeine Media Player 0.5 rc1
        Kaffeine kaffeine-0.8.1.tar.bz2
        http://prdownloads.sourceforge.net/kaffeine/kaffeine-0.8.1.tar.bz2?dow nload
        KDE kaffeine-0.5.x-CVE-2006-0051.patch
        ftp://ftp.kde.org/pub/kde/security_patches/kaffeine-0.5.x-CVE-2006-005 1.patch
        Kaffeine Media Player 0.7.1
        Kaffeine kaffeine-0.8.1.tar.bz2
        http://prdownloads.sourceforge.net/kaffeine/kaffeine-0.8.1.tar.bz2?dow nload
        KDE kaffeine-0.7.x-CVE-2006-0051.patch
        ftp://ftp.kde.org/pub/kde/security_patches/kaffeine-0.7.x-CVE-2006-005 1.patch
        

- 漏洞信息

24377
Kaffeine Player http_peek() Function Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2006-04-04 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Kaffeine Remote HTTP_Peek Buffer Overflow Vulnerability
Boundary Condition Error 17372
Yes No
2006-04-04 12:00:00 2006-06-27 03:20:00
Discovery of this issue is credited to Marcus Meissner.

- 受影响的程序版本

Ubuntu Ubuntu Linux 5.10 powerpc
Ubuntu Ubuntu Linux 5.10 i386
Ubuntu Ubuntu Linux 5.10 amd64
Ubuntu Ubuntu Linux 5.0 4 powerpc
Ubuntu Ubuntu Linux 5.0 4 i386
Ubuntu Ubuntu Linux 5.0 4 amd64
S.u.S.E. Linux Professional 10.0 OSS
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Personal 10.0 OSS
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
Mandriva Linux Mandrake 2006.0 x86_64
Mandriva Linux Mandrake 2006.0
Kaffeine Media Player 0.7.1
Kaffeine Media Player 0.5 rc1
Kaffeine Media Player 0.4.3 b
Kaffeine Media Player 0.4.3
Kaffeine Media Player 0.4.2
Kaffeine Media Player 0.7
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Conectiva Linux 10.0
Kaffeine Media Player 0.8

- 不受影响的程序版本

Kaffeine Media Player 0.8

- 漏洞讨论

Kaffiene is reportedly affected by a remote buffer-overflow vulnerability because the application fails to perform sufficient boundary checks on user-supplied strings before copying them into finite stack-based buffers.

An attacker can leverage this issue remotely to execute arbitrary code on an affected computer with the privileges of an unsuspecting user that executed the vulnerable software.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com

- 解决方案

The vendor has released a security advisory along with an updated version of Kaffeine and patches to address this issue.

Please see the referenced advisories for more information.


Kaffeine Media Player 0.7

Kaffeine Media Player 0.4.2

Kaffeine Media Player 0.4.3 b

Kaffeine Media Player 0.4.3

Kaffeine Media Player 0.5 rc1

Kaffeine Media Player 0.7.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站